'dpkg --configure -a' problem when trying to run Synaptic

Created by Vojtěch Trefný on on 2008-01-22
Keywords:
dpkg synaptic install update extra programs error
Last updated by:
Nick Ellery on on 2008-06-13

When I try to install something or update I get this error message:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

To correct this problem just open Terminal (Applications → Accessories → Terminal) and type:
sudo dpkg --configure -a

Give your user password when requested. You will not see anything, but type it and press enter.

Then retry to update and/or to install desired package.