Compiz Fusion dosn't work in my Ubuntu 8.04

Asked by Алексей on 2008-05-10

HDD 40 GB IDE U-ATA/100 casche 2Mb 7200 rpm. CD: NEC CD-RW 52x/52x/32x IDE NR-9500B
Memory: Apacer DIMM DDR-400 256MB. Intel Celeron D-EM64T 326 2533 MHz. Motherboard: MSI SIS Socket 775 LGA with
integrated video card 16 MB. Monitor Acer 1716B.GeForce 5200,128 Mb videocard with proprietary drivers.

   I renewed my Ubuntu 7.10 at 8.04 successfully. And then I tried to initiate Compiz Fusion, but it doesn't work.I installed compizconfig-settings-manager but the same result. I made "sudo apt-get install xserver-xgl" ( as recommended from question #20530 ) command but it makes me worse during booting procedure how it seems for me. No results. I wanted deinstall "xserver-xgl" but after command 'sudo apt-get --purge remove xserver-xgl' it writes:
                                                    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
Aftercommand 'sudo apt-get remove xserver-xgl' all the same.At this point i don't undestand what i must do.Is it means type the command: dpkg --configure -a, at a terminal? I'm afraid to make something wrong again after all .
 After this manipulating the new nice 8.04's effect of blinking by Mozilla FireFox and Evolution label dissapiared for my despair.I would be glad to get back primary state of my system without Compiz .
Synaptric manager and all commands "apt-get upgrade, ..." doesn't work and answer the same report:
                                                    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
Also E: _cache->open() failed, please report. ( from Synaptic)

"E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem."

Just open terminal (Applications→Accesories→Terminal) and run "sudo dpkg --configure -a" (without quotation marks).

Vojtěch Trefný suggests this article as an answer to your question:
FAQ #52: “Can't install new software and updates”.

Алексей (colovrat) said : #3

                       Hi, Vojtěch Trefný ! Thank you for your answer very much !! I made it. The 34 packages were tuning. At the bottom line was written:
                                                                    " Processing triggers for libc6 ...
                                                                     ldconfig deferred processing now taking place"
                       As i andastand after I yersterday had downloaded renewed packages they wasn't installed ( the process run very hardly and was often interrupted). The command "sudo dpkg --configure -a" do they installed. Must I run command:

                                                                                                       sudo apt-get install -f ,

as it recommended in FAQ #52 :
                                         " Then to dress pending packages please type:
                                                                                           sudo apt-get install -f "

   The Synaptic works at present I have checked.

Алексей (colovrat) said : #4

I made "sudo apt-get install -f" myself it was not any trouble.
 Thank you Vojtěch Trefný very much for help.

Алексей (colovrat) said : #5

Thanks Vojtěch Trefný, that solved my question.