package update-manager 1:0.87.27 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)

Asked by Nathan Adams on 2008-06-13

Binary package hint: update-manager

This results in:

Could not install the upgrades

The upgrade aborts now. Your system could be in an unusable state. A recovery will run now (dpkg --configure -a).

ProblemType: Package
Architecture: amd64
Date: Fri Jun 13 08:42:30 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)

NonfreeKernelModules: nvidia
Package: update-manager 1:0.87.27
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.87.27 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): E:Sub-process /usr/bin/dpkg returned an error code (1)
Uname: Linux 2.6.22-14-generic x86_64

Nathan Adams (nadams) said : #1
Nathan Adams (nadams) said : #2
Nathan Adams (nadams) said : #3

See also bug #239741

Thanks for reporting, but this is not a real bug, so I'm converting this to question...

Vojtěch Trefný suggests this article as an answer to your question:
FAQ #52: “'dpkg --configure -a' problem when trying to run Synaptic”.

To solve your problem just open Terminal (Applications→Accesories→Terminal) and type "sudo dpkg --configure -a" (without quotation marks).

Can you help with this problem?

Provide an answer of your own, or ask Nathan Adams for more information if necessary.

To post a message you must log in.