synaptic error dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem

Asked by orion on 2008-02-28

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

Best Riku Eskelinen (kingi89) said : #1

Hi Orion and thanks for your question.

It seems that you have closed package manager (such as Synaptic, Add&Remove Programs, Adept...) before it was ready to be closed - ie. you closed it or it crashed before the installation was complete. You can recover from this by opening your terminal (Gnome: Applications » Utilities » Terminal, KDE: K » System » Konsole) and typing following lines to it one by one:
sudo dpkg --configure -a
sudo apt-get -f install

When you confirm the first line by pressing Enter, you'll see a "Password:" prompt asking for your password. You will not see dots or stars as feedback while typing. When done, press Enter to continue.
If this doesn't solve your problem, please let us know.

NOTE: If this solves your problem, do not forget to mark this question as Solved. Thank you.

orion (crazyhorse1660) said : #2

ok
I got synaptic to start and not close but I get another error message; You have 1 broken package on your system!

Use the "Broken" filter to locate it.
However I cant find any "broken" filter.

Any ideas?
thanx

orion (crazyhorse1660) said : #3

Thanks Riku Eskelinen, that solved my question.

orion (crazyhorse1660) said : #4

You are a genius!

Vojtěch Trefný suggests this article as an answer to your question:
FAQ #52: “Can't install new software and updates”.

marca311 (mail-marcd) said : #6

that didn't work

marca311 (mail-marcd) said : #7

that didn't work

marca311 (mail-marcd) said : #8

I still get the same message

marca311

Please don't append a new question on a marked as solved question.
Please make new question from here: https://answers.launchpad.net/ubuntu/+addquestion
you will get better chance to get right answer on a fresh tagged "open" question.
Solved question are usually not read from answering people.

Thank you