installing updates

Asked by Enrique de Llano on 2008-05-18

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report

ProblemType: Bug
Architecture: i386
Date: Sun May 18 14:23:10 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/gnome-terminal
Package: gnome-terminal 2.22.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
Uname: Linux 2.6.24-16-generic i686

Enrique de Llano (endell081) said : #1
Nick Ellery (nick.ellery) said : #2

Hi, I don't believe that this is a bug... just a support problem.
Enter this into a terminal:
sudo dpkg --configure -a

and it should be fixed. Please post if it was or wasn't.

Thanks for reporting, but this is not a bug, so I'm converting this to a question...

Vojtěch Trefný suggests this article as an answer to your question:
FAQ #52: “Can't install new software and updates”.

To solve your problem just open terminal (Applications→Accesories→Terminal) and run "sudo dpkg --configure -a" (without quotation marks).

Enrique de Llano (endell081) said : #6

Thonks Vojtech Trefny and Nick Ellery. Your solution solve my problem.

Enrique de Llano (endell081) said : #7

Thanks Vojtěch Trefný, that solved my question.