Cannot install Updates or anything

Asked by Raman on 2008-03-26

Hey i am unable to install automatic updates or install any app from add and remove.
the error i get is

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.

I am totally new to linux. I dont know anything about it. So, please explain in detail so that i can understand.

Thanx.

Kevin (kevinrs91) said : #1

try go to system --> Administration --> Synaptic Package Manager --> edit --> fix broken packages

Vojtěch Trefný suggests this article as an answer to your question:
FAQ #52: “Can't install new software and updates”.

Open Terminal (Applications→Accesories→Terminal) and type "sudo dpkg --configure -a" (without quotation marks).

Raman (raman-preet30) said : #4

Thnx vojtech but it worked for the first time and from second time it is giving same problem. wen i try to run the same command it starts somthing else. And Synaptic Package Manager is also giving the same error.

Old_Soldier (charles.davis) said : #5

sudo dpkg --configure -a
sudo apt-get install -f

Raman (raman-preet30) said : #6

thnx ppl

shoshanna (mdwlndslinda) said : #7

I've tried the sudo dpkg--congfigure-a and sudo apt-get install-f and I get the message command not found