Synaptic Package manager/Add Remove Sftware

Asked by june on 2008-01-26

I'm new with ubuntu, I can't open the synaptic package manager and i can't add program. I got this message:

  E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
  E: _cache->open() failed, please report.

can anyone help me with this.

thanks in advance.
june

Vojtěch Trefný suggests this article as an answer to your question:
FAQ #52: “Can't install new software and updates”.

please try running

sudo dpkg --configure -a

in a terminal

let it do its stuff and then try installing other things

june (june0669) said : #3

hi sam

i tried that and it works but still i got this message:

You have 1 broken package on your system!

Use the "Broken" filter to locate i

where i can find the "Broken"?

june.

where i can find the "Broken"?

→ Synaptic → Custon Filters (left botoom corner) → Broken

If you look around in synaptic there is also a ´fix broken packages´ option.

try running

aptitude -f install or aptitude -f remove

maybe correct the problem

june (june0669) said : #7

Thanks Vojtěch Trefný, that solved my question.

june (june0669) said : #8

thanks sam, that solved my problem.

sidney adams (adams1936) said : #9

maby I should add some detail. first I open a web broswer, open a connection then goto add/remove programs. A pop up window tells me I need to have a web connection. informs me my packages are out of date then hanges my computer. I then have to push the reset button on my p.c. and start all over again. also I have to use the kppp modem setup, the the other modem setup program dosn't work for me. but thats just fine.I prefer the kppp setup anyway. Im new to ubuntu, when I learn my way around I think it will work out just fine.
sidney adams.

@ sidney adams
Please don't append a new question on a already answered or marked as solved question.
Please make new question from here: https://answers.launchpad.net/ubuntu/+addquestion
you will get better chance to get right answer on a fresh tagged "open" question.
Solved or answered questions are usually not read from answering people.

Thank you