Failed to load module "type1"

Asked by Sam_ on 2008-06-20

Hi,
since I have this message showing up everytime in the Xorg.0.log [Hardy LTS 8.04]
(II) LoadModule: "type1"
(WW) Warning, couldn't open module type1
(II) UnloadModule: "type1"
(EE) Failed to load module "type1" (module does not exist, 0)
and I've read the xorg mailing list
http://lists.freedesktop.org/archives/xorg/2007-August/027486.html
I wonder if anyone could provide steps to get rid of this module message or tell me if it helps to just remove the line in Section "Module" in the xorg.conf to get rid of "type1".
I'm far away to be a hacker, therefore I'll appreciate an easy to understand description of commands. Thanks a lot in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2008-08-04
Last query:
2008-08-04
Last reply:
2008-08-03
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

mysteryweapon (leskop) said : #2

mysteryweapon suggests this article as an answer to your question:

Actually I couldn't figure out how to reply to this question. So here goes:
I noticed this happens in my debian box. If I run:

  apt-get purge type1inst
  apt-get install type1inst

This seems to fix the problem, although I'm not sure why I have to reinstall this package. It seems like a bug to me. The other symptom that I've experienced is my mouse cursor disappears when it would normally go into a "half pointer, half spinning wait icon" It makes it very frustrating to use the computer when my mouse keeps disappearing. I hope this helps you
FAQ #52: “'dpkg --configure -a' problem when trying to run Synaptic”.

Sam_ (and-sam) said : #3

Hi,
thanks I appreciate your answer, but the command doesn't work here.
I've decided to wait until developers reorganize Xorg.
And sorry, I don't know what a disappearing mouse cursor and Faq 52 have to do with type1?

mysteryweapon (leskop) said : #4

Faq 52 has nothing to do with it. If you read the beginning of my message:

Actually I couldn't figure out how to reply to this question...

I had to pick the "FAQ" option because the question was "expired" whatever that means. And no there is no relevant FAQ related to this.

Also, you must restart X for this to work, and it seems to only be a temporary fix anyway until you reboot.

Sam_ (and-sam) said : #5

Hi,
thanks for the reply and now understanding what you've meant it'd be a good question on how to answer an expired question.
At the end of the day, I guess we "the common user" won't solve the type1 issue.
For not annoying anyone I'll mark it as solved, although it belongs to wishlist.