Whenever I try to install a program it says run manually "dpkg --configure -a"

Asked by heckman on 2008-08-15

Binary package hint: isns

I don't know if it's a bug, however, it happens repetitively, and it will not let me do anything in "Add/Remove". Nor can I download anything from the internet or seperate disks. I have tried re-installing the OS multiple times.

Nick Ellery (nick.ellery) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs .

Nick Ellery (nick.ellery) said : #2

Nick Ellery suggests this article as an answer to your question:
FAQ #52: “'dpkg --configure -a' problem when trying to run Synaptic”.

Al Constable (w7wp2) said : #3

I have the same Error message problem. It is repetitive. It only happens when I use Update Manager on my 8.04 ver. of Ubuntu. If I follow the instructions and type dpkg --configure -a everything is fine. I don't think this error message should pop up so often.

Yolanda Quinones (yolyquin) said : #4

I'm having a similar problem with update manager. I've been looking at the FAQ's and have found it's a common error but when i try to correct by going to application-->accesseries-->terminal and enter the dpkg--configure-a' I get a command not found message.

@ Yolanda please take care of spaces when you type the command:

sudo <space> dpkg <space> --configure <space> -a

Then please also read below...

------------------------------------------------------------------

The "dpkg --configure -a" is asked by the system when a previous update/upgrade process have not completely performed good, and it must run with "root" privileged administrative user.
Using the "sudo" command we can do a command as "root" user, and "dpkg --configure -a" need be run from root user.
After the "dpkg --configure -a" command i add all the usual commands (see below) you can run to be sure your system became fully upgraded.

Typing the commands as sudo the system will ask you for a password, please give your user password when requested, you don't see nothing when you type it, then press enter.

So please be sure your system is fully updated/upgraded with no pending packages or errors:

Open a Terminal from the menu Applications → Accessories → Terminal and type:
(when the system ask you a password give your user password, you will not see nothing when you type it, then press enter)

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get clean
sudo apt-get autoremove

Hope this helps

ganga (ganga253) said : #6

Whenever I try to install a program it says run manually "dpkg --configure -a"

Can you help with this problem?

Provide an answer of your own, or ask heckman for more information if necessary.

To post a message you must log in.