broken software index

Asked by John Wilson on 2008-02-03

This is what I get when I run it. It's still broken. Cannot install flash.

aliciadove@aliciadove:~$ sudo dpkg --configure -a
[sudo] password for aliciadove:
Setting up perl-modules (5.8.8-12ubuntu0.4) ...
dpkg: dependency problems prevent configuration of libgomp1:
 libgomp1 depends on gcc-4.2-base (= 4.2.4-1ubuntu3); however:
  Version of gcc-4.2-base on system is 4.2.3-2ubuntu7.
dpkg: error processing libgomp1 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libgomp1
aliciadove@aliciadove:~$

Vojtěch Trefný suggests this article as an answer to your question:
FAQ #52: “Can't install new software and updates”.

"If I try and run dpkg --configure -a I am told that requires superuser privileges."
→ you have to run it with sudo - "sudo dpkg --configure -a"

https://help.ubuntu.com/community/RootSudo

Please open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo dpkg --configure -a

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

John Wilson (jwilsondmartin) said : #4

Thank you both for your prompt replies.
marcobra sudo dpkg --configure -a seems to have worked for now I am downloading 198 updates onto my laptop!
Many thanks to both of you,
John

John Wilson (jwilsondmartin) said : #5

Thanks marcobra, that solved my question.

Will (moresouls) said : #6

when I try to do that it says that it is locked by another process
(yes this is while I am logged in as a super user)