Problem stating synaptic manager

Asked by clive littlewood on 2008-03-16

Hi
I am a newbie so please excuse if this seems simple.

I am trying to run the synaptic package manager to load google desktop but am getting the following error messages.

dpkg was interrupted and you must manually run dpkg --configure -a to correct.

-cache->open()failed please report.

How do i run this manually and who do i report it to ???

Thanks in anticipation.

Vojtěch Trefný suggests this article as an answer to your question:
FAQ #52: “Can't install new software and updates”.

Just open Terminal (Applications→Accesories→Terminal) and type "sudo dpkg --configure -a" (without quotation marks).

when i enter dpkg--configure-a then password
i get the message command not found
Help!

Yes it's because you've forgot space - it's "sudo dpkg --configure -a " -- between "dpkg" and "--" is space.

Hi Vojech

Thanks for the info.

I have tried with 1 space and 2 space but still get the same answer

Command not found.

When i try to use add/remove i also get the error

dpkg not found

any more thoughts

Clive

So, just copy/paste this command from here and then copy full error output here (or make screenshot of terminal), please.

Hi Vojtech

This is a copy /paste from the terminal.

I have altered the password for obvious reasons

clive@clive-laptop:~$ sudo dpkg --configure -a
[sudo] password for clive:
Harclive@clive-laptop:~$ Ha
bash: Ha: command not found
clive@clive-laptop:~$

Clive

Hi Vojtech

This is a copy /paste from the terminal.

I have altered the password for obvious reasons

clive@clive-laptop:~$ sudo dpkg configure a
[sudo] password for clive:
Harclive@clive-laptop:~$ Ha
bash: Ha: command not found
clive@clive-laptop:~$

Clive

"Harclive@clive-laptop:~$ Ha
bash: Ha: command not found"

What's ever 'Ha'?

Ha is the first 2 letters of my password

So, just write the command (sudo dpkg --configure -a) and then just write your password in displayed line ([sudo] password for clive:) -- the passwords won't show up as you type them but they are being entered.. Notice that it won't show the '*' while you type, but just type in normally !

Ok thats sorted the password
Thanks

I now get the following:

clive@clive-laptop:~$ sudo dpkg configure a
dpkg: need an action option

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;
Type dpkg --license for copyright license and lack of warranty (GNU GPL) [*].

Options marked [*] produce a lot of output - pipe it through `less' or `more' !
clive@clive-laptop:~$ dpkg help
dpkg: need an action option

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;
Type dpkg --license for copyright license and lack of warranty (GNU GPL) [*].

Options marked [*] produce a lot of output - pipe it through `less' or `more' !
clive@clive-laptop:~$

You've forgot hyphens...

sudo dpkg --configure -a

Thanks Vojtěch Trefný, that solved my question.