how to enable java in web browser

Asked by carolyn crownover on 2009-09-29

trying to install java for my class assignment, i don't understand applets and plugins .i received this error message: install missing plugins. when i clicked install, i receive this message: already installed 'gcjwebplugin.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xulrunner-1.9 Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-03
Last reply:
2009-10-04
Sam_ (and-sam) said : #1
carolyn crownover (crlncrown) said : #2

i typed in exactly what you said, but there was nothing about gcjwebplugin: Here is the list of what it said:

Installed plugins
Find more information about browser plugins at mozilla.org.
Help for installing plugins is available from plugindoc.mozdev.org.
________________________________

Shockwave Flash
File name: libflashplayer.so
Shockwave Flash 10.0 r32
MIME Type
Description
Suffixes
Enabled
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes
Default Plugin
File name: libnullplugin.so
The default plugin handles plugin data for mimetypes and extensions
that are not specified and facilitates downloading of new plugins.
MIME Type
Description
Suffixes
Enabled
* All types .* No
Demo Print Plugin for unix/linux
File name: libunixprintplugin.so
The demo print plugin for unix.
MIME Type
Description
Suffixes
Enabled
application/x-print-unix-nsplugin Demo Print Plugin for Unix/Linux .pnt Yes

________________________________
From: Alexander Sack <email address hidden>
To: <email address hidden>
Sent: Tuesday, September 29, 2009 4:29:11 PM
Subject: [Question #84228]: Status of bug #438738 changed to 'Incomplete' in xulrunner-1.9 in ubuntu

Bug #438738 status changed in xulrunner-1.9 in ubuntu:

    New => Incomplete

Status change explanation given by Alexander Sack:

please go to about:plugins (type that in location bar of firefox). do
you see the gcjwebplugin listed there?

purge gcjwebplugin plugin and install sun-java-5-plugin packages

does that help?

https://bugs.edge.launchpad.net/ubuntu/+source/xulrunner-1.9/+bug/438738
"java is not working properly, or is not correctly installed"

This bug is linked to #84228.
how to enable java in web browser
https://answers.edge.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

--
You received this question notification because you are a direct
subscriber of the question.

wojox (wojox) said : #3

Open System > Admin > Synaptic Package Manager and search sun-java6-plugin

Right click and mark for installation.

carolyn crownover (crlncrown) said : #4

This is the error message I am still receiving:

 This
product does not support the web browser you are using. To log in you
must use one of the supported browsers. For a list of supported
browsers, click the system and browser requirements link below.

________________________________
From: wojox <email address hidden>
To: <email address hidden>
Sent: Wednesday, September 30, 2009 3:44:22 AM
Subject: Re: [Question #84228]: Status of bug #438738 changed to 'Incomplete' in xulrunner-1.9 in ubuntu

Your question #84228 on xulrunner-1.9 in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

    Status: Open => Answered

wojox proposed the following answer:
Open System > Admin > Synaptic Package Manager and search sun-
java6-plugin

Right click and mark for installation.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

You received this question notification because you are a direct
subscriber of the question.

Luky Winarto (luckyborneo) said : #5

Hi carolyn crownover,

First, open your terminal apps (Applications > Accessories > Terminal), then type this command:
$ sudo apt-get install sun-java-6-bin sun-java-6-jre sun-java-6-fonts sun-java-6-plugin

If you're already install them, try to visit this URL to check whether your java plugin on your firefox is already installed.
http://www.java.com/en/download/help/testvm.xml

Have a nice try, dude... cheers...
-Luky-

carolyn crownover (crlncrown) said : #6

Please note this is the new error message that I am receiving:There was a problem with the command for this terminal: Text was empty (or contained only whitespace)

Carolyn

________________________________
From: wojox <email address hidden>
To: <email address hidden>
Sent: Wednesday, September 30, 2009 3:44:22 AM
Subject: Re: [Question #84228]: Status of bug #438738 changed to 'Incomplete' in xulrunner-1.9 in ubuntu

Your question #84228 on xulrunner-1.9 in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

    Status: Open => Answered

wojox proposed the following answer:
Open System > Admin > Synaptic Package Manager and search sun-
java6-plugin

Right click and mark for installation.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

You received this question notification because you are a direct
subscriber of the question.

carolyn crownover (crlncrown) said : #7

This is the error message that I am receiving from your instructions below:There was a problem with the command for this terminal: Text was empty (or contained only whitespace)

________________________________
From: Luky Winarto <email address hidden>
To: <email address hidden>
Sent: Wednesday, September 30, 2009 9:44:41 AM
Subject: Re: [Question #84228]: Status of bug #438738 changed to 'Incomplete' in xulrunner-1.9 in ubuntu

Your question #84228 on xulrunner-1.9 in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

    Status: Open => Answered

Luky Winarto proposed the following answer:
Hi carolyn crownover,

First, open your terminal apps (Applications > Accessories > Terminal), then type this command:
$ sudo apt-get install sun-java-6-bin sun-java-6-jre sun-java-6-fonts sun-java-6-plugin

If you're already install them, try to visit this URL to check whether your java plugin on your firefox is already installed.
http://www.java.com/en/download/help/testvm.xml

Have a nice try, dude... cheers...
-Luky-

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228/+confirm?answer_id=4

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

You received this question notification because you are a direct
subscriber of the question.

carolyn crownover (crlncrown) said : #8

This is the error message I am receiving:There was a problem with the command for this terminal: Text was empty (or contained only whitespace)

Carolyn

Luky Winarto (luckyborneo) said : #9

Hi Carolyn Crownover,

Please see this solution for the last problem:
https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/60506

-Luky-

carolyn crownover (crlncrown) said : #10

Luky: I cannot do #1 because there is nothing that indicates Sun jave 5 plugin packages. I cannot input something that is not there. So now what?

#2 The system will not allow me to do the following:First, open your terminal apps (Applications > Accessories > Terminal), then type this command:
$ sudo apt-get install sun-java-6-bin sun-java-6-jre sun-java-6-fonts sun-java-6-plugin

When I tried the above for #2 this is the second error message:There was a problem with the command for this terminal: Text was empty (or contained only whitespace)

This is very frustrating, can anyone tell me what to do? Carolyn

If you're already install them, try to visit this URL to check whether your java plugin on your firefox is already installe

Luky Winarto (luckyborneo) said : #11

Carolyn, I will answer #2:

#2: There's a problem with your terminal, isn't it? In order to solve it, I gave you the solution from the URL before.
"I figured out that somehow the option for "Run a custom command instead of my shell" became clicked under the "Title and Command" tab in "Profile Preferences". I hope this helps others with this strange deal." (from: https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/60506)

My questions is what ubuntu version do you using now?
Cheerss...
-Luky-

carolyn crownover (crlncrown) said : #12

I am using Ubuntu 8.04 and no the problem is not fixed and the question is not answered. Carolyn

________________________________
From: Luky Winarto <email address hidden>
To: <email address hidden>
Sent: Wednesday, September 30, 2009 3:40:09 PM
Subject: Re: [Question #84228]: In Response To Your Instructions

Your question #84228 on xulrunner-1.9 in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

    Status: Open => Answered

Luky Winarto proposed the following answer:
Carolyn, I will answer #2:

#2: There's a problem with your terminal, isn't it? In order to solve it, I gave you the solution from the URL before.
"I figured out that somehow the option for "Run a custom command instead of my shell" became clicked under the "Title and Command" tab in "Profile Preferences". I hope this helps others with this strange deal." (from: https://answers.launchpad.net/ubuntu/+source/gnome-terminal/+question/60506)

My questions is what ubuntu version do you using now?
Cheerss...
-Luky-

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228/+confirm?answer_id=10

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

You received this question notification because you are a direct
subscriber of the question.

zvacet (ivicakolic) said : #13

Ctrl+alt+F2 and you will get CLI.Type

sudo apt-get install sun-java-6-bin sun-java-6-jre sun-java-6-fonts sun-java-6-plugin

carolyn crownover (crlncrown) said : #14

How many times do I have to say this Sun Java is not listed, so how can I install something that isn't even listed. Sun Java is not one of the choices listed for installation. carol

Luky Winarto (luckyborneo) said : #15

Please, copy and paste here your sources.list file. It is at /etc/apt/sources.list

-Luky-

carolyn crownover (crlncrown) said : #16

Is anyone listening, or are you guys just shooting off the top of your heads. This is an ongoing serious problems, and one of which no one is providing a solution for. All I want to know is how to install java, have someone review the list of my error messages that I am receiving and tell me how to solve the problem. Stop saying question answered, when the question is not answered nor has the problem be resolved.

Luky Winarto (luckyborneo) said : #17

Well, you have to explain more about your problem. Do you want to programming in Java to develope applications or just view java applets in your favourite browser?

This URL will explain how to install Java.
https://help.ubuntu.com/community/JavaInstallation

carolyn crownover (crlncrown) said : #18

Please review all of the questions I have asked in the past. Then review this error message I continue to receive after applying the information you have given. My question is how do I resolve the issue?

 This product does not support the web browser you are using. To log in you must use one of the supported browsers. For a list of supported browsers, click the system and browser requirements link below.

If we review the above error message when I try to login with my student information, just tell me in plain English how to resolve the problem. Thank you

carolyn crownover (crlncrown) said : #19

I was specific in my questions: I also supplied you with the questions and your responses and the problem is yet resolved. and this is the error message:

 This
product does not support the web browser you are using. To log in you
must use one of the supported browsers. For a list of supported
browsers, click the system and browser requirements link below.

Now how do I resolve this message so that i can gain access to using Java, that is all I have been asking.

________________________________
From: Luky Winarto <email address hidden>
To: <email address hidden>
Sent: Thursday, October 1, 2009 5:46:25 AM
Subject: Re: [Question #84228]: In Response To Your Instructions

Your question #84228 on xulrunner-1.9 in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

    Status: Open => Answered

Luky Winarto proposed the following answer:
Well, you have to explain more about your problem. Do you want to
programming in Java to develope applications or just view java applets
in your favourite browser?

This URL will explain how to install Java.
https://help.ubuntu.com/community/JavaInstallation

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228/+confirm?answer_id=16

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

You received this question notification because you are a direct
subscriber of the question.

carolyn crownover (crlncrown) said : #20

If you are looking and reviewing the problem, what else is there to explain. i copied and paste the error message and that is the problem.

________________________________
From: carolyn crownover <email address hidden>
To: <email address hidden>
Sent: Thursday, October 1, 2009 7:36:45 AM
Subject: Re: [Question #84228]: In Response To Your Instructions

Your question #84228 on xulrunner-1.9 in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

You gave more information on the question:
I was specific in my questions: I also supplied you with the questions
and your responses and the problem is yet resolved. and this is the
error message:

This
product does not support the web browser you are using. To log in you
must use one of the supported browsers. For a list of supported
browsers, click the system and browser requirements link below.

Now how do I resolve this message so that i can gain access to using Java, that is all I have been asking.

________________________________
From: Luky Winarto <email address hidden>
To: <email address hidden>
Sent: Thursday, October 1, 2009 5:46:25 AM
Subject: Re: [Question #84228]: In Response To Your Instructions

Your question #84228 on xulrunner-1.9 in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

    Status: Open => Answered

Luky Winarto proposed the following answer:
Well, you have to explain more about your problem. Do you want to
programming in Java to develope applications or just view java applets
in your favourite browser?

This URL will explain how to install Java.
https://help.ubuntu.com/community/JavaInstallation

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228/+confirm?answer_id=16

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

You received this question notification because you are a direct
subscriber of the question.

You received this question notification because you are a direct
subscriber of the question.

Sam_ (and-sam) said : #21

Carolyn,
before installing Java including plugins for webbrowser, please close Firefox.
Please open Synaptic (package manager) in -> system administration
Search for 'icedtea' and openjdk-6-jre. I'ts open source, I've used it in Hardy and was happy with it.
If you right click to mark those packages for installation they'll suggest others because of dependencies, install everything which is offered.
Start Firefox afterwards and check Extras -> Addons -> TAB Plugins if the icedtea plugin is there.
Test with this site, (javascripting) has to be enabled. It will tell you, that you have an older version blabla, but nothing to worry.
http://www.java.com/de/download/help/testvm.xml

btw. you may search OpenOffice -> preferences -> for Java and enable openjdk also there, it worked for me in Hardy and Karmic, hence no need for sun-java.

Reference:
https://help.ubuntu.com/community/JavaInstallation
https://help.ubuntu.com/community/Java
https://help.ubuntu.com/community/SynapticHowto

carolyn crownover (crlncrown) said : #22

Sam: Thank you so much I am moving a step closer. You are the only one that has given me something to work with. I found icedtea and performed the download and this screen popped up. Choose a Cache directory then it stated Netx open source JNLP Client NETX needs a location for storing Cache and then it states Cache directory/tmp

Now I need to know what to do next. Thanks so much, Carolyn
I will await your response

________________________________
From: Sam <email address hidden>
To: <email address hidden>
Sent: Friday, October 2, 2009 4:06:58 PM
Subject: Re: [Question #84228]: In Response To Your Instructions

Your question #84228 on xulrunner-1.9 in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

    Status: Open => Answered

Sam proposed the following answer:
Carolyn,
before installing Java including plugins for webbrowser, please close Firefox.
Please open Synaptic (package manager) in -> system administration
Search for 'icedtea' and openjdk-6-jre. I'ts open source, I've used it in Hardy and was happy with it.
If you right click to mark those packages for installation they'll suggest others because of dependencies, install everything which is offered.
Start Firefox afterwards and check Extras -> Addons -> TAB Plugins if the icedtea plugin is there.
Test with this site, (javascripting) has to be enabled. It will tell you, that you have an older version blabla, but nothing to worry.
http://www.java.com/de/download/help/testvm.xml

btw. you may search OpenOffice -> preferences -> for Java and enable
openjdk also there, it worked for me in Hardy and Karmic, hence no need
for sun-java.

Reference:
https://help.ubuntu.com/community/JavaInstallation
https://help.ubuntu.com/community/Java
https://help.ubuntu.com/community/SynapticHowto

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228/+confirm?answer_id=20

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/xulrunner-1.9/+question/84228

You received this question notification because you are a direct
subscriber of the question.

Sam_ (and-sam) said : #23

Carolyn,
not sure what you did, but I don't remember such a question about directory for cache.
Please take a look here and verify what you've installed (package names are the same as in Synaptic):
http://packages.ubuntu.com/hardy/openjdk-6-jre
http://packages.ubuntu.com/hardy/icedtea-gcjwebplugin
http://packages.ubuntu.com/hardy/java-common
http://packages.ubuntu.com/search?suite=default&section=all&arch=any&searchon=names&keywords=icedtea

Can you help with this problem?

Provide an answer of your own, or ask carolyn crownover for more information if necessary.

To post a message you must log in.