Intel integrated graphics controller gives only the resolution of 800 x 600.

Asked by Kiikonen on 2012-05-06

My computer model is Asus R11CX (10,1 inch netbook). It has an Intel Atom processor and an integrated graphics controller. I use Ubuntu 12.04 . The commend " lspci | grep VGA " gives:

00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09)

The sreen resolution cannot be changed from 800 x 600. The resolution of 1024 x 600 should be possible. Proprietary drivers are not found. Another user has the same problem and began a discussion thread in http://ubuntuforums.org/showthread.php?t=1966999 .

Some full screen applications (for example the settings manager of Ubuntu) are also printed partially off screen to the right and down of the correct location.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-10
Last reply:
2012-05-26

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

Kiikonen (kiikonenh) said : #2

Thanks for an immediate response! Unbelieveable! Ran the command and here's the output:

Starts here***
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Atom Processor D2xxx/N2xxx Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:dfc00000-dfcfffff ioport:f0e0(size=8)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux minipro 3.2.0-24-generic-pae #37-Ubuntu SMP Wed Apr 25 10:47:59 UTC 2012 i686 i686 i386 GNU/Linux
***and ends here.

ok and the output of:

lspci | grep -i vga

Thanks

http://www.altlinux.org/Intel_GMA_500/600

Kiikonen (kiikonenh) said : #4

Okay, here's the output for that:

00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09)

Hope that it helps!

Kiikonen (kiikonenh) said : #5

The question was marked as answered, altough there seems to be no full solution yet.

You are confusing 'answered' where somebody has provided an answer for you to try, with 'solved' where the issue is solved. This can only be set by YOU as you are the owner of the question.

Kiikonen (kiikonenh) said : #7

All right. I'm sorry, my linux skills are not wide enought for finding an answer from that link. Not even after translating it with google ;) So, my answer is that I still need an answer, at least more instructions.

Apologies and thanks a lot for all your work!

Launchpad Janitor (janitor) said : #8

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

José Antonio Rey (jose) said : #9

This seems to be a common problem. Try with this:
FAQ #1901: “Intel Chipsets Screen Resolution Problem”.

Same problem with Asus 1011CX notebook (Ubuntu 12.04)

I tried to install 3.4 kernel but it didn't work.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/

http://ubunteate.es/instala-el-nuevo-kernel-3-4-en-ubuntu-12-04/

Please help!

About https://answers.launchpad.net/ubuntu/+faq/1901

* Step 1 -> No idea how to.
* Step 2 -> ERROR

Fatal server error:
Unrecognized option: -configure:1

José Antonio Rey (jose) said : #12

About step 1, you should google for them. About step two, bare in mind that there's a space between configure and :1

Thanks, but the trick didn't work for me...

And others...

http://www.vcubells.net/blog/30/may/2012/problemes-asus-seashell-en-ubuntu/

Big problem for a lot of people with these Intel Graphics Card Familly.

Only one screen, only 800x600. Nothing more detected!

Asus 1011CX (Intel Atom N2600) working with 12.04

Solved using:

http://daily.siebler.eu/2012/06/ubuntu-12-04-driver-for-intel-cedarview-atom-n2000-und-d2000-serie/

This problem affects Cedar View and Cedar Trail chipsets (new Intel Atom chipsets with memory & graphics integrated controllers):

http://en.wikipedia.org/wiki/List_of_Intel_Atom_microprocessors

Som users say that the problem is solved with Quantal (12.10), but I prefer LTS editions.

12.04 (Precise) is LTS (Long Term Service).

David Hope (dhhope) said : #17

Is this problem moving toward a resolution?

Asus 1011CX (Intel Atom N2600) working with 12.04 up-to-date (29-setember-2012)

1. Go to [System Parameters] [Additional Drivers]
2. Activate cedarview-drm
3. Reboot. In my case I needed to reboot from Ctl+Alt+F1 (no-graphic terminal) because graphic server went out.
4. Go next time to [System Parameters] [Additional Drivers]
5. Activate cedarview-graphics-drivers
6. System resolution ok, at 1024x600. Unity 2D.