Screen resolution problem

Asked by Jason Imago on 2012-02-23

I recently bought a new MSI U180 netbook and after realising it came with windows, I switched it to Ubuntu 11.10. The screen is supposed to be 1024x600 yet it displays at 800x600. In the "Displays" menu, the screen is labelled "Unknown" and the only option avaliable is the 800x600. From what I've read this means it's not picking up a driver for it.

There are a few similar questions to this however none of the solutions have worked for me so far. I do believe the solution is to modify xorg.conf but I have no idea how to do so. Any help would be greatly appreciated. The following pieces of information are things I've used/tried so far. They may either be useful or useless but it doesn't hurt to put the information there.

xorg.conf is empty - every time I've attempted to follow guides or instructions and put something in it, my computer fails to boot.

Results of cvt 1024 600:
# 1024x600 59.85 Hz (CVT) hsync: 37.35 kHz; pclk: 49.00 MHz
Modeline "1024x600_60.00" 49.00 1024 1072 1168 1312 600 603 613 624 -hsync +vsync

Then if I try: xrandr --newmode "1024x600_60.00" 49.00 1024 1072 1168 1312 600 603 613 624 -hsync +vsync
xrandr: Failed to get size of gamma for output default

Results of xrandr:
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
   800x600 0.0*

results of sudo dpkg-reconfigure xserver.xorg:
Package `xserver.xorg' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: xserver.xorg is not installed.

Results of lspci:
00:00.0 Host bridge: Intel Corporation Cedarview DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Cedarview Integrated Graphics Controller (rev 09)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)

If this duplicates other posts then I apologise, however having followed many other posts with no success and being somewhat of a beginner in Linux, I hope this warrants a new question.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Solved by:
MikeR
Solved:
2012-10-31
Last query:
2012-10-31
Last reply:
2012-09-29

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a

Thanks

Jason Imago (7x2g) said : #2

sudo lshw -C display; lsb_release -a; uname -a
returns:

[sudo] password for user:
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Cedarview Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:dfc00000-dfcfffff ioport:f100(size=8)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux user-pcname-pc 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:50:54 UTC 2012 i686 i686 i386 GNU/Linux

Jason Imago (7x2g) said : #4

Does that link mean that there is no driver available and the only way I'll get it to work is downgrading by a few distributions?

José Antonio Rey (jose) said : #5

José Antonio Rey suggests this article as an answer to your question:
FAQ #1901: “Intel Chipsets Screen Resolution Problem”.

Jason Imago (7x2g) said : #6

Unfortunately the FAQ did not solve my problem. I could find the monitor values in the first step however when I type in :
sudo X configure :1

it returns:
Unrecognized option: configure
use: X [:<display>] [option]

(then a load of options)

Fatal server error:
Unrecognized option: configure.

Pau Amma (pauamma) said : #7

The syntax in the FAQ is slightly wrong. The correct command is:

sudo X -configure :1

(missing - before "configure")

Jason Imago (7x2g) said : #8

Thank you for clearing that up. I attempted this new command but it now gives an error message rather than a command not found:

$ sudo X -configure :1

X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-29-server i686 Ubuntu
Current Operating System: Linux nick-bouse-pc 3.0.0-16-generic #28-Ubuntu SMP Fri Jan 27 17:50:54 UTC 2012 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=6acbbe7d-2cbf-40a4-b5f8-1b1562e73fca ro quiet splash vt.handoff=7
Build Date: 19 October 2011 05:09:41AM
xorg-server 2:1.10.4-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.22.2
 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sun Mar 11 20:49:18 2012
List of video drivers:
 qxl
 neomagic
 ati
 vmware
 radeon
 vmwlegacy
 r128
 sisusb
 savage
 nouveau
 tdfx
 ztv
 s3
 openchrome
 intel
 cirrus
 siliconmotion
 trident
 mach64
 geode
 sis
 mga
 fbdev
 vesa
(EE) Failed to load module "vmwgfx" (module does not exist, 0)
(EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
(++) Using config file: "/home/nick/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
  Configuration failed.
 ddxSigGiveUp: Closing log

Jason Imago (7x2g) said : #9

It did actually create a xorg.conf.new in my home folder but I'm not sure it had anything useful in it. I tried the steps from the FAQ but it didn't affect anything. It didn't break anything either so I assume it hasn't created the xorg.conf.new correctly.

sokolov (daniel-sokolov) said : #10

Over at
http://forums.debian.net/viewtopic.php?f=7&t=78157&start=15
someone was successful with compiling their own 3.3.2 experimental kernel.

Similar problem with Asus 1011CX (Intel Atom N2600) working with 12.04

Solved using:

http://daily.siebler.eu/2012/06/ubuntu-12-04-driver-for-intel-cedarview-atom-n2000-und-d2000-serie/

Best MikeR (mike-rechtman) said : #13

I had the same problem with an MSI U180.
With some trepidation I followed the instructions at
http://daily.siebler.eu/2012/06/ubuntu-12-04-driver-for-intel-cedarview-atom-n2000-und-d2000-serie/

No problems!
After a reboot, resolution showed as 1024x600
Hopefully, problem solved

Asus 1011CX (Intel Atom N2600) working with 12.04 up-to-date (29-setember-2012)

1. Go to [System Parameters] [Additional Drivers]
2. Activate cedarview-drm
3. Reboot. In my case I needed to reboot from Ctl+Alt+F1 (no-graphic terminal) because graphic server went out.
4. Go next time to [System Parameters] [Additional Drivers]
5. Activate cedarview-graphics-drivers
6. System resolution ok, at 1204x600. Unity 2D.

1024x600 I would to say.

Jason Imago (7x2g) said : #16

Thanks MikeR, that solved my question.