installing adobe flashplayer 10,Error: Dependency is not satisfiable: libnspr4-dev

Asked by SteveArmstrong on 2009-08-21

After the install of Ubuntu 9.10 I tried to install Adobe Flashplayer 10, and got the following: Error: Dependency is not satisfiable: libnspr4-dev.

I'm running the 32 bit version of Ubuntu.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2009-08-28
Last query:
2009-08-28
Last reply:
2009-08-27

Hi,

First please make sure to close all open programs, including all package managers like Synaptic, Add/remove programs, etc ...

Then please try this procedure:

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2: Please COPY-PASTE each line below into the Terminal then hit <enter> after each line)

sudo aptitude install libnspr4-dev libnss3-dev ubuntu-restricted-extras
sudo aptitude install -f
sudo aptitude update
sudo aptitude dist-upgrade

Step 3: Please post results (copy/paste terminal output from each command) on this thread

Hope it helps,

Regards,

Mark

SteveArmstrong (scbmarmstrong) said : #2

Thanks a million. looks easy
All of the commands .
Got a message(see below)

Then....
I ran my "adobe-flashplugin package...
Got the message: Error: Dependency is not satisfiable: libnspr4-dev
No candidate version found for libnspr-dev
No candidate version found for libnss3-dev
Couldn't find any package whose name or description matched "ubuntu-restricted-extras"
No candidate version found for libnspr-dev
No candidate version found for libnss3-dev
Couldn't find any package whose name or description matched "ubuntu-restricted-extras"

Evidently they need downloaded ????

Thanks again.

sudo aptitude install libnspr4-dev libnss3-dev ubuntu-restricted-extras
steve@molly-desktop:~$ sudo aptitude install libnspr-dev libnss3-dev ubuntu-restricted-extras
[sudo] password for steve:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Initializing package states... Done
Writing extended state information... Done
Building tag database... Done
No candidate version found for libnspr-dev
No candidate version found for libnss3-dev
Couldn't find any package whose name or description matched "ubuntu-restricted-extras"
No candidate version found for libnspr-dev
No candidate version found for libnss3-dev
Couldn't find any package whose name or description matched "ubuntu-restricted-extras"
The following packages are unused and will be REMOVED:
  libnss3-0d
The following packages have been kept back:
  gaim
0 packages upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
Need to get 0B of archives. After unpacking 86.0kB will be freed.
Do you want to continue? [Y/n/?]
steve@molly-desktop:~$
steve@molly-desktop:~$ sudo aptitude install libnspr-dev libnss3-dev ubuntu-restricted-extras
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
No candidate version found for libnspr-dev
No candidate version found for libnss3-dev
Couldn't find any package whose name or description matched "ubuntu-restricted-extras"
No candidate version found for libnspr-dev
No candidate version found for libnss3-dev
Couldn't find any package whose name or description matched "ubuntu-restricted-extras"
The following packages are unused and will be REMOVED:
  libnss3-0d
The following packages have been kept back:
  gaim
0 packages upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
Need to get 0B of archives. After unpacking 86.0kB will be freed.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
(Reading database ... 116047 files and directories currently installed.)
Removing libnss3-0d ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
Building tag database... Done

steve@molly-desktop:~$ sudo aptitude dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages will be upgraded:
  gaim
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 86.7kB of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Get:1 http://security.ubuntu.com hardy-security/universe gaim 1:2.4.1-1ubuntu2.6 [86.7kB]
Fetched 86.7kB in 0s (90.1kB/s)
(Reading database ... 116040 files and directories currently installed.)
Preparing to replace gaim 1:2.4.1-1ubuntu2.5 (using .../gaim_1%3a2.4.1-1ubuntu2.6_all.deb) ...
Unpacking replacement gaim ...
Setting up gaim (1:2.4.1-1ubuntu2.6) ...
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
steve@molly-desktop:~$

I suggest installing Ubuntu 9.04 from a LiveCD session and then following these instructions to install Adobe Flash player:

http://www.howtoforge.com/the-perfect-desktop-ubuntu-9.04

Sam_ (and-sam) said : #4

Steve,
actually it shouldn't be an issue by installing directly from Adobe.
https://answers.launchpad.net/ubuntu/+question/79126

But before that, every other or older version of flash app should be removed to make firefox uses the newest version.

SteveArmstrong (scbmarmstrong) said : #5

Well, it took me a while....
but 9.04 is in and Adobe 10 is very nice.

thanks a million.
Nice simple instructions :-)

--- On Fri, 8/21/09, Mark Rijckenberg <email address hidden> wrote:

From: Mark Rijckenberg <email address hidden>
Subject: Re: [Question #80569]: installing adobe flashplayer 10, Error: Dependency is not satisfiable: libnspr4-dev
To: <email address hidden>
Date: Friday, August 21, 2009, 7:24 PM

Your question #80569 on yelp in ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/80569

    Status: Open => Answered

Mark Rijckenberg proposed the following answer:
I suggest installing Ubuntu 9.04 from a LiveCD session and then
following these instructions to install Adobe Flash player:

http://www.howtoforge.com/the-perfect-desktop-ubuntu-9.04

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/80569/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/yelp/+question/80569

You received this question notification because you are a direct
subscriber of the question.

Hi Steve,

You are welcome. If your issue is solved, can you please set the thread status to "solved" ?

Regards,

Mark

SteveArmstrong (scbmarmstrong) said : #7

Thank you....

Vikram Dhillon (dhillon-v10) said : #8

How did you do the install?? Did you download it from the website, then
you can use sudo dkpg -i package-name to install it otherwise, synatic
should take care fo the dependencies here.

--
Regards,
Vikram Dhillon

On Mon, 2009-12-07 at 00:41 +0000, ani wrote:
> Question #80569 on yelp in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/yelp/+question/80569
>
> Description changed to:
> After the install of Ubuntu 9.10 I tried to install Adobe Flashplayer
> 10, and got the following: Error: Dependency is not satisfiable:
> libnspr4-dev.
>
> I'm running the 32 bit version of Ubuntu.
>