I cannot read a floppy in Ubuntu 10.04 (Lucid)

Asked by Laurence Nagel on 2010-08-10

I keep thinking I must be doing something wrong as I try to read an ordinary MS-DOS (circa 1990)
floppy disk. With a flash drive or a CD, I just plug the media in and an icon appears on my
desktop and I can look at it with Nautilus or in /media. When I insert a floppy into the floppy
drive, the light comes on for a moment and absolutely nothing happens. I know the drive works,
because if I leave the floppy in the drive and reboot it tries to read the floppy and GRUB complains
that it is not a System Disk.

If I insert the floppy in the drive, right click on Floppy Drive in Nautilus, and then left click
on Mount, nautilus complains that there is "No Media In Drive."

Then I got creative and tried to mount the drive using any of the commands
mount /dev/fd0 /media/floppy0
mount -t msdos /dev/fd0 media/floppy0
mount /dev/fd0
mount /media/floppy0

The contents of my /etc/modules are:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
floppy

The contents of my /etc/fstab are:

# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=d6835917-e68f-41ea-a3e0-901d7c19e04b / ext3 relatime,errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=ba2f4a0c-5eec-4845-a012-29f044af8562 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

I realize this isn't earth shattering, but it is a matter of Ubuntu pride. I happened to be trying
to read this stinking floppy with a friend who is a died-in-the-wool MS guy, and, oh! the grief I
got.....

Can somebody tell me what I'm doing wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Laurence Nagel
Solved:
2010-08-16
Last query:
2010-08-16
Last reply:
2010-08-13
Marc Stewart (marc.stewart) said : #1

You're trying to use a floppy disk, in 2010, and then asking what you're doing wrong!? (-; Sorry—couldn't resist.

More seriously, though, I seem to recall seeing in the Users and Groups preferences that users aren't by default permitted to use floppy drives (and just confirmed that*). Have you checked that setting for your own user account?

* System > Administration > Users and Groups; Advanced Settings; User Privileges; Use floppy drives

Greg Beam (ki7mt) said : #2

Confirmed, was seeing exactly the same thing as Laurence 10.04.

Although I rarely (only for Video Card Firmware Flashing) use FD's, I had the same results, but after enabling User Privileges, it worked as expected.

Let us know if Marc's solution fixes your issue Laurence.

KE1HA

peter b (b1pete) said : #3

Laurence, in a nutshell, udisks pkg requires regression to 1.0.1-1build1; it is available in repos.

peter b (b1pete) said : #4

sorry Marc Stewart, not everybody must share your opinions ....'You're trying to use a floppy disk, in 2010, and then asking what you're doing wrong!? (-; '......

as long as a device is present it must be recognized and render operational by the os. it is up to the user whether to use it or not.

Laurence Nagel (lwn) said : #5

Thank you everyone for your replies! I thought allowing myself to use floppies via System->Administration->Users and Groups. Alas, setting my privileges to allow floppies had absolutely no effect at all. I tried rebooting to make sure the new privileges had an effect, but still no luck. It almost seems like Lucid doesn't allow floppies no matter how Users and Groups are set. So, KE1HA, could you please tell me how the floppy "worked as expected?"

Please also check if your user have all permissions
please open the menu System→Administration→User and groups
and check the permissions of your user please give all permissions using the
"Advanced settings" go to "Users Priviledges" and set all permissions

Laurence Nagel (lwn) said : #7

OK, I went to System->Administration->Users and Groups->Advanced Settings->User Privileges and checked all of the boxes. I then rebooted and inserted my DOS FAT format floppy into the drive and nothing happened. When I go into Nautilus under Places->Computer and right clicked on Floppy Drive followed by left click on Mount, I get the message "Unable to mount location - No media in drive" And when I open a terminal and issue the command

sudo mount /dev/fd0

I get the message

mount: device /dev/fd0 is write protected, mounting read-only

there is nothing in /media/floppy0, and the command umount /dev/fd0 results in the message

umount: /dev/fd0 is not mounted (according to mtab)

First please try a different floppies... (more than 1 or 2)

Related https://answers.launchpad.net/ubuntu/+question/60831

Laurence Nagel (lwn) said : #9

OK, I tried every floppy I own (all 12 of them) with exactly the same result. All my floppies are MS/DOS FAT floppies.

peter b (b1pete) said : #10

the avenues pursued obviously returned the results shown.

 pls follow my recommendation above .....'udisks pkg requires regression to 1.0.1-1build1; it is available in repos.'.....

if in doubt as to how to do it, the ubuntu url below provides all the answers

https://help.ubuntu.com/community/SynapticHowto

Laurence Nagel (lwn) said : #11

Problem solved, thanks to peter b!!!

To summarize, reading (and writing) a floppy disk in Lucid Lynx (10.04) requires three steps:

1. Allow yourself to use the floppy by going to System->Administration->Users and Groups->Advanced Settings->User Privileges and click on "Use floppy drives"

2. Use the old version of udisks () by going to System->Administration->Synaptic Package Manager, find the udisks package, mark udisks for reinstallation, click on Package->Force Version, and select the 1.0.1-1build1 version (which is the old version). Then click on apply to finish the installation.

3. Remember to unclick udisks whenever Update Manager wants to install new updates, or you'll get the new version and floppy disks won't work anymore!

After the old udisks is installed (and the machine is rebooted), when you insert a floppy a cute little icon comes up on the desktop and in Nautilus (and on Disk Mounter if you have that installed). Left clicking on the icon and select Mount Floppy Disk will put an icon in Nautilus, and then you read, write, and format the floppy just like any other drive.

Thank you, peter b!!!

PS: Is this a bug???

peter b (b1pete) said : #12

glad that you got it working.

....'PS: Is this a bug???'..... well, I'd say so. it is a long story associated with this situation which I'd rather not get into. the ubuntu people in charge of handling bug fix releases sorted out the problem as you already could see. however, the fix is not yet implemented in the main lucid release; I assume it will be done sometime somehow.

I work in a system where hundreds of floppies are used. There are lots of small files which may not be called upon for years. Nobody is willing to place these files on a sytem which is exposed to the internet. The same file names (with different contents) occur many times. Are we ever likely to see a USB flash device at a cost of a few pence? No, the manufacturers are rushing to push the storage size *up*. Big is not always beautiful.
I'm unhappy at having to spend an afternoon sorting this out.
I read a magazine a few weeks ago which contained an article about how the floppy was dead. Another article was on how to rescue a stymied PC. Guess what the writer advised using.....
Thanks for all the help, chums!
Phil

and003 (and03) said : #14

I tried this method and it worked just as described. I would like to share this information with those at UbuntuForums.org who have the same problem. I think they'd be interested.

Laurence Nagel (lwn) said : #15

I thought this was Ubuntu-Forums.org!!!

Larry
---
Laurence Nagel
Omega Enterprises Consulting
251 Stanford Avenue
Kensington, CA 94708

(510) 558-0842
<email address hidden>
http://www.omega-enterprises.net

On 08/20/2010 11:36 PM, and003 wrote:
> Your question #120571 on util-linux in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/util-linux/+question/120571
>
> and003 posted a new comment:
> I tried this method and it worked just as described. I would like to
> share this information with those at UbuntuForums.org who have the same
> problem. I think they'd be interested.
>

and003 (and03) said : #16

I was referring to the main site at the URL http://www.ubuntuforums.org/, not the LaunchPad.Net site here.

Merel (merel469) said : #17

My Personal Conclusion : Ubuntu , Linux for (human beings ?? ) ... masochists !!
At the end of the day I came to the point when I have to agree with Windows users that Linux never works. What a deceiving fact that after so many years an operating system is not able to make a simple floppy station working !!!

Reading all the problems and efforts made (not only here) to solve such a stupid problem, I don't know if I should laugh to dead or cry a river about Canonical.

One thing is for sure :
Ubuntu 10.04 will not impress people coming from Windows and wanting to try it !

Another thing is almost sure :
My fidelity to keep using Ubuntu and my patience have come to an end.
I'm very close to give up on Ubuntu , if users need to downgrade to earlier packages in order to .... run a floppy drive, as if it was something extremely complicated. With all due respect to our community members, who tried to help (here and on many other fora).

Ian M. Stewart (ims) said : #18

Laurence Nagel usefully told us:
"2. Use the old version of udisks () by going to System->Administration->Synaptic Package Manager, find the udisks package, mark udisks for reinstallation, click on Package->Force Version, and select the 1.0.1-1build1 version (which is the old version). Then click on apply to finish the installation.

3. Remember to unclick udisks whenever Update Manager wants to install new updates, or you'll get the new version and floppy disks won't work anymore!"

There is also the facility in Lucid 10.04 to "Lock Version" under Package>Lock Version which sets it to red, and presumably will prevent any updates screwing it up.

Can I add my tiny weight to the request for Canonical to FIX THIS PLEASE!!! It surely can't be that hard.

Alan (avhennessy) said : #19

it looks like Laurence Nagel has opened a bug report at https://bugs.launchpad.net/ubuntu/+source/udisks/+bug/618953. It help get attention if every one affected by this problem post there.

Branimir Kolar (branimir101) said : #20

Hi, downgrading udisks worked but now floppy is mounted as root and I can't (as a user) change/create files.
How to fix it?

Ian M. Stewart (ims) said : #21

Branimir Kolar said 13 hours ago:
I can't (as a user) change/create files.

In Ubuntu:
System > Administration > Users and Groups > select the user you wish to change, and click on Advanced Settings. Enter the password, then under User Privileges scroll down to "Use Floppy Drives" and check the box.

Ian

Branimir Kolar (branimir101) said : #22

Hi Ian,

I already did that but it didn't work. Its working now after editing fstab following instructions in this thread:
http://www.uluga.ubuntuforums.org/showthread.php?t=1499378

Also, I had to create a folder 'floppy0' in media directory...

cheers

Branimir Kolar (branimir101) said : #23

I just upgraded to Ubuntu 10.10 Maverick .

Sadly - this issue remains.

Also you can't downgrade udisks from Synaptic, but theres a great guide how to downgrade here:
After downgrading it works again!

http://linux.derkeiler.com/Mailing-Lists/Ubuntu/2010-09/msg02035.html

Alan (avhennessy) said : #24

It doesn't look like anything is going to be done about this problem anytime soon. The bug at https://bugs.launchpad.net/ubuntu/+source/udisks/+bug/618953 has been posted for almost 2 months. Its 'Importance' is still classed as undecided, it is unassigned to a developer, no developers have posted asking any questions or providing any information, and only six people has signed up as being affected by this bug. i expect to be using udisks 1.0.1-1build1 version for quite some time!

Hello guys,

I'm a brazilian man, and please pardon my english writing style.
Well, I'd like to say that I don't get to use floppy disk in my computer (Ubuntu 10.04).
Particularly, I need to use them to save my income tax return. These archives are small the sufficient to fit in a floppy and it still it constitutes a format practical and convenient to make backup of archives of the treasury department.
I made as Lawrence advised but I don't get to use the floppies.
Please, some of you would have another tip to solve this problem. It make days that I am hided in the thicket of a wood in this problem.
Thanks!

My best regards,

delance (olivier-delance) said : #26

Be careful. The life expectancy of floppy drive is limited, as I unfortunately learned!

Please open the menu System→Administration→User and groups
and check the permissions of your user please give all permissions using the "Advanced settings" go to "Users Priviledges" and set all permissions.

Then open a terminal and type::

udisk --mount /dev/fd0

Dear marcobra,

I made as you advised, I typed:

udisk --mount /dev/fd0

and typed enter, but the following output showed:

'udisk' command not found, you wanted to say:
'udisks' command of 'udisks' package (main)
'fdisk' command of 'gnu-fdisk' package (universe)
'fdisk' command of 'util-linux' package (main)
'gdisk' command of 'gdisk' package (universe)
udisk: command not found

Please, marcobra, what's the next step?

My best regards,

Sorry typo:

udisks --mount /dev/fd0

Dear marcobra,

I command in the terminal:

udisks --mount /dev/fd0

and follows the result of the command:

Cannot stat device file /dev/fd0: File or directory not found

Please, help me!!

Regards,

Please copy and paste here the result of tihs terminal command:

ls -la /dev/fd*

lrwxrwxrwx 1 root root 13 2010-11-15 19:47 /dev/fd -> /proc/self/fd

so try:

udisks --mount /dev/fd

Dear marcobra,

$ udisks --mount /dev/fd
Device file /dev/fd is not a block device: Recurso temporariamente indisponível

Thank you for your attention, please, continue suggesting solutions for this problem!

Bye!

nrama (nrama) said : #35

I solved my problem by downgrading the udisks package and editing fstab to reflect UUID of the floppy drive.This can be retrieved by typing
"blkid -o value -s UUID" in terminal (without the quotes of course).

My result:
2b563ace-54f8-4596-be3c-b933566ca06f
c44a8bd0-48d8-403d-b612-4f44ecff8341
518a970a-fab3-47d0-90ec-04c0a2c622b4
c47b64c5-616c-4bc3-a771-00698aba2819
cadb6faf-a1de-4f80-8ffd-54d72e5c208b
40f89141-681f-4c12-98f0-5ffa9afed7db

I tried mounting with, AS ROOT, with

  mount -t /dev/fd0 with no joy. It worked with
 mount -t /media/floppy.

I am not certain if the above step is necessary

Now clicking on Places should reveal a nice symbol of the Floppy drive. Restarting the computer did not vaporise the fix as in other fixes I tried!!

It seems that different fixes work in different circumstances reflecting the individuality of the OS. It is almost human!

mikeys (miketwo) said : #36

Is there a way to mount floppy in Lucid w/out downgrading udisks? Please advise.

mikeys (miketwo) said : #37

It works w/out downgrading. In terminal type: udisks --mount /dev/fd0. Advanced user settings should be set before that to use floppy. Works great on Lucid Lynx (32-bit)! Thanks marcobra.

Merel (merel469) said : #38

NUTS !
Personal opinion : Ubuntu is a (not) operating system for masochists.

Udisks not being downgraded, I tried 2 following codelines.
Both give an error message (confirming once again my personal opinion) :

=========================================================
georges@PC1:~$ udisks --mount /dev/fd
Device file /dev/fd is not a block device: Resource temporarily unavailable
==========================================================
georges@PC1:~$ udisks --mount /dev/fd0
Mount failed: Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/fd0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so
============================================================

Hey mikeys, what do you mean with "Advanced user settings" to be set ? Thank you

mikeys (miketwo) said : #39

Hey Merel, Here are steps for Lucid (x32): System, Administraton, Users and Groups, Advanced Settings (bottom right - under your account that is shown - there may be more than one user shown), put in passwd, User Privileges, check the box that says "Use floppy Drives", say OK. Then, try the "udisks --mount /dev/fd" command in terminal. If command is OK, look on your desktop and the floppy icon should be there ready for you to access. if not, check your computer to make sure floppy drive is connected OK and it works under another OS such as Windows. Make sure you have a msdos formated floppy disk inside. That's all. No need to change udisks in synaptic, but you should check in synaptic that udisks is installed in the first place. Turns out, Canonical took out the use of floppies as default option this time. Why???

Branimir Kolar (branimir101) said : #40

@mikeys I don't have time to try it again but around October I tried everything and I (as also others then) didn't get it working without downgrading udisks. Maybe something changed I dont know.

@Merel if nothing works try downgrading, heres the guide I followed in 10.10 maverick:
http://linux.derkeiler.com/Mailing-Lists/Ubuntu/2010-09/msg02035.html

I'm forced to use floppies a lot everyday and I have to say although there are initial problems setting it up, once you done it - works great.

With Windows 7 floppy disks didnt work at all for me. And XP constantly ruined 70% of disks. Writing errors all the time.

Merel (merel469) said : #41

@Mikeys Thank you for suggestions.

But nope; in the present situation (no udisks downgrade made) and using a system fully update :

=============

1. System, Administraton, Users and Groups, Advanced Settings

(bottom right - under your account that is shown - there may be more than one user shown),

[I must apologize for not reading the whole topic ; this was already explained before]

================

2. Put in passwd, User Privileges, check the box that says "Use floppy Drives", say OK.

[Comment Point 2 : this option box was already checked ON]
=============
===
3. Then, try the "udisks --mount /dev/fd" command in terminal.
================
3.1. If command is OK, look on your desktop and the floppy icon should be there ready for you to access.

3.2. if not, check your computer to make sure floppy drive is connected OK and it works under another OS such as Windows.

=============
[Comment]
Point 3 failed :
    georges@PC1:~$ udisks --mount /dev/fd
    Device file /dev/fd is not a block device: Resource temporarily unavailable

=============
4. Make sure you have a msdos formated floppy disk inside.

[Comment: All of my floppies run with Windows on the same floppydrive]
============

Furthermore : (System fully updated)
System > Administration > StartUp-Manager > [Tab] Advanced > [Knob] Create Rescue Floppy

The process starts, the floppy is accessed and (probably ?) starts formatting.
One can see the drive is being being accessed continuously.
But soon after about 10-15 seconds, it stops with a super-smart message : "ERROR"

nrama (nrama) said : #42

Further to my post of the 18th and being Masochistic I have tried all suggestions including using the latest version of udisks.

My experiments show that it is possible to use latest version but require a mounting by way of terminal each time the floppy drive needs to be used after an unmount.

The older version of udisks allows the floppy to be mounted by clicking on floppy in Places. In both cases there must be a Floppy in the drive. The first click mount the floppy and the second click opens the file. The floppy can be mounted and unmounted any number of times in a session by merely clicking on the floppy icon, which magically appears, after the first click in Places!

Although I suggested using UUID in FSTAB, commenting out all references to Floppy therein makes no difference. This has mystified me. It also has removed the /media/floppy, which I consider a good thing.

Being a lazy Masochist I prefer using the older udisks which I have locked from further updates! BTW I am using the 64 bit version if that is significant.

Ah the joys of unfettered experimenting afforded by the Linux world.

Merel (merel469) said : #43

@ nrama

Thank you for your conclusions.
It makes no difference wether 64/32 versions are used. Some time ago I downgraded udisks and I remember that i was able to use the floppy station. However, I confirm that for each diskette change in a session, again another 'mount' was required.

But being also a lazy masochist, I got tired (and forgot sometimes) to exclude udisks at each update.

You are write that it is possible to LOCK version updates of programs. I didn't know that. I might find very quickly how to do this, but maybe it requires some more research time. To save time to our masochists club, I would appreciate a quick how-to note here. Thank you.

On the other hand, if a floppy user stops updating, how will he ever know that "eventually perhaps" this stupid bug might have been fixed in a future version (which I doubt very much).

I consider the floppy disks still worth to be used. We all have personal reasons and justifications for using them (or not), Some respect for each opinion is a must. Therefore I don't accept the attitudes of Canonical / Linux developers in this stupid issue.

nrama (nrama) said : #44

@Merel

To lock udisks, in Synaptic, highlight it and from the drop down menu under Packages mark Lock version.

You are correct of course that without updates we will never know if a workable solution arises. I suspect though that whilst the floppy has its uses it has reached its use by date. What I have done is transferred all of my significant floppies to USB sticks, This process, of course, needed the floppy drive to accomplish!!

I sincerely hope that our personal needs and desires shall require no justification what so ever. I believe that it is fierce individualism,apart from the freedom, that has drawn many to the Linux world. And a sense of adventure.

Kris Dee (stargazer185) said : #45

For the last hour or so (possibly more) I was busy trying to get my floppy drive to work, to no avail. Then Google brought me overe here, and downgrading the "udisks" solved it: I can now mount a floppy.
I commented in the appropriate "Bug" thread about this.

Jim (JR) Harris (jimrh) said : #46

@ Kris,

The reason you get the funky S&M (laughing!) message at boot is because you have a floppy line in your FSTAB file (as was suggested before)

With the "new" (downgraded) UDISKS file, you do not need this line. You can safely delete it or comment it out, and floppy disks will still mount-on-demand just as if it were a USB or hot-swap eSATA drive.

@ Everyone.
1. Thanks for all the posts. I finally got my floppy working by following the various instructions here - including the down-rev and locking the file down tighter than the head-bolts on a 350 V-8.

2. IMHO, whoever came up with this brilliant brain-storm (depreciating floppy drives) should be the first up against the wall when the revolution comes! Barring that, I'd settle for hanging the &$*# idiot by his/her feet and beating them senseless with a short bat. This has got to be one of the most short-sighted decisions I've ever been subjected to. Not even Windows is that stupid!!

3. I have posted before about my frustrations with the short-sighted "Ivory-Tower" attitudes that surround some of these decisions, and the responses I received were versions of "You don't like it? Awwww. . . . . Go find another distro!" How in the [. . . . .] are we supposed to evangelize open-source/free software when we have to put up with more BS than even the payware stuff gives us? OK, if I don't like it, I should go write my OWN modules. . . . if I had both the skill AND the time, I'd surely do that. Unfortunately neither is the case.

@ Ubuntu decision makers / Canonical

Please remember that it is *YOUR USER BASE - PEOPLE LIKE US* that has driven you to the top of Distrowatch. Remember - You ignore your users at your own peril. It is this kind of arrogant ivory-tower attitude that will rapidly see you go from #1 to totally irrelevant.

If becoming as irrelevant as Windows 3.1 is your goal, let me assure you that you are going about it in precisely the right way.

What say ye?

Jim

Alan (avhennessy) said : #47

Folks:
This is just an 'Answer' page. No one is going to pay any attention to what's posted here since it has been labeled "Solved".

If you want action you need to post to the 'Bug Report' pages which can be found here:

https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/593140

And here:

https://bugs.launchpad.net/ubuntu/+source/udisks/+bug/618953

Please go there and make your voices heard!!

Jim (JR) Harris (jimrh) said : #48

Been there, done that, bought the T-shirt. Both bugs.

Based on the amount of interest in other bugs I've either written or supported - I'm not really holding my breath.

It's like the fact that Outlook 2010 jumbles up your e-mail if you have more than one e-mail account associated with a mail-file. Hundreds, if not thousands, of people have complained bitterly about this - and Microsoft's answer? Not a bug - it's by design. If 90% of the Outlook user base thinks it's the most retarded thing to happen since the Dawn of Man - well, according to M$ it just vacuums being us. The fact that the design is asinine is not significant.

So it is with Ubuntu. Some group of developers sitting in their Ivory Towers make an absolutely brain-dead decision - and if we complain? Well, it vacuums being us too.

Try this: Install Ubuntu on a system that has a wide-screen monitor - 1600x900 is common - and try booting directly into a text-mode login - the text on the screen defaults to 1600x900 - and there is no way to change it! You end up using a Bausch and Lomb hand-held magnifier to see the 3-point text.

I raised that as an issue - and you want to know what they suggested as a fix? No kidding! They recommended I use a different distro!

Sigh.

So much for "humanizing" Linux. We've come full circle and we're right back where the payware operating systems left us.

(/rant)

What say ye?

Jim

Jim (JR) Harris (jimrh) said : #49

I just linked it to bug 593140 too.

Oh, and by the way - I noticed on *MY* system (Ubuntu 10.04 Desktop) that after I performed the hack-job workaround to get the floppy working - my system stopped recognizing *any other kind of removable media* - USB, eSATA, you name it. All gone.

I had to re-install the updated udev package to get my other removable types back.

Oh, and who marked this beast as "solved"? It *ISN'T* solved, there's just an ugly hack as a workaround! I wish we could un-mark it as solved. . . .

Jim

This worked for me. It took many hours of searching the internet.. Fred Kelsey..
*****************************************************************************

Problem solved, thanks to peter b!!!
To summarize, reading (and writing) a floppy disk in Lucid Lynx (10.04) requires three steps:
1. Allow yourself to use the floppy by going to System->Administration->Users and Groups->Advanced Settings->User Privileges and click on "Use floppy drives"
2. Use the old version of udisks () by going to System->Administration->Synaptic Package Manager, find the udisks package, mark udisks for reinstallation, click on Package->Force Version, and select the 1.0.1-1build1 version (which is the old version). Then click on apply to finish the installation.
3. Remember to unclick udisks whenever Update Manager wants to install new updates, or you'll get the new version and floppy disks won't work anymore!
After the old udisks is installed (and the machine is rebooted), when you insert a floppy a cute little icon comes up on the desktop and in Nautilus (and on Disk Mounter if you have that installed). Left clicking on the icon and select Mount Floppy Disk will put an icon in Nautilus, and then you read, write, and format the floppy just like any other drive.
Thank you, peter b!!!