Ubuntu

Flash Player not working properly in 11.10

Asked by John Paton on 2011-10-27

Although Flash Player works well enough for viewing video if I visit a website which requires access to my webcam then Flash does not work properly. When the website asks for permision to access the webcam the usual Flash Settings panel appears but it is completely inoperative and the screen freezes. I do not know whether this is a flaw in the latest version of Adobe Flash or a bug introduced in Ubuntu 11.10

I would have re-installed the previous version of Flash for test purposes but I cannot find any way of doing so.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu flashplugin-nonfree Edit question
Assignee:
No assignee Edit question
Solved by:
John Paton
Solved:
2011-10-30
Last query:
2011-10-30
Last reply:
2011-10-28
Sam_ (and-sam) said : #1
John Paton (john-paton) said : #2

Thank you for the suggestion but I have tried using the general settings manager at the Flash Website on several occasions before posting my question. In the General Settings Manager, in relation to allowing access to camera and microphone, the options presented are "Always Deny" and "Always Ask". Selecting "Always Ask" makes no difference to the behaviour of Flash on my machine. The problem is that when Flash DOES ask, by bringing up the pop-up seeking permission to access camera and microphone, this pop-up is non-responsive ie the buttons and tabs do not work and the only way to clear the pop-up from the screen is to kill the page which was trying to access the camera and microphone.

The problem does not lie with the content provider since everything still works properly on another computer running an earlier version of Ubuntu. Everything worked OK in 11.04, the problem has only appeared since I upgraded to 11.10 a few days ago.

John Paton (john-paton) said : #3

MORE DETAILS>

I have now re-installed 11.04 in a dual boot with 11.10.

Flash works fine.

Right click on screen brings up Flash settings dialogue box. Selecting Global settings brings up a settings manager which allows checking and setting of Flash parameters while on 11.10 selecting Global Settings takes me to the Macromedia website and the remote settings manager which I mentioned above.

Flash is definitely broken in Ubuntu 11.10 on my machine. Don't know if it would be broken in a fresh install as opposed to an upgrade from 11.04.

I am going to go back to 11.04.

To anyone who might be thinking about this problem, thank you, but I no longer need a solution.

If you decide to go back to Ubuntu 11.10, this problem can probably be solved without too much trouble. Probably.

However, since the problem is resolved for you now by downgrading, please mark this question as Solved so that people know you no longer want help. You do not have to mark any particular answer as the solution, when you do this. You can mark it as Solved at https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/176541. If you ever experiencing this same problem again, you can reopen this question. (If you experience other problems, you should open a new, separate question instead.)

John Paton (john-paton) said : #5

Thank you

Eliah,

I'm having the same identical problem as John on my new Oneiric machine and need a fix or workaround to remain on Oneiric. It exhibits the same behavior in both Chrome (16.0.912.20 dev) and Firefox (7.01) with Adobe (11,2,202,19).
You Tube and all videos work fine but it freezes when accessing the webcam not allowing clicks on anything. I also have it working properly on my Ubuntu 11.04 machine.

John

@John S. Blenke
Please create a new question for your Flash problem (https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+addquestion). In it, please describe the problem, and also include a link to this question. Please also post a comment here, and feel free to subscribe me to the new question. If nobody else gets to it first, I'll try to help you out in the new question.

munz (munzerelli) said : #8

@Eliah,

i feel this marked as "solved" is wrong. asking for this to be marked as solved is WRONG. a joke. you answer did not solve it. the user DOWNGRADED! this is NOT solved! it is WORKED AROUND! the question is now "solved" so people come hear to read this crap! please remove "solved"

-200 points bro!

@munz
You may *feel* that it is wrong for this to be marked as Solved, but Solved means that the creator of the question considers the problem resolved and is no longer requesting assistance. I would encourage you to look at how it is actually used in numerous questions here on Launchpad (and not just question with which I have been involved).

Questions with Solved status are not more available as search results than questions with Open, Answered, or Needs Information statuses.

Furthermore, there is no clear distinction between solving a problem and working around it, for questions. (For bugs, there is a clear distinction.) That's why there is no Worked Around status.

In the future, I would encourage you to avoid using capitalization for emphasis, unless your objective is actually to upset others and prevent them from taking you seriously. Capitalization of whole words indicates screaming, and is quite rude. You can include words in *stars* (or **stars** for more emphasis).

Michele (m-meknet) said : #10

I found a workaround that may help those who must work with the Flash plugin .. uses Unity 2D !!!
is not the best, but better than nothing ..

Michele (m-meknet) said : #11

Another workaround is:
- Right-click on the flash window,
- select "global settings" -> "webcam and microphone" click on the button "webcam and microphone settiings ..." and give the permissions to the site ..

tested on Firefox and chrome.

I hope this can help some desperate as me ..

cajunlibra (rossmkennedy) said : #12

@Michele, your workaround using the global settings didn't work for me. I've authorized the site and the popup is still unusable.

Michele (m-meknet) said : #13

@cajunlibra, I tested it on Ubuntu 11.10, firefox 8.0 ( $ firefox -v ) and Adobe Flash player 11.1.102.55.
 I also followed the instructions to install Adobe non free at : https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/177128, and in General settings of camera and microphone ( camera and microphone settings based on the site ), I have 3 options : Deny, Ask and Allow , than using Allow for target web site, flash webcam start fine for me ..

I hope this help

munz (munzerelli) said : #14

@Eliah,

plz excuse my frustration. the "solved" status ***needs to be changed*** it should be deferred or more appropriately "gave up". this frustration is more with the process than you. sorry. i do think it is very misleading and sad. *******nothing was solved******** these things must be fixed before 12.04 and pretending they are solved solves nothing and works agianst the oss software and ubuntu as a whole. just sayin. sorry for taking it out on you.

for me, i logged in to 2d and went to the sited i needed tha cam to work in and added them. now they work in unity 3d fine

<3

munz (munzerelli) said : #15

@Eliah,

plz excuse my frustration. the "solved" status ***needs to be changed*** it should be deferred or more appropriately "gave up". this frustration is more with the process than you. sorry. i do think it is very misleading and sad. *******nothing was solved******** these things must be fixed before 12.04 and pretending they are solved solves nothing and works agianst the oss software and ubuntu as a whole. just sayin. sorry for taking it out on you.

for me, i logged in to 2d and went to the sited i needed tha cam to work in and added them. now they work in unity 3d fine

<3

munz (munzerelli) said : #16

*site

 @cajunlibra, try 2d and save

Todd Cole (tcole3737) said : #17

agreed, I too have the same problem the global setting does work both in 11.10 64bit and 12.04 64 bit
only if I set indevidual sites to always allow but that is a poor way to do it. I should be able to have it ask
before it is allowed. and since it did work using 10.10 and 11.04 with the same verion af flash I assune itdue to a change in Ubuntu/Unity not flash. and should be fixed before 12.04 LTS is released.

Matthijs ten Kate (igadget) said : #18

This issue has already been reported, see Bug 865672. Let's hope it's fixed in time before 12.04 becomes final...