Flash Player not working in Ancestry.com

Asked by John S. Blenke on 2011-11-01

I use a paid site, Ancestry.com. Starting a couple of weeks ago, when I try to open an Ancestry document to view, it gives the message "This page requires the Adobe Flash Viewer . . . " Synaptic shows: Flash plugin-installer NO, Adboe-flashplugin YES, Acroread YES, Adobe-flash-properties gtk YES, Acroread common YES. The plugins options in Foxfire shows Adobe 9.4, but I disabled it.

Any recommendations?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu flashplugin-nonfree Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-01
Last reply:
2011-12-10

Does the problem occur if you log in to your Ubuntu system using a different user account? If you only have one account, you can create a second one, for testing purposes. (This is a diagnostic step to help figure out where the problem lies, so we can fix it. I am not suggesting that using a second account would be a satisfactory solution.)

Also, please open a Terminal window (Ctrl+Alt+T) and run this command by copying it to the clipboard, pasting it into the Terminal, and pressing enter:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|lightspark'

Then select all the text in the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here.

john@john-NV59:~$ lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|lightspark'
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux john-NV59 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
ii flashplugin-downloader:i386 11.0.1.152ubuntu1 Adobe Flash Player plugin downloader
john@john-NV59:~$

I created a new administrator account and logged in ... same issue exists. Also logged on with a Guest non-Admin account and ... same issue exists.

It might fix the problem to run this command in the Terminal (make sure to copy it from https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/177128 rather than your email, so that it gets copied as one line)...

sudo apt-get update; sudo apt-get -y upgrade; sudo apt-get purge flashplugin-downloader

...and then install the package called adobe-flashplugin in the Software Center.

If that doesn't work, then please post another reply, including the text from the Terminal, after running this additional command (which you will notice is similar to something you ran before...but this is to inspect the recent changes):

dpkg -l | egrep 'flash|gnash|swf|lightspark'

john@john-NV59:~$ dpkg -l | egrep 'flash|gnash|swf|lightspark'
ii flashplugin-downloader:i386 11.0.1.152ubuntu1 Adobe Flash Player plugin downloader
ii flashplugin-installer 11.0.1.152ubuntu1 Adobe Flash Player plugin installer
john@john-NV59:~$

OK, Success on the Firefox 7.01 front ... works successfully there now.

Chrome (16.0.912.20 dev) just white screens, as if in search of something Adobe *-(

Now that I have Firefox working, I can hack a bit on the latest Chrome with their support, unless you ave any other ideas.

Thank you for your time and assistance!

John

It looks like you installed the flashplugin-installer package in the Software Center, rather than the adobe-flashplugin package. The latter tends to work better on 64-bit machines running Oneiric (like yours), because it provides the 64-bit version of the plugin, which better utilizes your system resources and also seems more stable (for unknown reasons pertaining probably to the way it is engineered, but perhaps because it uses the native 64-bit libraries. Adobe Flash is proprietary software with secret source code, so it's hard to say more).

Open your Software Sources window. One way to do this is in the Software Center. Another is to run "gksu software-properties-gtk". Enable the partner repository, if it is not already enabled. Then, in the Terminal, run:

sudo apt-get purge flashplugin-downloader flashplugin-installer; sudo apt-get update; sudo apt-get install adobe-flashplugin

(Copy that command from https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/177128 and not your email, to prevent a spurious linebreak from being inserted.)

Then close all browser windows and go back in to your browsers, and see if that fixes the problem.

If that change makes things worse, then to restore the old configuration that was like what you just had, run:

sudo apt-get purge adobe-flashplugin adobe-flash-properties-gtk; sudo apt-get update; sudo apt-get install flashplugin-installer

(Again, copy that from the Launchpad website rather than your email.)

Like before, close all browser windows and then go back into your browser, if you make that change.

Whichever setup you end up using, if the problem persists in Chrome, the first thing to do is to see whether or not it occurs in Chrome after logging on to your Ubuntu system with a different user account. This may be a new problem, or at least a different variant on the old problem, and there may be more than one factor at play causing it.

Can you give the output of:

apt-cache search adobe

Thanks

cajunlibra (rossmkennedy) said : #8

I'm having the same problem on all user profiles as well, although I'm using the 32bit version. Worked fine on 11.04.
Should I do the same thing for my machine?

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|lightspark'
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux RossLaptop 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:25:36 UTC 2011 i686 i686 i386 GNU/Linux
ii adobe-flash-properties-gtk 11.1.102.55-0natty1 GTK+ control panel for Adobe Flash Player plugin version 11
ii adobe-flashplugin 11.1.102.55-0natty1 Adobe Flash Player plugin version 11
rc flashplugin-downloader 11.0.1.152ubuntu1 Adobe Flash Player plugin downloader

ok then run:

sudo dpkg -P flashplugin-downloader

To clean up, looks fine otherwise.

cajunlibra (rossmkennedy) said : #10

I just ran that command and then restarted my browser and it didn't fix the issue for me. I failed to mention that I am running FF 8.0.

I did notice that for whatever reason, flash was showing natty instead of oneiric. I went into my sources.list and changed natty to oneiric at
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-backports main restricted universe multiverse

I then ran and restarted my browser. Still no change. It didn't seem to cause any problems.
sudo apt-get update; sudo apt-get -y upgrade

0N3_xyz (tophitter225) said : #11

Same thing happens to me if I switch to gnome-shell or classic gnome login problem is solved it's only happening on Unity.

0N3_xyz (tophitter225) said : #12

Suppose there not going to bother there holes to fix this or possibly not capable its obviously a Unity issue......

Flash is nothing to do with Unity.

0N3_xyz (tophitter225) said : #14

It's only happening on Unity, Gnome its no problem using same browsers. I have tried Midori, Chromium, Google Chrome & Firefox all work perfect on Gnome 3 none of them allow me to use the flash control panel I suggest you look it up on Ubuntu Forums this is effecting alot of people on Unity and nothing else.

Unity is a shell for gnome3, so by using Unity you are also using gnome 3.

Can you help with this problem?

Provide an answer of your own, or ask John S. Blenke for more information if necessary.

To post a message you must log in.