Ubuntu

package flashplugin-installer 10.3.183.7ubuntu0.11.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Asked by Ranjit Susal on 2011-08-27

my ubuntu UI is not working properly because i tried to install gnome 3 after that some packages are not installing
and totally my ubuntu UI is messed up
and recently beta version also got some installation problem
is it possible to get back ubuntu unity UI without re-install of ubuntu

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: flashplugin-installer 10.3.183.7ubuntu0.11.04.1
ProcVersionSignature: Ubuntu 2.6.38-11.48-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic i686
Architecture: i386
Date: Sat Aug 27 23:55:57 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 2
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
SourcePackage: flashplugin-nonfree
Title: package flashplugin-installer 10.3.183.7ubuntu0.11.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
UpgradeStatus: Upgraded to natty on 2011-08-11 (16 days ago)

Question information

Steve Langasek (vorlon) said : #1

The error in your logfile is:

> update-alternatives: error: /var/lib/dpkg/alternatives/xulrunner-flashplugin corrupt: line not terminated while trying to read status

This indicates filesystem corruption, not a bug in the flashplugin package. Marking this bug report as a question.

I recommend trying the steps that I detailed in post #2 at https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/172546. Then please let us know if that fixes the problem. (If it does, you can mark this question as Solved, which you can do here at https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/172547. If it doesn't, then please post a reply explaining what difference, if any, occurred.)

Can you help with this problem?

Provide an answer of your own, or ask Ranjit Susal for more information if necessary.

To post a message you must log in.