Firefox bin does not close after ending Firefox (version 3.6.23) in Ubuntu 10.04.

Asked by Peterbeter on 2011-10-12

After ending Firefox, when I try to restart Firefox (version 3.6.23) I get the message that Firefox is already running and need to restart the system. By manually closing the firefox bin in Systemmonitor /processes the problem can be overcome.
I have this problem since the latest Firefox update.

Does this problem occur when you log in as a different user? If you only have one user account, then you can create a second one for testing purposes (System > Administration > Users and Groups).

If it does not occur for another user, then you can probably fix it by resetting all your user-specific settings and profile data. To do this, first back up or export your bookmarks if you want to retain them. Then open a Terminal window (Ctrl+Alt+T) and run this command:

mv ~/.mozilla ~/.mozilla.old

There are two caveats:

(1) Do not do that if you use Thunderbird or other Mozilla suite applications like Seamonkey or Sunbird, as then you'll lose your Thunderbird emails (or personal data from whatever other Mozilla suite application you run) too. If you use Thunderbird or another non-Firefox application in the Mozilla suite, run "mv ~/.mozilla/firefox ~/.mozilla/firefox.old" (without the quotes) instead of the above command.

(2) Make sure that Firefox (and any other Mozilla suite applications) are not running, when you run the above command. (You can paste the command into the Terminal, then quit Firefox, then terminate Firefox in the System Monitor, then press enter in the Terminal to run the command.)

If the problem occurs in another user account too, or the above instructions don't fix the problem, or you have trouble following them, please feel free to post a reply. If the above instructions solve the problem, please mark this question as Solved (which you can do at https://answers.launchpad.net/ubuntu/+source/firefox/+question/174043).

marcus aurelius (adbiz) said : #2

there's a bug logged to this. there's only 2 people on the bug report, so i suggest you log a bug as well, so the developers will get on it to fix it.

press CTL+ALT+T to get into terminal, then type

ubuntu-bug firefox

"there's a bug logged to this."

Do you know what bug it is, Marcus?

"there's only 2 people on the bug report, so i suggest you log a bug as well, so the developers will get on it to fix it."

Unless the new bug report contains new information to help in writing a fix, this won't help nearly as much as finding the original bug report, using the green "This bug affects..." link near the top of the bug page to indicate you are affected, subscribing to the bug so you are notified of changes (this also indicates interest in the bug, which is not the same thing as being affected by it, but is of course not inconsistent with being affected), and posting any information you have about the bug as a comment, if it is not already present in the bug report.

If you do file your own bug report, please make sure to read https://help.ubuntu.com/community/ReportingBugs carefully first.

If you file your own bug and there is already one, nothing is likely to happen until it is identified as a duplicate of the original report and marked as such.

Also, if you file a bug about this, then in this situation it is better to invoke ubuntu-bug with the PID of the running Firefox process while Firefox has been quit but is still running in the background, than to report it by running "ubuntu-bug firefox". Initiating the report by the PID will include information about the running state of the process, which is highly relevant to this bug. The instructions in this paragraph will make sense after you have read the ReportingBugs page.

Alex Cockell (alcockell) said : #4

I've also filed bug 872714 about this - and supplied info on the running processes... as suggested above.

Same issue here - play more than one clip from Youtube - Firefox-bin has to be ended rather than File/Quit closing the app down.

Runnign other Flash sites, such as Weightwatchers or abbey.co.uk - no probs.

marcus aurelius (adbiz) said : #5

@eliah.

not sure what the bug # is. since they changed bug reporting to the processing of issung "ubuntu-bug", there's no way on getting into the bug tracker. firefox has been acting up for a few months and i got fed up. so when the problem occurred again, i filed the bug immediately. however, when i was brought to the site, i found someone else with the problem and added mine to his. whether the data collected from my report was attached or not, i can't tell you.

marcus aurelius (adbiz) said : #6

@eliah

ah, i see you linked the launchpad question to the bug. thanks for your work.

there are a few other people who posted in the last couple of days that they are having the same problem with firefox.

Peterbeter (petervanbeek-vet) said : #7

I only have had this bug after visiting sites with several Youtube visuals available. In all these cases Firefox seems not to be able to stop Firefox bin; not even after hours.
After closing Firefox bin manually the problem is over.....until....etc.
After upgrading to Firefox 7 the problem has not returned here.

I think (at least) two separate bugs have been discussed here, but I am not sure. And Peterbeter's bug seems to be fixed (not just in the sense of no longer bothering Peterbeter, but in the sense that anyone experiencing it, at least who is running the same release as Peterbeter, can probably just update their system to fix it).

@Peterbeter
Since your problem is now resolved, you can mark this question as Solved, unless you need further assistance reporting this as a bug / adding information to an existing bug report (I do recommend you consider doing one or both of these things to help the problem ultimately get solved for everyone). If you are running Ubuntu 11.04 Natty Narwhal and you obtained Firefox 7 by updating the system normally without using any PPA for Firefox, then the bug has been fixed in Natty and there is really no need to report it, except to try to help confirm the reports of others. In that case, I recommend against reporting a new bug--the new bug would just get closed as Invalid if nobody else confirmed it, or would get closed as Fix Released if someone did.

Since the problem occurred only in connection with Flash, it may be bug 872714 (thanks Alex!) rather than bug 693396. I recommend commenting briefly in both bugs describing what happened and providing the exact versions of Flash in which the bug did and did not occur, as well as indicating which release of Ubuntu you are running. You can get the current Firefox package version with the command "apt-cache policy firefox". If you don't know the old version, you can find it by inspecting /var/log/dpkg.log (make sure to indicate the version you had just before the current version, and not some even older version that the log file says you had at some point in the less recent past). You can get information about your Ubuntu release with "lsb_release -a". You can get information about installed Flash plugins with "dpkg -l | egrep 'flash|gnash|swf|lightspark'". For each of the commands listed in this paragraph, the outside containing double-quotes should be omitted when running them.

@marcus
What version of Firefox are you running, and what release of Ubuntu are you using? When you disable Flash, either by following Charlie Kravetz's instructions in https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/693396/comments/4 for using a clean profile or by temporarily uninstalling all packages providing flash plugins, does it stop the problem from occurring. If disabling Flash does prevent the problem from occurring, then what specific packages and package versions do you have providing Flash?

Also, I am not sure what you meant by, ' since they changed bug reporting to the processing of issung "ubuntu-bug", there's no way on getting into the bug tracker' but the adoption of Apport for bug reporting has in no way (or certainly *should* not have) removed any previously existing functionality in the Bugs application on Launchpad, and I was able to find the bug by browsing through the bugs related to you at https://bugs.launchpad.net/~adbiz (to get to this, go to your Launchpad user page and click Bugs). If you are having trouble accessing this, then you should post a new question about Launchpad itself (please feel free to subscribe me to such a question, if you wish). If there is a bug in Launchpad interfering with searching in the Bugs application, it may well be affecting others; posting a question about Launchpad itself detailing your problem might be an effective way to figure out if you're experiencing something that should be reported as a bug.

Peterbeter (petervanbeek-vet) said : #9

Thanks for your attention; my problem is solved now by the upgrade to Firefox 7

Here's another user who is experiencing this sort of problem on Ubuntu 10.04: https://answers.launchpad.net/ubuntu/+source/firefox/+question/174159