wifi disconnection on ubuntu 14.04 after a short while of connection

Asked by VINCENT on 2015-07-17

I have a wifi problem on my ubuntu 14.04 desktop. For a month now it usually connects to the internet for about 10 minutes before it puts me offline yet the wifi connection on the applet shows its ok. I have been using 'ping' to test the connection but at the point of disconnection it reports 'no buffer space available'. The only solution so far has been rebooting the system over and over again, which is pretty annoying while working. I have been using 14.04 since last year and the problem for me is quite recent, I have tried several proposed solutions from the forums and discussions but to no success.

Could anyone help me understand what the problem could be and how to solve it. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu broadcom-sta Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2015-07-17
Last query:
2015-07-17
Last reply:
2015-07-17

What is the output of:

sudo lshw -C network; lsb_release -a; uname -a

Thanks

VINCENT (sircenty) said : #2

here are the results of the commands,
sudo lshw -C network :

*-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 10
       serial: 68:f7:28:2e:68:8c
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:60 ioport:4000(size=256) memory:c0504000-c0504fff memory:c0500000-c0503fff
  *-network
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: 74:29:af:55:12:e9
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=3.13.0-57-generic firmware=N/A ip=192.168.43.84 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:19 ioport:3000(size=256) memory:c0400000-c0403fff

 lsb_release -a :

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.2 LTS
Release: 14.04
Codename: trusty

uname -a :

Linux wizard 3.13.0-57-generic #95-Ubuntu SMP Fri Jun 19 09:28:15 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Try:

echo "options rtl8723be fwlps=0 swlps=0" | sudo tee /etc/modprobe.d/rtl8723befix.conf > /dev/null

Reboot to test

VINCENT (sircenty) said : #4

thanks, it is working fine so far,

On Fri, Jul 17, 2015 at 1:16 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #269326 on broadcom-sta in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/broadcom-sta/+question/269326
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Try:
>
> echo "options rtl8723be fwlps=0 swlps=0" | sudo tee
> /etc/modprobe.d/rtl8723befix.conf > /dev/null
>
> Reboot to test
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/broadcom-sta/+question/269326/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/broadcom-sta/+question/269326
>
> You received this question notification because you asked the question.
>

VINCENT (sircenty) said : #5

it has solved myn too,.. what does that command do if i may ask?

It adds the text in the quotes to the filename after the tee command.

Please mark as solved if the issue is so.

VINCENT (sircenty) said : #7

Thanks actionparsnip, that solved my question.