error running apt-get

Asked by rahul prasad

Hello, When i ran the following code in Ubuntu 16.04,

user@ubuntu:~$ sudo apt-get remove gcc-arm-none-eabi

i am getting the following error message,

[sudo] password for user:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'gcc-arm-none-eabi' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
2 not fully installed or removed.
Need to get 0 B/28.2 kB of archives.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing package libcrack2:amd64 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of cracklib-runtime:
 cracklib-runtime depends on libcrack2 (>= 2.9.2-1ubuntu1); however:
  Package libcrack2:amd64 is not configured yet.

No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: error processing package cracklib-runtime (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

What has to be done? This is almost the same error every time i try to install any application through terminal.

Kindly help me out in this

Question information

English Edit question
Ubuntu apt Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

Already answered in

sudo apt-get install --reinstall libcrack2

Can you help with this problem?

Provide an answer of your own, or ask rahul prasad for more information if necessary.

To post a message you must log in.