Not able to install toolchain

Asked by rahul prasad on 2017-11-15

I tried installing this ToolChain in Ubuntu 16.04 and i get the below error message:

$sudo apt-get install gcc-arm-embedded
Reading package lists... Done
Building dependency tree
Reading state information... Done
gcc-arm-embedded is already the newest version (6-2017q2-1~xenial1).
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
2 not fully installed or removed.
Need to get 0 B/28.2 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: error processing package libcrack2:amd64 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of cracklib-runtime:
 cracklib-runtime depends on libcrack2 (>= 2.9.2-1ubuntu1); however:
  Package libcrack2:amd64 is not configured yet.

dpkg: error processing package cracklib-runtime (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 libcrack2:amd64

Kindly help me out with this

Question information

Language:
English Edit question
Status:
Solved
For:
GNU Arm Embedded Toolchain Edit question
Assignee:
No assignee Edit question
Solved by:
rahul prasad
Solved:
2017-11-15
Last query:
2017-11-15
Last reply:
2017-11-15

Hi Rahul,

As the error message indicate, this is a problem with libcrack2:amd64, not with our toolchain. Have you tried running sudo apt-get reinstall libcrack2:amd64 as suggested by the message? If that does not work, try apt-get clean before and then try the reinstall.

Best regards.

Manfred Hampl (m-hampl) said : #2

Try the command

sudo apt-get install --reinstall libcrack2

rahul prasad (rahulprasad) said : #3

Thank you, I tried to get rid of the error message after trying

sudo apt-get install --reinstall libcrack2

Now I am getting this message, when i used
$sudo apt-get update

W: The repository 'http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubuntu/dists/xenial/main/binary-amd64/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Manfred Hampl (m-hampl) said : #4

Terry Guo's PPA does not have software for Ubuntu xenial.
You have to remove this PPA from your list of repository sources.

rahul prasad (rahulprasad) said : #5

do we have any specific command for this?
should i use

$sudo ppa-purge http://ppa.launchpad.net/terry.guo/gcc-arm-embedded/ubuntu/dists/xenial/main/binary-amd64/Packages ?

Or is there any other command?

Good catch Manfred!

@Rahul: You'll first need to install ppa-purge (sudo apt-get install ppa-purge) and then you can remove Terry's PPA with sudo ppa-purge ppa:terry.guo

Then at last you will need to enable the current PPA:

1) sudo add-apt-repository ppa:team-gcc-arm-embedded/ppa
2) sudo apt-get update
3) sudo apt-get install gcc-arm-embedded

as explained on the PPA webpage [1] itself linked from the front page.

[1] https://launchpad.net/~team-gcc-arm-embedded/+archive/ubuntu/ppa

Best regards.

rahul prasad (rahulprasad) said : #7

Thank you so much :)
I got this done.