Incorrect import of translations

Asked by Павло Славинський on 2010-02-20

Translations made in Ukrainian by Serhij Dubyk were imported incorrectly, probably because of incorrect encoding.
https://translations.launchpad.net/ubuntu/jaunty/+source/synaptic/+pots/synaptic/uk/+filter?person=serhijdubyk

Please, remove this question marks and reimport translations with correct encoding. Many thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Translations Edit question
Assignee:
Ubuntu Ukrainian Translators Edit question
Last query:
2010-02-20
Last reply:
2010-06-10

This question was originally filed as bug #524819.

Jeroen T. Vermeulen (jtv) said : #1

Converting from a bug to a question, since it's a request rather than a bug report.

Adi Roiban (adiroiban) said : #2

This question was also opened on launchpad-users mailinglist

Here is my response:
https://lists.launchpad.net/launchpad-users/msg05819.html

Павло Славинський , please get in touch with Ubuntu Ukrainian translators.
https://edge.launchpad.net/~ubuntu-l10n-uk

They can fix this problem.

I have contacted Serhij February 14, he answered that he would contact Michael Vogt to fix it (possible incorrect encoded attachment with the translation).

Thus the problem should be fixed by the following import from the upstream.

Ubuntu Ukrainian translators is very anarchic so it cannot be fixed by applying to this group (IMHO).

Adi Roiban (adiroiban) said : #4

Hi yurchor and thanks for the update!

Sometimes Ubuntu developers are quite busy, and this is why Ubuntu translation teams are granted „commit” right for translations.

This problem can be solved by any member of Ubuntu Ukrainian translation team.

Yurchor, it looks like you are a member of Ubuntu Ukrainian translation team.

Can you please try to upload a correct translation file?

Kindest regards,
Adi

Hi Adi,

I am neither translation owner nor even Ubuntu user, but I can ask Serhij to upload his translation.

BTW it's very ordinary thing on LP. Some time ago developer (LT) vandalize my kpackagekit translation (I'm KDE Ukrainian coordinator), so I have to reupload it form KDE l10n. You need more QA for side uploads.

Best regards,
Yuri

banza (banza) said : #6

In http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/lucid/synaptic/lucid/revision/88?start_revid=88#po/uk.po already fixed.
I've installed/reinstalled synaptic 0.63.1ubuntu1 uk translation is broken there and look like http://2img.org.ua/images/f84d1d3553d26ec3b27ebc5910bb606c.png.

Someone else can verify this?

banza.

Adi Roiban (adiroiban) said : #7

Hi Banza,

The translation were only fixed recently and they did not reached the Langauge package updates.

To test the translations please make a download request for a MO Format file from here
https://translations.edge.launchpad.net/ubuntu/jaunty/+source/synaptic/+pots/synaptic/uk/+export

Then replace the synaptic.mo file from /usr/share/locale-langpack/uk/LC_MESSAGES/ with the download file.

Start synaptic again and see if the problem is fixed.

Cheers

banza (banza) said : #8

'????' gone. Thanks, problem fixed.

Adi Roiban (adiroiban) said : #9

Hi Banza,

Was this solved by manualy downloading the MO file or the fix is done via system updates?

banza (banza) said : #10

Manual replacement of synaptic.mo help to fix it. And now i've delete synaptic.mo then reinstall ukrainian language(uk) support and synaptic.mo(good) was recovered.
Now synaptic (uk lang) seems ok.

David Planella (dpm) said : #11

El dl 22 de 02 de 2010 a les 18:32 +0000, en/na yurchor va escriure:
> Question #102023 on Ubuntu Translations changed:
> https://answers.edge.launchpad.net/ubuntu-translations/+question/102023
>
[...]
>
> BTW it's very ordinary thing on LP. Some time ago developer (LT)
> vandalize my kpackagekit translation (I'm KDE Ukrainian coordinator), so
> I have to reupload it form KDE l10n. You need more QA for side uploads.
>

Hi Yuri,

I now understand that you are referring to bug 534915 [1]. First of all
thanks for reporting this. In the future, though, I'd like to ask you to
try to post different bug or different requests separately, and with as
much information as possible.

Having different issues mixed in the same request makes it very
difficult for those who want to solve them to track and understand them.

Thanks!

Regards,
David.

[1] https://bugs.launchpad.net/ubuntu/+source/kpackagekit/+bug/534915

David Planella (dpm) said : #12

Could someone please verify if the problem still exists? If it was solved, please mark the support request as Solved by going to https://answers.launchpad.net/ubuntu-translations/+question/102023.

Thanks!

David Planella (dpm) said : #13

Marking it as solved as per Yuri Chornoivan's request on IRC. Thanks!