I am not able to auto show onboard on lxde desktop.

Asked by sachin varadkar on 2014-05-19

Hi All,

I am using onboard on Ubuntu 12.04 Desktop version and everything seems to be working fine.
But when I am using Onboard on 12.04 LXDE version auto show is not working.

Does anyone has any idea about it?

Regards,
Sachin V.

Question information

Language:
English Edit question
Status:
Answered
For:
Onboard Edit question
Assignee:
No assignee Edit question
Last query:
2014-05-21
Last reply:
2014-05-22
Francesco Fumanti (frafu) said : #1

Are the following packages installed on your system?

libatk-adaptor
qt-at-spi
libreoffice-gtk
libreoffice-gtk3
libatk-wrapper-java

sachin varadkar (sachin-s) said : #2

Dear,

Yes, except libreoffice-gtk3 all other packages are installed.

However on the ubuntu desktop where its working we found that
libreoffice-gtk3 is not installed but still its working fine.

One more information is that when we execute onboard from console we get
following warning message.
Warning message:

*(python:2571): Wnck-WARNING **: Unhandled action type
_OB_WM_ACTION_UNDECORATE*

Regards,
Sachin V.

On Mon, May 19, 2014 at 8:46 PM, Francesco Fumanti <
<email address hidden>> wrote:

> Your question #248878 on Onboard changed:
> https://answers.launchpad.net/onboard/+question/248878
>
> Francesco Fumanti posted a new comment:
> Are the following packages installed on your system?
>
> libatk-adaptor
> qt-at-spi
> libreoffice-gtk
> libreoffice-gtk3
> libatk-wrapper-java
>
> --
> You received this question notification because you asked the question.
>

marmuta (marmuta) said : #3

LXDE is GTK-2 based, I think you'll have to set the GTK_MODULES environment variable. Add

export GTK_MODULES=gail:atk-bridge
to ~/.profile for example

or for system-wide effect

GTK_MODULES=gail:atk-bridge
to /etc/environment

There is an old related question too:
https://answers.launchpad.net/onboard/+question/195106

I'm not sure where the warning comes from, but I doubt it has an effect on auto-show. We did use libwnck briefly, though IIRC not with v0.97 from Precise. The message might even disappear if you upgrade to the latest Onboard.
https://launchpad.net/~onboard/+archive/stable

sachin varadkar (sachin-s) said : #4

Hi ,

We tried with the given setting but still we cannot get auto show
functionality working.

The onboard keyboard will show up only when we click on the option show
onboard and it get hide when we click on the hide option shown in the tray.

When we run it from console we are getting following error:

*root@hal:/home/hal# onboard** (python:2185): WARNING **:
(../../atk-adaptor/bridge.c:793):adaptor_init: runtime check failed:
(root)(python:2185): Wnck-WARNING **: Unhandled action type
_OB_WM_ACTION_UNDECORATE(python:2185): Wnck-WARNING **: Unhandled action
type _OB_WM_ACTION_UNDECORATE(python:2185): Wnck-WARNING **: Unhandled
action type _OB_WM_ACTION_UNDECORATE*

Regards,
Sachin V.

On Tue, May 20, 2014 at 2:36 AM, marmuta <
<email address hidden>> wrote:

> Your question #248878 on Onboard changed:
> https://answers.launchpad.net/onboard/+question/248878
>
> Status: Open => Answered
>
> marmuta proposed the following answer:
> LXDE is GTK-2 based, I think you'll have to set the GTK_MODULES
> environment variable. Add
>
> export GTK_MODULES=gail:atk-bridge
> to ~/.profile for example
>
> or for system-wide effect
>
> GTK_MODULES=gail:atk-bridge
> to /etc/environment
>
> There is an old related question too:
> https://answers.launchpad.net/onboard/+question/195106
>
> I'm not sure where the warning comes from, but I doubt it has an effect on
> auto-show. We did use libwnck briefly, though IIRC not with v0.97 from
> Precise. The message might even disappear if you upgrade to the latest
> Onboard.
> https://launchpad.net/~onboard/+archive/stable
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/onboard/+question/248878/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/onboard/+question/248878
>
> You received this question notification because you asked the question.
>

marmuta (marmuta) said : #5

You wrote "12.04 LXDE version" above, did you mean Lubuntu 12.04?
What's the output of these commands:
cat /etc/issue
apt-cache policy onboard

Dipak Shetye (deepak-r) said : #6

Hi,

Output of above commands:

root@hal:/home/hal# cat /etc/issue
Ubuntu 12.04.4 LTS \n \l

root@hal:/home/hal# apt-cache policy onboard
onboard:
  Installed: 0.97.0-0ubuntu4
  Candidate: 0.97.0-0ubuntu4
  Version table:
 *** 0.97.0-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.97.0-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

sachin varadkar (sachin-s) said : #7

Hi,

Output of above commands:

root@hal:/home/hal# cat /etc/issue
Ubuntu 12.04.4 LTS \n \l

root@hal:/home/hal# apt-cache policy onboard
onboard:
  Installed: 0.97.0-0ubuntu4
  Candidate: 0.97.0-0ubuntu4
  Version table:
 *** 0.97.0-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386
Packages
        100 /var/lib/dpkg/status
     0.97.0-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

Somehow we got Auto show onboard working after installing "libgail-common"
for leafpad, terminal and File manager but still its not working in Mozilla
browser.

Can you please us to figure out why its not working in Mozilla browser?

Regards,
Sachin V.

On Tue, May 20, 2014 at 1:41 PM, marmuta <
<email address hidden>> wrote:

> Your question #248878 on Onboard changed:
> https://answers.launchpad.net/onboard/+question/248878
>
> marmuta posted a new comment:
> You wrote "12.04 LXDE version" above, did you mean Lubuntu 12.04?
> What's the output of these commands:
> cat /etc/issue
> apt-cache policy onboard
>
> --
> You received this question notification because you asked the question.
>

marmuta (marmuta) said : #8

Right, libgail is necessary. I don't have a good idea what is still missing for mozilla applications, though. I got stuck with that myself before in Lubuntu. There are some general things you can check, but I suspect you already have those.

- gconftool-2 --set /desktop/gnome/interface/accessibility --type bool true

- make sure libatk-adaptor, libatk-bridge and libatk are installed.

sachin varadkar (sachin-s) said : #9

Hi,

We have libatk-adaptor and libatk installed but not sure what is
 libatk-bridge?

We don't have the path " /desktop/gnome/interface/accessibility" to execute
command
gconftool-2 --set /desktop/gnome/interface/accessibility --type bool true

We tried to install chrome browser and auto show functionality partially
worked.
It only worked for address bar and not for any textbox shown in the webpage.

Seems like some setting or package is still missing.

Do you have any idea about it?

Regards,
Sachin V.

On Tue, May 20, 2014 at 4:47 PM, marmuta <
<email address hidden>> wrote:

> Your question #248878 on Onboard changed:
> https://answers.launchpad.net/onboard/+question/248878
>
> marmuta posted a new comment:
> Right, libgail is necessary. I don't have a good idea what is still
> missing for mozilla applications, though. I got stuck with that myself
> before in Lubuntu. There are some general things you can check, but I
> suspect you already have those.
>
> - gconftool-2 --set /desktop/gnome/interface/accessibility --type bool
> true
>
> - make sure libatk-adaptor, libatk-bridge and libatk are installed.
>
> --
> You received this question notification because you asked the question.
>

marmuta (marmuta) said : #10

> We have libatk-adaptor and libatk installed but not sure what is
> libatk-bridge?
Never mind, I saw that libatk-bridge didn't exist in 12.04.

> We don't have the path " /desktop/gnome/interface/accessibility" to execute
> command
I wasn't completely sure about that. I'll have to install 12.04 to maybe figure out what is still missing. What exactly are you running? Is it an actual Lubuntu install, or did you install lubuntu-desktop manually, or did you install lxde from individual packages?

> We tried to install chrome browser and auto show functionality partially
> worked.
> It only worked for address bar and not for any textbox shown in the webpage.
Chromium from my experience doesn't support GNOME accessibility very well, if at all. I faintly remember that auto-show worked in the address bar in 12.04, but last I tried In Ubuntu 14.04 it didn't anymore. There is some old statement of intent, but the situation doesn't seem to have improved since.
http://www.chromium.org/developers/accessibility/linux-accessibility

sachin varadkar (sachin-s) said : #11

Hi,

We have installed 12.04 minimal system with LXDE manually.
Attached is info about our OS and hardware.

We finally need Mozilla to support auto show functionality.
We installed chromium just for testing purpose.

Regards,
Sachin V.

On Tue, May 20, 2014 at 9:56 PM, marmuta <
<email address hidden>> wrote:

> Your question #248878 on Onboard changed:
> https://answers.launchpad.net/onboard/+question/248878
>
> marmuta posted a new comment:
> > We have libatk-adaptor and libatk installed but not sure what is
> > libatk-bridge?
> Never mind, I saw that libatk-bridge didn't exist in 12.04.
>
> > We don't have the path " /desktop/gnome/interface/accessibility" to
> execute
> > command
> I wasn't completely sure about that. I'll have to install 12.04 to maybe
> figure out what is still missing. What exactly are you running? Is it an
> actual Lubuntu install, or did you install lubuntu-desktop manually, or did
> you install lxde from individual packages?
>
> > We tried to install chrome browser and auto show functionality partially
> > worked.
> > It only worked for address bar and not for any textbox shown in the
> webpage.
> Chromium from my experience doesn't support GNOME accessibility very well,
> if at all. I faintly remember that auto-show worked in the address bar in
> 12.04, but last I tried In Ubuntu 14.04 it didn't anymore. There is some
> old statement of intent, but the situation doesn't seem to have improved
> since.
> http://www.chromium.org/developers/accessibility/linux-accessibility
>
> --
> You received this question notification because you asked the question.
>

sachin varadkar (sachin-s) said : #12

Hi,

Pls let us know if there is any update on onboard autoshow issue?

Regards,
Sachin V.

On Tue, May 20, 2014 at 10:44 PM, Sachin VJ <email address hidden> wrote:

> Hi,
>
> We have installed 12.04 minimal system with LXDE manually.
> Attached is info about our OS and hardware.
>
> We finally need Mozilla to support auto show functionality.
> We installed chromium just for testing purpose.
>
> Regards,
> Sachin V.
>
>
> On Tue, May 20, 2014 at 9:56 PM, marmuta <
> <email address hidden>> wrote:
>
>> Your question #248878 on Onboard changed:
>> https://answers.launchpad.net/onboard/+question/248878
>>
>> marmuta posted a new comment:
>> > We have libatk-adaptor and libatk installed but not sure what is
>> > libatk-bridge?
>> Never mind, I saw that libatk-bridge didn't exist in 12.04.
>>
>> > We don't have the path " /desktop/gnome/interface/accessibility" to
>> execute
>> > command
>> I wasn't completely sure about that. I'll have to install 12.04 to maybe
>> figure out what is still missing. What exactly are you running? Is it an
>> actual Lubuntu install, or did you install lubuntu-desktop manually, or did
>> you install lxde from individual packages?
>>
>> > We tried to install chrome browser and auto show functionality partially
>> > worked.
>> > It only worked for address bar and not for any textbox shown in the
>> webpage.
>> Chromium from my experience doesn't support GNOME accessibility very
>> well, if at all. I faintly remember that auto-show worked in the address
>> bar in 12.04, but last I tried In Ubuntu 14.04 it didn't anymore. There is
>> some old statement of intent, but the situation doesn't seem to have
>> improved since.
>> http://www.chromium.org/developers/accessibility/linux-accessibility
>>
>> --
>> You received this question notification because you asked the question.
>>
>
>

marmuta (marmuta) said : #13

I've got auto-show working in firefox, although only with a workaround.

Create the file
/etc/ld.so.conf.d/lxde-firefox.conf
containing
/usr/lib/x86_64-linux-gnu/gtk-2.0/modules
and run
sudo ldconfig

I found that Firefox ignores "atk-bridge" in GTK_MODULES and even actively removes it from there. Later it attempts to load atk-bridge.so manually, but without looking in all the same paths as GTK does, and fails to find it.

Can you help with this problem?

Provide an answer of your own, or ask sachin varadkar for more information if necessary.

To post a message you must log in.