Onboard appears blank on Lubuntu 12.04

Asked by Ivan Rybolovlev on 2012-04-28

Hi! I have just upgraded my Lubuntu 11.10 to 12.04 version and Onboard was automatically updated too. But it seems doesn't work properly beacause it appears blank and no tweaks can possibly change this. I really appreciate any kind of help out there. P.S. It is strange to me, but on Lubuntu 12.04 LiveUSB Onboard is pre-installed and works fine.

Question information

Language:
English Edit question
Status:
Solved
For:
Onboard Edit question
Assignee:
No assignee Edit question
Solved by:
marmuta
Solved:
2012-05-01
Last query:
2012-05-01
Last reply:
2012-04-30
marmuta (marmuta) said : #1

Hi, could you describe what tweaks you already tried? I've just tested it, and Onboard shows up just fine here. Openbox isn't one of our target WMs (compiz, metacity, mutter), but it might largely work anyway. Auto-show doesn't seem to be supported though.

Are there any errors when you run it from a terminal:
$ onboard

What's your system language?
$ locale

Hi. I've installed ubuntu 12.04 distro, and then added lubuntu (sudo apt-get install lubuntu-desktop), and onboard woked fine (except the autoshow option). However I also have installed lubuntu 12.04 distro, and then added onboard (sudo apt-get install onboard), and I suffered the same problem than Ivan: onboard window is fully black. Maybe a theme problem?

My locale is ES_ES, and onboard in a terminal returns

WARNING: El esquema de gsettings para <<org.gnome.mosetweaks>> no está instalado
(python:2573) Wnck-WARNING : uNHANDLED ACTION TYPE _OB_WM_ACTION_UNDECORATE

Wish this helps.

Best marmuta (marmuta) said : #3

Thanks David, I've just tried it on a fresh lubuntu install and Onboard was all black there too. This fixed it:

$ sudo apt-get install python-gi-cairo

Apparently something is missing that package as a dependency, but I don't think we should add that directly to Onboard at this point.

In the end I had auto-show partially working too. Something is still missing, but it pops up for gcalctool, gnome-terminal and pkexec. Many lxde apps don't seem to support atk/at-spi2 though.

$ sudo apt-get install libatk-adaptor
$echo GTK_MODULES=atk-bridge | sudo tee -a /etc/environment

Ivan Rybolovlev (bobrybolov) said : #4

Thanks marmuta, that solved my question.

Thanks, marmuta. Tested in lubuntu and adding python-gi-cairo works.

By the way, auto-show doesn't work fine in x-terminal-emulator: Onboard unhides, but it can be moved.

marmuta (marmuta) said : #6

> By the way, auto-show doesn't work fine in x-terminal-emulator:
> Onboard unhides, but it can be moved.
Yeah, x-terminal-emulator is lxterminal on lubuntu. I couldn't get it to work with auto-show either. I'm not sure what's still missing.

B MacRAGE (s-contactbmac) said : #7

Solution provided from marmuta has solved it for me and 15 office users.

$ sudo apt-get install python-gi-cairo