Avoid starting with with screen

Asked by Per Liljeqvist on 2013-02-14

I use Midori to start up automatically in Kiosk mode when I start my Raspberry PI. The problem is that when I start it flashes with a white screen. How can I avoid that.

I guess that happens always when you start Midori. So are there a possiblity to change that?

Regards

Per Liljeqvist

Question information

Language:
English Edit question
Status:
Answered
For:
Midori Web Browser Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-14
Last reply:
2013-02-14
Paul Menzel (pm-debian) said : #1

Am Donnerstag, den 14.02.2013, 09:35 +0000 schrieb Per Liljeqvist:

> I use Midori

Which version and what distribution?

> to start up automatically in Kiosk mode when I start my Raspberry PI.
> The problem is that when I start it flashes with a white screen. How
> can I avoid that?

Could you please post a video demonstrating this issue as I am not
exactly sure what you mean.

> I guess that happens always when you start Midori. So are there a
> possibility to change that?

There is always a possibility.

Thanks,

Paul

I am using Midor1 0.4.3 running on a Raspberry PI with a distribution of Devian special for Raspberry.

At start I use the the option to start a script with this line

sudo midori --app = file:///home/pi/Raspberry_start.html -e Fullscreen

Midori will start up, but before I get the requested page, a full white screeen will be shown for a short moment. The system is used for showing captioning in the theater. I hope there is a possiblity to avoid the white screen flashing up before the presentation starts.

Regards

Per

Per Liljeqvist
mail: <email address hidden>
mobile: +46 70 6697558
web: www.dogood.se

14 feb 2013 kl. 10:46 skrev Paul Menzel:

> Your question #221858 on Midori changed:
> https://answers.launchpad.net/midori/+question/221858
>
> Status: Open => Answered
>
> Paul Menzel proposed the following answer:
> Am Donnerstag, den 14.02.2013, 09:35 +0000 schrieb Per Liljeqvist:
>
>> I use Midori
>
> Which version and what distribution?
>
>> to start up automatically in Kiosk mode when I start my Raspberry PI.
>> The problem is that when I start it flashes with a white screen. How
>> can I avoid that?
>
> Could you please post a video demonstrating this issue as I am not
> exactly sure what you mean.
>
>> I guess that happens always when you start Midori. So are there a
>> possibility to change that?
>
> There is always a possibility.
>
>
> Thanks,
>
> Paul
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/midori/+question/221858/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/midori/+question/221858
>
> You received this question notification because you asked the question.

Paul Menzel (pm-debian) said : #3

Am Donnerstag, den 14.02.2013, 10:15 +0000 schrieb Per Liljeqvist:

> I am using Midor1 0.4.3 running on a Raspberry PI with a distribution of
> Debian special for Raspberry.
>
> At start I use the the option to start a script with this line
>
> sudo midori --app=file:///home/pi/Raspberry_start.html -e Fullscreen

1. Not sure if Launchpad did it, but there should be no spaces around
the equal sign »=«.
2. You should never start such stuff as root. I guess since it is
probably not connected to a network it might be fine. But Midori should
run perfectly fine when started from the normal user.

> Midori will start up, but before I get the requested page, a full white
> screeen will be shown for a short moment.

Yes. Thanks to your command line I could reproduce it here too with
Midori 0.4.7 under Debian Sid/unstable.

> The system is used for showing captioning in the theater. I hope there
> is a possibility to avoid the white screen flashing up before the
> presentation starts.

So do you expect instant start up? I guess it will always take the
system some time – especially the Raspberry PI – to load the files for
Midori or WebKitGTK+ libraries (from a SD card(?)), to run them and then
the Web page needs to be rendered by WebKitGTK+. I guess it is there
were

Here are some more things to consider.

3. Please convert this question to a Launchpad bug report.
4. Try to reproduce (and fix) this problem under a “normal” desktop
system.
5. You need to profile the start up and find out where it takes the most
time. For example install the package `linux-tools-3.2`. (Replace 3.2
with your Linux kernel version.)
6. Does it make a difference when you started Midori already once before
or have it running in parallel?
7. Load all the files into RAM to save the time from loading them from
the SD card.
8. Get a faster SD card.
9. It could also be a WebKit problem taking too long to load your page.

Thanks,

Paul

Paul Menzel (pm-debian) said : #4

Am Donnerstag, den 14.02.2013, 10:56 +0000 schrieb Paul Menzel:

> Am Donnerstag, den 14.02.2013, 10:15 +0000 schrieb Per Liljeqvist:
>
> > I am using Midor1 0.4.3 running on a Raspberry PI with a distribution of
> > Debian special for Raspberry.
> >
> > At start I use the the option to start a script with this line
> >
> > sudo midori --app=file:///home/pi/Raspberry_start.html -e Fullscreen
>
> 1. Not sure if Launchpad did it, but there should be no spaces around
> the equal sign »=«.
> 2. You should never start such stuff as root. I guess since it is
> probably not connected to a network it might be fine. But Midori should
> run perfectly fine when started from the normal user.
>
> > Midori will start up, but before I get the requested page, a full white
> > screeen will be shown for a short moment.
>
> Yes. Thanks to your command line I could reproduce it here too with
> Midori 0.4.7 under Debian Sid/unstable.
>
> > The system is used for showing captioning in the theater. I hope there
> > is a possibility to avoid the white screen flashing up before the
> > presentation starts.
>
> So do you expect instant start up? I guess it will always take the
> system some time – especially the Raspberry PI – to load the files for
> Midori or WebKitGTK+ libraries (from a SD card(?)), to run them and then
> the Web page needs to be rendered by WebKitGTK+. I guess it is there
> were
>
> Here are some more things to consider.
>
> 3. Please convert this question to a Launchpad bug report.
> 4. Try to reproduce (and fix) this problem under a “normal” desktop
> system.
> 5. You need to profile the start up and find out where it takes the most
> time. For example install the package `linux-tools-3.2`. (Replace 3.2
> with your Linux kernel version.)

This package contains the `perf` program.

    $ cd /tmp
    $ sudo perf record midori --app=file:///home/pi/Raspberry_start.html -e Fullscreen
    $ sudo perf report

> 6. Does it make a difference when you started Midori already once before
> or have it running in parallel?
> 7. Load all the files into RAM to save the time from loading them from
> the SD card.
> 8. Get a faster SD card.
> 9. It could also be a WebKit problem taking too long to load your page.

Thanks,

Paul

Thank you for yout comments and suggestions.

What I did now was that I in the startscript moved the files used to /dev/shm. Then started Midori with the files on /dev/shm instead.
It worked of course. Maybe a little bit faster. But sitll I get a short period of White screen.

Is it possible to avoid that during the short period when Midori starts till it have loaded the page, it shows a blank screen? If not the solution to my problem is that the blank screen shouldnt be white but black instead. Is there any possiblity to change that?

Your suggestons implies that I should look at ways of finding how to start up the page in a shorter time. But even if it is fast there will, I think, be a short period when Midori will show a blank screen? And if that blank screen is white, the projector showing it will flash up for a short period. Not so nice in a dark theater :(

Regards

Per

Per Liljeqvist
mail: <email address hidden>
mobile: +46 70 6697558
web: www.dogood.se

14 feb 2013 kl. 12:15 skrev Paul Menzel:

> Your question #221858 on Midori changed:
> https://answers.launchpad.net/midori/+question/221858
>
> Paul Menzel proposed the following answer:
> Am Donnerstag, den 14.02.2013, 10:56 +0000 schrieb Paul Menzel:
>
>> Am Donnerstag, den 14.02.2013, 10:15 +0000 schrieb Per Liljeqvist:
>>
>>> I am using Midor1 0.4.3 running on a Raspberry PI with a distribution of
>>> Debian special for Raspberry.
>>>
>>> At start I use the the option to start a script with this line
>>>
>>> sudo midori --app=file:///home/pi/Raspberry_start.html -e Fullscreen
>>
>> 1. Not sure if Launchpad did it, but there should be no spaces around
>> the equal sign »=«.
>> 2. You should never start such stuff as root. I guess since it is
>> probably not connected to a network it might be fine. But Midori should
>> run perfectly fine when started from the normal user.
>>
>>> Midori will start up, but before I get the requested page, a full white
>>> screeen will be shown for a short moment.
>>
>> Yes. Thanks to your command line I could reproduce it here too with
>> Midori 0.4.7 under Debian Sid/unstable.
>>
>>> The system is used for showing captioning in the theater. I hope there
>>> is a possibility to avoid the white screen flashing up before the
>>> presentation starts.
>>
>> So do you expect instant start up? I guess it will always take the
>> system some time – especially the Raspberry PI – to load the files for
>> Midori or WebKitGTK+ libraries (from a SD card(?)), to run them and then
>> the Web page needs to be rendered by WebKitGTK+. I guess it is there
>> were
>>
>> Here are some more things to consider.
>>
>> 3. Please convert this question to a Launchpad bug report.
>> 4. Try to reproduce (and fix) this problem under a “normal” desktop
>> system.
>> 5. You need to profile the start up and find out where it takes the most
>> time. For example install the package `linux-tools-3.2`. (Replace 3.2
>> with your Linux kernel version.)
>
> This package contains the `perf` program.
>
> $ cd /tmp
> $ sudo perf record midori --app=file:///home/pi/Raspberry_start.html -e Fullscreen
> $ sudo perf report
>
>> 6. Does it make a difference when you started Midori already once before
>> or have it running in parallel?
>> 7. Load all the files into RAM to save the time from loading them from
>> the SD card.
>> 8. Get a faster SD card.
>> 9. It could also be a WebKit problem taking too long to load your page.
>
>
> Thanks,
>
> Paul
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/midori/+question/221858/+confirm?answer_id=3
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/midori/+question/221858
>
> You received this question notification because you asked the question.

Christian Dywan (kalikiana) said : #6

Per, I strongly suspect you are seeing a side effect of how Midori loads itself (open tabs, extensions, bookmarks etc.). Coincidentally I am investigating exactly this "white screen" at the moment.

I filed bug 1125476 based on the question to follow up on fixing this.

Can you help with this problem?

Provide an answer of your own, or ask Per Liljeqvist for more information if necessary.

To post a message you must log in.