When will hplip support ubuntu 12.10?

Asked by pulsatorius on 2012-10-21

I have installed hplip and then I run hp-check -r --fix. It says ubuntu 12.10 is not supported. hp-setup can't find the printer attached to the USB-port.
When will hplip in ubuntu 12.10 support ubuntu 12.10?
A piece of the output of hp-check -r:
user@computer:~$ hp-check -r

HP Linux Imaging and Printing System (ver. 3.12.6)
Dependency/Version Check Utility ver. 15

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

Saving output in log file: /home/user/hp-check.log

Initializing. Please wait...
warning: ubuntu-12.10 version is not supported. Using ubuntu-12.04 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012 GNU/Linux
 Host: ardbeg
 Proc: 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:32:08 UTC 2012 GNU/Linux
 Distribution: ubuntu 12.10

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.12.6
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for ubuntu distro 12.10 version

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-04
Last reply:
2012-11-08
jp.seixas (joaopseixas) said : #1

My Photosmart Plus worked like a charm with earlier versions, and simply does not print under 12.10...

Sanjay Kumar (sanjay-kumar14) said : #2

Hi,

Ubuntu 12.10 will be supported in our next release of HPLIP which migh happen in couple of weeks time or so.

As a temporary workaround, please
1)Download HPLIP-3.12.10a (e.g to ~/Downloads)
2)Open Terminal and go to ~/Downloads/hplip-3.12.10a
3)Open ~/Downloads/hplip-3.12.10a/installer/distros.dat and then replace "12.04" with "12.10"
4)./install.py (this will start the auto installer)

=> Reconfigure print queue with the commands in the terminal mentioned below.
       => system-config-printer (remove all print queues)
      => su -c "hp-plugin" (This will download right plugin)
       => hp-setup (It should not be run in a root mode. This command is adding print queue, make sure you select ppd name having "-ps" or "hpcups" substring)
=>Try printing now.

pulsatorius (pulsatorius) said : #3

Step 4) Fails because it can't find any printer.
su -c "hp-plugin" doesn't work in ubuntu. But sudo hp-plugin does.
hp-setup fails because it can't find the printer.
user@computer:~$ hp-setup

HP Linux Imaging and Printing System (ver. 3.12.10a)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching... (bus=usb, search=(None), desc=0)
error: No devices found on bus: usb

Sanjay Kumar (sanjay-kumar14) said : #4

Hi,

Is printer connected to USB or network? if usb then please paste the output of "lsusb" command.

Also please paste the output of "hp-setup -g" command

Hi Patrick Andersson,

Probably due to one of the reasons, Device is not detected in hp-setup using USB.

Case 1:-
         Smart install (i.e. Device as CD ROM ) might be enabled.
         1) run lsusb and check for Hewlett
             $ lsusb |grep Hewlett
             --> Bus 001 Device 017: ID 03f0:042a Hewlett-Packard ( this is an example).
         2) now run lsusb with above VID and PID info..
             $ lsusb -d 03f0:042a -v | grep bNumInterfaces (change this 03f0:042a value according to the device)
            --> if bNumInterfaces = 1 is displayed, that means smart install is enabled.
            --> disable smart install as explained in https://answers.launchpad.net/hplip/+question/210691 comment #1

Case 2:-
         non-root user doesn't have USB permissions.
         1) run lsusb in non-root mode
             $ lsusb |grep Hewlett

         2) run lsusb in root mode
             $ sudo lsusb |grep Hewlett

         --> If device is dected only in root mode, either user is not in lp, lpadmin group or user doesn't have usb permissions.
         --> run hp-check --fix command
                $ hp-check --fix

--> if problem still persists, please post 'hp-check' command out here.

Thanks & Regards,
Amarnath

RavanH (ravanhagen) said : #6

Hi,

Apparently, bNumInterfaces = 1 is my case so I need to disable Smart Install for my printer... However, without a working Windows machine (they all break in the end, don't they) I'm cooked :(

Is there no service code I can enter on the control panel for the machine (it's an OfficeJet g85) itself to disable it manually?

RavanH (ravanhagen) said : #7

Also tried the method of replacing all 12.04 with 12.10 in ~/Downloads/hplip-3.12.10a/installer/distros.dat and re-installing (which did get me a newer interface and the printer was detected by Ubuntu on re-connection) but the device communication error code 5012 remains and print jobs remain 'on hold'...

RavanH (ravanhagen) said : #8

Finally found the answer for OfficeJet G85 on https://answers.launchpad.net/hplip/+question/216721 and https://answers.launchpad.net/hplip/+question/210089 ...

Amazing that support for older but perfectly good machines gets dropped like that without any backward compatibility or choice. Is it really impossible to support/use either libusb01 or libusb10 for different devices out of the box? Say libusb01 by default and only 10 for devices that support libusb10 communication?

Can you help with this problem?

Provide an answer of your own, or ask pulsatorius for more information if necessary.

To post a message you must log in.