Zim

Do large files, like videos, break Zim?

Asked by Ipsod on 2015-08-17

I ran into a bug with Zim. I had one page that had 5 videos inside of it. When I tried to fold/unfold the page, the index pane glitched out. The arrow next to the folder was going both down and right at the same time, and as I waved the cursor over the index, pages would appear and disappear at random. I restarted Zim, and even my computer, several times, and this did not fix it.

I removed the videos from the folder, and this fixed the issue, so I believe that they were the cause.

So, is this a known bug, and am I wrong for trying to store such large files inside of a Zim folder? Or was it, maybe, because of permission issues (I forgot to check file permissions on the videos)? I've decided, for now, to store large files elsewhere, and just link to them from Zim pages.

In case it makes any difference, my operating system is Linux Mint 17.2 KDE, and my Zim version is .63.

Question information

Language:
English Edit question
Status:
Solved
For:
Zim Edit question
Assignee:
No assignee Edit question
Solved by:
Jaap Karssenberg
Solved:
2015-08-19
Last query:
2015-08-19
Last reply:
2015-08-19

I do often store rather large files in zim notebooks as attachments, so
should not be an issue perse, but it might take the indexer a while to scan
the folder.

Working on new version of the indexer that should be more robust for these
kind of issues.

REgards,

jaap

On Tue, Aug 18, 2015 at 1:16 PM, Ipsod <<email address hidden>
> wrote:

> Question #270471 on Zim changed:
> https://answers.launchpad.net/zim/+question/270471
>
> Description changed to:
> I ran into a bug with Zim. I had one page that had 5 videos inside of
> it. When I tried to fold/unfold the page, the index pane glitched out.
> The arrow next to the folder was going both down and right at the same
> time, and as I waved the cursor over the index, pages would appear and
> disappear at random. I restarted Zim, and even my computer, several
> times, and this did not fix it.
>
> I removed the videos from the folder, and this fixed the issue, so I
> believe that they were the cause.
>
> So, is this a known bug, and am I wrong for trying to store such large
> files inside of a Zim folder? Or was it, maybe, because of permission
> issues (I forgot to check file permissions on the videos)? I've
> decided, for now, to store large files elsewhere, and just link to them
> from Zim pages.
>
> In case it makes any difference, my operating system is Linux Mint 17.2
> KDE, and my Zim version is .63.
>
> --
> You received this question notification because you are an answer
> contact for Zim.
>

Ipsod (ipsod) said : #2

That could be the issue. My Zim folder is half a gig, but those video files added another gig or so.

Ipsod (ipsod) said : #3

Thanks Jaap Karssenberg, that solved my question.