Ubuntu 18.04.02&16.04.6

Asked by huyang on 2019-03-05

Dear yade-team:
I've been installing yade for several days, but no matter what i did, it always failed.
I just finally found that the reason is Ubuntu had release Ubuntu 18.04.02&16.04.6 at 27th,Feb , so all the download Ubuntu desk are these two.
May be both of it have not been support by Yade is the reason I failed ?

Question information

Language:
English Edit question
Status:
Solved
For:
Yade Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Caulk
Solved:
2019-03-06
Last query:
2019-03-06
Last reply:
2019-03-06

This question was reopened

Robert Caulk (rcaulk) said : #1

>I've been installing yade for several days, but no matter what i did, it always failed.

I'm confused. I answered two of your Yade install questions in the past 2 days and you marked both of them as "solved"[1][2]. Did something not work?

>May be both of it have not been support by Yade is the reason I failed ?

 Yade is packaged for Xenial and Bionic (et al) [3].

[1]https://answers.launchpad.net/yade/+question/678888
[2]https://answers.launchpad.net/yade/+question/678950
[1]http://yade-dem.org/packages/

huyang (huyang960926) said : #2

Thaks a lot.
Each of the problem has been solved,but there's always some new problem come out,so i change my Ubuntu system from 18.04.02to 16.04.06,but i found some new coming out .
So i m thinking what's happen to my computer or the packages have some problem.
As for Yade has packaged for Xenial and Bionic, im going to try another computer to install yade .
Really thank you,Robert, for answering my question clearly.

Hi,
The package yadedaily for 18.04 is broken unfortunately (or is it just me?).
However you should be able to install "yade" (v2018.02b-1), which is almost as up-to-date as yadedaily.
For 16.04 both should work.

Your question is quite obscure:
> " it always failed... there's always some new problem come out... i change my Ubuntu system ... i found some new coming out ."

That's not describing any problem...
As for the solution:
> "im going to try another computer to install yade"

I doubt it will be any better.

huyang (huyang960926) said : #4

Hi ,it's me again.
It's sad to see that on another computer yade still cannot install,
That is my order to type the code
1\ sudo apt-get install git
2\git clone https://gitlab.com/yade-dev/trunk.git
3\build 3 new folder named trunk\build\install
4\sudo add-apt-repository ppa:yade-users/external
5\sudo apt-get update
it seems like follow
hty@hty-System-Product-Name:~$ sudo apt-get update
Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:2 http://cn.archive.ubuntu.com/ubuntu xenial InRelease
Hit:3 http://cn.archive.ubuntu.com/ubuntu xenial-updates InRelease
Ign:4 http://ppa.launchpad.net/yade-users/external/ubuntu xenial InRelease
Hit:5 http://cn.archive.ubuntu.com/ubuntu xenial-backports InRelease
Ign:6 http://ppa.launchpad.net/yade-users/external/ubuntu xenial Release
Ign:7 http://ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 Packages
Ign:8 http://ppa.launchpad.net/yade-users/external/ubuntu xenial/main i386 Packages
Ign:9 http://ppa.launchpad.net/yade-users/external/ubuntu xenial/main all Packages
Ign:10 http://ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en_US
Ign:11 http://ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en
Ign:12 http://ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:13 http://ppa.launchpad.net/yade-users/external/ubuntu xenial/main DEP-11 64x64 Icons
Ign:7 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 Packages
Ign:8 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main i386 Packages
Ign:9 http://59.80.44.100/ppa.launchpad.net/yade-users/external/ubuntu xenial/main all Packages
Ign:11 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en
Ign:10 http://120.52.51.14/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en_US
Ign:7 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 Packages
Ign:13 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main DEP-11 64x64 Icons
Ign:8 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main i386 Packages
Ign:12 http://59.80.44.98/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:9 http://59.80.44.100/ppa.launchpad.net/yade-users/external/ubuntu xenial/main all Packages
Ign:11 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en
Ign:10 http://120.52.51.14/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en_US
Ign:13 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main DEP-11 64x64 Icons
Ign:7 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 Packages
Ign:12 http://59.80.44.98/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:8 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main i386 Packages
Ign:9 http://59.80.44.100/ppa.launchpad.net/yade-users/external/ubuntu xenial/main all Packages
Ign:11 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en
Ign:10 http://120.52.51.14/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en_US
Ign:7 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 Packages
Ign:13 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main DEP-11 64x64 Icons
Ign:8 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main i386 Packages
Ign:12 http://59.80.44.98/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:9 http://59.80.44.100/ppa.launchpad.net/yade-users/external/ubuntu xenial/main all Packages
Ign:11 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en
Ign:10 http://120.52.51.14/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en_US
Err:7 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 Packages
  404 Not Found
Ign:13 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main DEP-11 64x64 Icons
Err:8 http://59.80.44.99/ppa.launchpad.net/yade-users/external/ubuntu xenial/main i386 Packages
  404 Not Found
Ign:12 http://59.80.44.98/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:9 http://59.80.44.100/ppa.launchpad.net/yade-users/external/ubuntu xenial/main all Packages
Ign:11 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en
Ign:10 http://120.52.51.14/ppa.launchpad.net/yade-users/external/ubuntu xenial/main Translation-en_US
Ign:12 http://59.80.44.98/ppa.launchpad.net/yade-users/external/ubuntu xenial/main amd64 DEP-11 Metadata
Ign:13 http://120.52.51.18/ppa.launchpad.net/yade-users/external/ubuntu xenial/main DEP-11 64x64 Icons
Reading package lists... Done
W: The repository 'http://ppa.launchpad.net/yade-users/external/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/yade-users/external/ubuntu/dists/xenial/main/binary-amd64/Packages 404 Not Found
E: Failed to fetch http://ppa.launchpad.net/yade-users/external/ubuntu/dists/xenial/main/binary-i386/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

6\ i input
hty@hty-System-Product-Name:~$ sudo apt-get install cmake git freeglut3-dev libloki-dev \
> libboost-all-dev fakeroot dpkg-dev build-essential g++ \
> python-dev ipython python-matplotlib libsqlite3-dev python-numpy python-tk gnuplot \
> libgts-dev python-pygraphviz libvtk6-dev python-numpy libeigen3-dev \
> python-xlib python-pyqt5 pyqt5-dev-tools python-pyqt5.qtwebkit gtk2-engines-pixbuf python-argparse python-pyqt5.qtsvg \
> libqglviewer-dev python-imaging libjs-jquery python-sphinx python-git python-bibtex \
> libxmu-dev libxi-dev libcgal-dev help2man libbz2-dev zlib1g-dev python-minieigen

7\
I Find "Software & Updates"
Click "Other Software" tab
Unclick http://ppa.launchpad.net/yade-users/external/ubuntu
And do it again,like follow:
hty@hty-System-Product-Name:~$ sudo apt-get update
Hit:1 http://cn.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:3 http://cn.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:4 http://cn.archive.ubuntu.com/ubuntu xenial-backports InRelease
*** Error in `appstreamcli': double free or corruption (fasttop): 0x00000000017b8150 ***
======= Backtrace: =========
/lib/x86_64-linux-gnu/libc.so.6(+0x77725)[0x7faa2138f725]
/lib/x86_64-linux-gnu/libc.so.6(+0x7ff4a)[0x7faa21397f4a]
/lib/x86_64-linux-gnu/libc.so.6(cfree+0x4c)[0x7faa2139babc]
/usr/lib/x86_64-linux-gnu/libappstream.so.3(as_component_complete+0x439)[0x7faa21713d19]
/usr/lib/x86_64-linux-gnu/libappstream.so.3(as_data_pool_update+0x44a)[0x7faa21714f0a]
/usr/lib/x86_64-linux-gnu/libappstream.so.3(as_cache_builder_refresh+0x1c2)[0x7faa2170a272]
appstreamcli(ascli_refresh_cache+0x12e)[0x4049de]
appstreamcli(as_client_run+0x6fb)[0x403ceb]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0)[0x7faa21338830]
appstreamcli(_start+0x29)[0x403519]
======= Memory map: ========
00400000-00408000 r-xp 00000000 08:02 3932210 /usr/bin/appstreamcli
00607000-00608000 r--p 00007000 08:02 3932210 /usr/bin/appstreamcli
00608000-00609000 rw-p 00008000 08:02 3932210 /usr/bin/appstreamcli
00ae7000-0263f000 rw-p 00000000 00:00 0 [heap]
7faa18000000-7faa18021000 rw-p 00000000 00:00 0
7faa18021000-7faa1c000000 ---p 00000000 00:00 0
7faa1c14b000-7faa1cb0a000 r--p 00000000 08:02 3939313 /usr/lib/locale/locale-archive
7faa1cb0a000-7faa1e3c0000 r-xp 00000000 08:02 3934405 /usr/lib/x86_64-linux-gnu/libicudata.so.55.1
7faa1e3c0000-7faa1e5bf000 ---p 018b6000 08:02 3934405 /usr/lib/x86_64-linux-gnu/libicudata.so.55.1
7faa1e5bf000-7faa1e5c0000 r--p 018b5000 08:02 3934405 /usr/lib/x86_64-linux-gnu/libicudata.so.55.1
7faa1e5c0000-7faa1e5c1000 rw-p 018b6000 08:02 3934405 /usr/lib/x86_64-linux-gnu/libicudata.so.55.1
7faa1e5c1000-7faa1e5c5000 r-xp 00000000 08:02 10485849 /lib/x86_64-linux-gnu/libuuid.so.1.3.0
7faa1e5c5000-7faa1e7c4000 ---p 00004000 08:02 10485849 /lib/x86_64-linux-gnu/libuuid.so.1.3.0
7faa1e7c4000-7faa1e7c5000 r--p 00003000 08:02 10485849 /lib/x86_64-linux-gnu/libuuid.so.1.3.0
7faa1e7c5000-7faa1e7c6000 rw-p 00004000 08:02 10485849 /lib/x86_64-linux-gnu/libuuid.so.1.3.0
7faa1e7c6000-7faa1e8ce000 r-xp 00000000 08:02 10490349 /lib/x86_64-linux-gnu/libm-2.23.so
7faa1e8ce000-7faa1eacd000 ---p 00108000 08:02 10490349 /lib/x86_64-linux-gnu/libm-2.23.so
7faa1eacd000-7faa1eace000 r--p 00107000 08:02 10490349 /lib/x86_64-linux-gnu/libm-2.23.so
7faa1eace000-7faa1eacf000 rw-p 00108000 08:02 10490349 /lib/x86_64-linux-gnu/libm-2.23.so
7faa1eacf000-7faa1eaf0000 r-xp 00000000 08:02 10490346 /lib/x86_64-linux-gnu/liblzma.so.5.0.0
7faa1eaf0000-7faa1ecef000 ---p 00021000 08:02 10490346 /lib/x86_64-linux-gnu/liblzma.so.5.0.0
7faa1ecef000-7faa1ecf0000 r--p 00020000 08:02 10490346 /lib/x86_64-linux-gnu/liblzma.so.5.0.0
7faa1ecf0000-7faa1ecf1000 rw-p 00021000 08:02 10490346 /lib/x86_64-linux-gnu/liblzma.so.5.0.0
7faa1ecf1000-7faa1ee70000 r-xp 00000000 08:02 3934409 /usr/lib/x86_64-linux-gnu/libicuuc.so.55.1
7faa1ee70000-7faa1f070000 ---p 0017f000 08:02 3934409 /usr/lib/x86_64-linux-gnu/libicuuc.so.55.1
7faa1f070000-7faa1f080000 r--p 0017f000 08:02 3934409 /usr/lib/x86_64-linux-gnu/libicuuc.so.55.1
7faa1f080000-7faa1f081000 rw-p 0018f000 08:02 3934409 /usr/lib/x86_64-linux-gnu/libicuuc.so.55.1
7faa1f081000-7faa1f085000 rw-p 00000000 00:00 0
7faa1f085000-7faa1f088000 r-xp 00000000 08:02 10490303 /lib/x86_64-linux-gnu/libdl-2.23.so
7faa1f088000-7faa1f287000 ---p 00003000 08:02 10490303 /lib/x86_64-linux-gnu/libdl-2.23.so
7faa1f287000-7faa1f288000 r--p 00002000 08:02 10490303 /lib/x86_64-linux-gnu/libdl-2.23.so
7faa1f288000-7faa1f289000 rw-p 00003000 08:02 10490303 /lib/x86_64-linux-gnu/libdl-2.23.so
7faa1f289000-7faa1f29f000 r-xp 00000000 08:02 10490317 /lib/x86_64-linux-gnu/libgcc_s.so.1
7faa1f29f000-7faa1f49e000 ---p 00016000 08:02 10490317 /lib/x86_64-linux-gnu/libgcc_s.so.1
7faa1f49e000-7faa1f49f000 rw-p 00015000 08:02 10490317 /lib/x86_64-linux-gnu/libgcc_s.so.1
7faa1f49f000-7faa1f611000 r-xp 00000000 08:02 3934338 /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
7faa1f611000-7faa1f811000 ---p 00172000 08:02 3934338 /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
7faa1f811000-7faa1f81b000 r--p 00172000 08:02 3934338 /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
7faa1f81b000-7faa1f81d000 rw-p 0017c000 08:02 3934338 /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
7faa1f81d000-7faa1f821000 rw-p 00000000 00:00 0
7faa1f821000-7faa1f851000 r-xp 00000000 08:02 3941267 /usr/lib/x86_64-linux-gnu/libprotobuf-lite.so.9.0.1
7faa1f851000-7faa1fa50000 ---p 00030000 08:02 3941267 /usr/lib/x86_64-linux-gnu/libprotobuf-lite.so.9.0.1
7faa1fa50000-7faa1fa51000 r--p 0002f000 08:02 3941267 /usr/lib/x86_64-linux-gnu/libprotobuf-lite.so.9.0.1
7faa1fa51000-7faa1fa52000 rw-p 00030000 08:02 3941267 /usr/lib/x86_64-linux-gnu/libprotobuf-lite.so.9.0.1
7faa1fa52000-7faa1fc46000 r-xp 00000000 08:02 3941627 /usr/lib/x86_64-linux-gnu/libxapian.so.22.7.0
7faa1fc46000-7faa1fe46000 ---p 001f4000 08:02 3941627 /usr/lib/x86_64-linux-gnu/libxapian.so.22.7.0
7faa1fe46000-7faa1fe4d000 r--p 001f4000 08:02 3941627 /usr/lib/x86_64-linux-gnu/libxapian.so.22.7.0
7faa1fe4d000-7faa1fe4e000 rw-p 001fb000 08:02 3941627 /usr/lib/x86_64-linux-gnu/libxapian.so.22.7.0
7faa1fe4e000-7faa1fe6b000 r-xp 00000000 08:02 3941681 /usr/lib/x86_64-linux-gnu/libyaml-0.so.2.0.4
7faa1fe6b000-7faa2006b000 ---p 0001d000 08:02 3941681 /usr/lib/x86_64-linux-gnu/libyaml-0.so.2.0.4
7faa2006b000-7faa2006c000 r--p 0001d000 08:02 3941681 /usr/lib/x86_64-linux-gnu/libyaml-0.so.2.0.4
7faa2006c000-7faa2006d000 rw-p 0001e000 08:02 3941681 /usr/lib/x86_64-linux-gnu/libyaml-0.so.2.0.4
7faa2006d000-7faa2021e000 r-xp 00000000 08:02 3934413 /usr/lib/x86_64-linux-gnu/libxml2.so.2.9.3
7faa2021e000-7faa2041d000 ---p 001b1000 08:02 3934413 /usr/lib/x86_64-linux-gnu/libxml2.so.2.9.3
7faa2041d000-7faa20425000 r--p 001b0000 08:02 3934413 /usr/lib/x86_64-linux-gnu/libxml2.so.2.9.3
7faa20425000-7faa20427000 rw-p 001b8000 08:02 3934413 /usr/lib/x86_64-linux-gnu/libxml2.so.2.9.3
7faa20427000-7faa20428000 rw-p 00000000 00:00 0
7faa20428000-7faa2042f000 r-xp 00000000 08:02 3940667 /usr/lib/x86_64-linux-gnu/libffi.so.6.0.4
7faa2042f000-7faa2062e000 ---p 00007000 08:02 3940667 /usr/lib/x86_64-linux-gnu/libffi.so.6.0.4
7faa2062e000-7faa2062f000 r--p 00006000 08:02 3940667 /usr/lib/x86_64-linux-gnu/libffi.so.6.0.4
7faa2062f000-7faa20630000 rw-p 00007000 08:02 3940667 /usr/lib/x86_64-linux-gnu/libffi.so.6.0.4
7faa20630000-7faa20647000 r-xp 00000000 08:02 10490431 /lib/x86_64-linux-gnu/libresolv-2.23.so
7faa20647000-7faa20847000 ---p 00017000 08:02 10490431 /lib/x86_64-linux-gnu/libresolv-2.23.so
7faa20847000-7faa20848000 r--p 00017000 08:02 10490431 /lib/x86_64-linux-gnu/libresolv-2.23.so
7faa20848000-7faa20849000 rw-p 00018000 08:02 10490431 /lib/x86_64-linux-gnu/libresolv-2.23.so
7faa20849000-7faa2084b000 rw-p 00000000 00:00 0
7faa2084b000-7faa2086a000 r-xp 00000000 08:02 10490437 /lib/x86_64-linux-gnu/libselinux.so.1
7faa2086a000-7faa20a69000 ---p 0001f000 08:02 10490437 /lib/x86_64-linux-gnu/libselinux.so.1
7faa20a69000-7faa20a6a000 r--p 0001e000 08:02 10490437 /lib/x86_64-linux-gnu/libselinux.so.1
7faa20a6a000-7faa20a6b000 rw-p 0001f000 08:02 10490437 /lib/x86_64-linux-gnu/libselinux.so.1
7faa20a6b000-7faa20a6d000 rw-p 00000000 00:00 0
7faa20a6d000-7faa20a86000 r-xp 00000000 08:02 10485765 /lib/x86_64-linux-gnu/libz.so.1.2.8
7faa20a86000-7faa20c85000 ---p 00019000 08:02 10485765 /lib/x86_64-linux-gnu/libz.so.1.2.8
7faa20c85000-7faa20c86000 r--p 00018000 08:02 10485765 /lib/x86_64-linux-gnu/libz.so.1.2.8
7faa20c86000-7faa20c87000 rw-p 00019000 08:02 10485765 /lib/x86_64-linux-gnu/libz.so.1.2.8
7faa20c87000-7faa20c8a000 r-xp 00000000 08:02 3932554 /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0.4800.2
7faa20c8a000-7faa20e89000 ---p 00003000 08:02 3932554 /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0.4800.2
7faa20e89000-7faa20e8a000 r--p 00002000 08:02 3932554 /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0.4800.2
7faa20e8a000-7faa20e8b000 rw-p 00003000 08:02 3932554 /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0.4800.2
7faa20e8b000-7faa20ea3000 r-xp 00000000 08:02 10490425 /lib/x86_64-linux-gnu/libpthread-2.23.so
7faa20ea3000-7faa210a2000 ---p 00018000 08:02 10490425 /lib/x86_64-linux-gnu/libpthread-2.23.so
7faa210a2000-7faa210a3000 r--p 00017000 08:02 10490425 /lib/x86_64-linux-gnu/libpthread-2.23.so
7faa210a3000-7faa210a4000 rw-p 00018000 08:02 10490425 /lib/x86_64-linux-gnu/libpthread-2.23.so
7faa210a4000-7faa210a8000 rw-p 00000000 00:00 0
7faa210a8000-7faa21116000 r-xp 00000000 08:02 10490408 /lib/x86_64-linux-gnu/libpcre.so.3.13.2
7faa21116000-7faa21316000 ---p 0006e000 08:02 10490408 /lib/x86_64-linux-gnu/libpcre.so.3.13.2
7faa21316000-7faa21317000 r--p 0006e000 08:02 10490408 /lib/x86_64-linux-gnu/libpcre.so.3.13.2
7faa21317000-7faa21318000 rw-p 0006f000 08:02 10490408 /lib/x86_64-linux-gnu/libpcre.so.3.13.2
7faa21318000-7faa214d8000 r-xp 00000000 08:02 10490279 /lib/x86_64-linux-gnu/libc-2.23.so
7faa214d8000-7faa216d7000 ---p 001c0000 08:02 10490279 /lib/x86_64-linux-gnu/libc-2.23.so
7faa216d7000-7faa216db000 r--p 001bf000 08:02 10490279 /lib/x86_64-linux-gnu/libc-2.23.so
7faa216db000-7faa216dd000 rw-p 001c3000 08:02 10490279 /lib/x86_64-linux-gnu/libc-2.23.so
7faa216dd000-7faa216e1000 rw-p 00000000 00:00 0
7faa216e1000-7faa2172c000 r-xp 00000000 08:02 3940360 /usr/lib/x86_64-linux-gnu/libappstream.so.0.9.4
7faa2172c000-7faa2192c000 ---p 0004b000 08:02 3940360 /usr/lib/x86_64-linux-gnu/libappstream.so.0.9.4
7faa2192c000-7faa2192d000 r--p 0004b000 08:02 3940360 /usr/lib/x86_64-linux-gnu/libappstream.so.0.9.4
7faa2192d000-7faa2192e000 rw-p 0004c000 08:02 3940360 /usr/lib/x86_64-linux-gnu/libappstream.so.0.9.4
7faa2192e000-7faa21980000 r-xp 00000000 08:02 3932578 /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.4800.2
7faa21980000-7faa21b7f000 ---p 00052000 08:02 3932578 /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.4800.2
7faa21b7f000-7faa21b80000 r--p 00051000 08:02 3932578 /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.4800.2
7faa21b80000-7faa21b81000 rw-p 00052000 08:02 3932578 /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.4800.2
7faa21b81000-7faa21d01000 r-xp 00000000 08:02 3932599 /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.4800.2
7faa21d01000-7faa21f01000 ---p 00180000 08:02 3932599 /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.4800.2
7faa21f01000-7faa21f05000 r--p 00180000 08:02 3932599 /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.4800.2
7faa21f05000-7faa21f07000 rw-p 00184000 08:02 3932599 /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0.4800.2
7faa21f07000-7faa21f09000 rw-p 00000000 00:00 0
7faa21f09000-7faa22018000 r-xp 00000000 08:02 10485777 /lib/x86_64-linux-gnu/libglib-2.0.so.0.4800.2
7faa22018000-7faa22217000 ---p 0010f000 08:02 10485777 /lib/x86_64-linux-gnu/libglib-2.0.so.0.4800.2
7faa22217000-7faa22218000 r--p 0010e000 08:02 10485777 /lib/x86_64-linux-gnu/libglib-2.0.so.0.4800.2
7faa22218000-7faa22219000 rw-p 0010f000 08:02 10485777 /lib/x86_64-linux-gnu/libglib-2.0.so.0.4800.2
7faa22219000-7faa2221a000 rw-p 00000000 00:00 0
7faa2221a000-7faa22240000 r-xp 00000000 08:02 10490251 /lib/x86_64-linux-gnu/ld-2.23.so
7faa223f8000-7faa22406000 rw-p 00000000 00:00 0
7faa2241d000-7faa2241e000 rw-p 00000000 00:00 0
7faa2241e000-7faa2243d000 r--s 00000000 08:02 4456617 /usr/share/mime/mime.cache
7faa2243d000-7faa2243f000 rw-p 00000000 00:00 0
7faa2243f000-7faa22440000 r--p 00025000 08:02 10490251 /lib/x86_64-linux-gnu/ld-2.23.so
7faa22440000-7faa22441000 rw-p 00026000 08:02 10490251 /lib/x86_64-linux-gnu/ld-2.23.so
7faa22441000-7faa22442000 rw-p 00000000 00:00 0
7ffd5e4a7000-7ffd5e4c8000 rw-p 00000000 00:00 0 [stack]
7ffd5e547000-7ffd5e54a000 r--p 00000000 00:00 0 [vvar]
7ffd5e54a000-7ffd5e54c000 r-xp 00000000 00:00 0 [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]
Aborted (core dumped)
Reading package lists... Done
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh > /dev/null; fi'
E: Sub-process returned an error code

IM really sad that i failed again:(

Best Robert Caulk (rcaulk) said : #5

Why not simply type:

sudo apt-get install yade

into a terminal?

huyang (huyang960926) said : #6

I just doing as https://yade-dev.gitlab.io/trunk/installation.html said......
On this page,there is a sentence:Installation from source code is reasonable, when you want to add or modify constitutive laws, engines, functions etc. Installing the latest trunk version allows one to use newly added features, which are not yet available in packaged versions.
As for I need to type modify constitutive laws into the model, so i m trying to Installation from source code.
Does yade-daily can do the same thing? If it does, i think it's really wonderful.

Robert Caulk (rcaulk) said : #7

I would recommend to you to become familiar with Yade et al (linux, python) first. In fact, you can modify many aspects of constitutive laws with the packaged version (sudo apt-get install yade). That is why Yade is wrapped in Python, you have access to almost everything without dealing with C++ compilations.

At risk of opening a can of worms - according to our thread from two days ago [1], you successfully compiled from sources already. No?

[1]https://answers.launchpad.net/yade/+question/678888

huyang (huyang960926) said : #8

Thank you very much!
https://answers.launchpad.net/yade/+question/678888
It's the nearest try for me to install yade successfully.And that's my first time to log in launchpad and ask a question.
After doing your recommendation, the problem i asked has been solved successfully, but some new errors about Prerequisites come out soon.
As i've trying to install yade for several days and never success. i abandoned to install yade on Bionic.
But on Xenial, some questions came out too.
I'm really confused about yade&linux, for about a week ago, i just install ubuntu on my PC for the first time in my life.
There's a time, i contacted a master who had installed yade from sources successfully. He control my PC through a software named teamviewer, but he failed,either. It's him who told me about i can asking on launchpad-yade, here might have some good guys solve these problems on my computer.

Really thank you, Caulk, for answering my question so many times.

I don't understand why your sequence of commands seems to break apt-get.
But anyway, everything should be fine if you reproduce the same sequence without "sudo add-apt-repository ppa:yade-users/external".
It seems adding + removing that repository (which you definitely don't need) is the cause of the problem.
Did you exit "Software & Updates" before typing "apt-get update"?

This being said, you seem pretty far away from implementing any new contact model in C++ (or are you an experienced c++ programmer?), so "apt-get install yade" should be good enough for a while.

Bruno

huyang (huyang960926) said : #10

Thank you,Bruno.
 As a rookie to yade, i decide to install yade-daily just now, when i can use it proficiently, i shall install a yade from sources.
 Hope everything goes well to every yade learner. It's a really good software. :)

huyang (huyang960926) said : #11

Thanks Robert Caulk, that solved my question.