A question about yade-installing on ubuntu 18.04

Asked by huyang on 2019-03-05

While i'm installing, it has falled lots of times,here is a code error
said http://ppa.launchpad.net/yade-users/external/ubuntu bionic Release'
does not have a Release file., what should i do just now?
thanks a lot :)

hty@hty-System-Product-Name:~$ sudo add-apt-repository ppa:yade-
users/external
 More recent version of various external packages, which are less
functional or buggy in ubuntu repositories.
 More info: https://launchpad.net/~yade-users/+archive/ubuntu/external
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 http://cn.archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://cn.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:3 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:4 http://cn.archive.ubuntu.com/ubuntu bionic-backports InRelease
Ign:5 http://ppa.launchpad.net/yade-users/external/ubuntu bionic
InRelease
Err:6 http://ppa.launchpad.net/yade-users/external/ubuntu bionic Release
  404 Not Found [IP: 91.189.95.83 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/yade-users/external/ubuntu
bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is
therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user
configuration details.

Question information

Language:
English Edit question
Status:
Solved
For:
Yade Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Caulk
Solved:
2019-03-05
Last query:
2019-03-05
Last reply:
2019-03-05
Robert Caulk (rcaulk) said : #1
huyang (huyang960926) said : #2

Hello, robert
It seems this ppa cannot be removed by the code they given
my terminal seems like follow:

root@hty-System-Product-Name:~# sudo ppa-purge ppa:yade-users/external
Updating packages lists
E: The repository 'http://ppa.launchpad.net/yade-users/external/ubuntu bionic Release' does not have a Release file.
Warning: apt-get update failed for some reason

Best Robert Caulk (rcaulk) said : #3

GUI version:

Find "Software & Updates"
Click "Other Software" tab
Unclick http://ppa.launchpad.net/yade-users/external/ubuntu

huyang (huyang960926) said : #4

Thanks Robert Caulk, that solved my question.