Damping

Asked by Daniela on 2011-10-16

Hi,

I would like to make a damping study in my model, but I don't know how. I am using :

O.materials.append(FrictMat(young=1e7,poisson=.25,frictionAngle=0.5,density=2000,label='mat1'))

but I do not see the option to change the damping here.

Does I need to make some change in the interaction loop? I am using this one:

InteractionLoop(
        [Ig2_Sphere_Sphere_L6Geom(),Ig2_Facet_Sphere_L3Geom()],
        [Ip2_FrictMat_FrictMat_FrictPhys()],
        [Law2_L3Geom_FrictPhys_ElPerfPl()]
 )

Thanks in advance for the feedback.
Daniela

Question information

Language:
English Edit question
Status:
Answered
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-17
Last reply:
2011-10-17
Klaus Thoeni (klaus.thoeni) said : #1

Hi Daniela,

if you want to use non viscous damping which is applied to each particle
(corresponds to local damping in PFC with slightly modified equation) then you
have to specify your damping coefficient in Newtonintegrator, e.g.

O.engines=[
 ...
 InteractionLoop(
        [Ig2_Sphere_Sphere_L6Geom(),Ig2_Facet_Sphere_L3Geom()],
        [Ip2_FrictMat_FrictMat_FrictPhys()],
        [Law2_L3Geom_FrictPhys_ElPerfPl()]
  ),
 GravityEngine(...),
 NewtonIntegrator(damping=0.2),
 ...
]

HTH

Klaus

On Mon, 17 Oct 2011 05:15:49 AM Daniela wrote:
> New question #174738 on Yade:
> https://answers.launchpad.net/yade/+question/174738
>
> Hi,
>
> I would like to make a damping study in my model, but I don't know how. I
> am using :
>
> O.materials.append(FrictMat(young=1e7,poisson=.25,frictionAngle=0.5,density
> =2000,label='mat1'))
>
> but I do not see the option to change the damping here.
>
> Does I need to make some change in the interaction loop? I am using this
> one:
>
> InteractionLoop(
> [Ig2_Sphere_Sphere_L6Geom(),Ig2_Facet_Sphere_L3Geom()],
> [Ip2_FrictMat_FrictMat_FrictPhys()],
> [Law2_L3Geom_FrictPhys_ElPerfPl()]
> )
>
> Thanks in advance for the feedback.
> Daniela

Daniela (dmaionchi) said : #2

Hi Klaus,

I thought this damping in the newton integrator had to do with the integrator and not with the physical interactions between the particles.
If I simulate just the particles, I get a stable behavior for them. But in my model the particles interact with facets (a wheel rolling over the particles). In this case I don't get a stable behavior for the particles, they spring overall. I have already tried to change the damping in the newton integrator to values from 0.1 to 0.9 (is the maximal 1.0?) and the behavior is always the same.
Should I not change something in the interaction loop?

Thanks in advance
Daniela

Hi,

The law you are using is perfectly elastic-plastic. It has no viscosity.
If you want viscosity at contact you have other laws like
Law2_ScGeom_ViscElPhys_Basic.
However, if you have problems with unstable facet-spheres interactions,
viscosity at contact will probably not help.
We know that a few problems remain in facet-sphere interactions. If you
can exhibit the instability in a simple script, please open a bug and
attach the script. It will help us to solve the problems.

Yes, maximum Newton's damping is 1.

Bruno

Jérôme Duriez (jduriez) said : #4

For your information, Daniela, you can give a look at https://bugs.launchpad.net/yade/+bug/850864, that Bruno should have in mind (I think).

Can you help with this problem?

Provide an answer of your own, or ask Daniela for more information if necessary.

To post a message you must log in.