compiling YADE

Asked by Gayanindika on 2011-04-27

I have installed scons and once I try to compile Yade (0.10.0) the following error message appears.

scons: *** No SConstruct file found.
File "/usr/lib/scons/SCons/Script/Main.py", line 834, in _main

can any body give me some suggestions?

-Gayan

Question information

Language:
English Edit question
Status:
Answered
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-27
Last reply:
2011-04-27
Jérôme Duriez (jduriez) said : #1

In which folder were you when you typed "scons" ?
You have to be in the folder where you have yade sources (and thus a Sconstruct file)....

Anton Gladky (gladky-anton) said : #2

Hi,

1) 0.10.0 is a very old version. Use at least 0.60.2 or the latest,
available in the trunk [1].
2) If you use Ubuntu, I would recommend you to try packaged version
[2] to escape compilation step.

[1] https://code.launchpad.net/~yade-dev/yade/trunk
[2] https://launchpad.net/~yade-pkg/+archive/snapshots

Can you help with this problem?

Provide an answer of your own, or ask Gayanindika for more information if necessary.

To post a message you must log in.