hoq to install xpad in centos

Asked by ham on 2017-02-24

hi
i want to install xpand in centos
my command is
wget http//...tar xvjf xpad-4.8.0.tar.bz2
tar xvjf xpad-4.8.0.tar.bz2

i dont know what is additional command
please help me every one

Question information

Language:
English Edit question
Status:
Answered
For:
Xpad Edit question
Assignee:
No assignee Edit question
Last query:
2017-02-24
Last reply:
2017-02-27

cd xpad-4.8.0
./configure
make
make install (or sudo make install)

ham (fun9990) said : #2

i used this command before your answer but i had this error missage :
(gtk+-3.0 >= 3.10 gio-2.0) were not met
No package 'gtk+-3.0' found
and gio-2.0

Two development dependencies are missing, which are needed to compile Xpad:
GTK (CentoS gtk3-devel ?) and GIO (*glib2-devel ?*).

On 25 February 2017 at 22:28, ham <email address hidden>
wrote:

> Question #486068 on Xpad changed:
> https://answers.launchpad.net/xpad/+question/486068
>
> ham posted a new comment:
> i used this command before your answer but i had this error missage :
> (gtk+-3.0 >= 3.10 gio-2.0) were not met
> No package 'gtk+-3.0' found
> and gio-2.0
>
> --
> You received this question notification because your team Xpad
> Developers is an answer contact for Xpad.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~xpad-hackers
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~xpad-hackers
> More help : https://help.launchpad.net/ListHelp
>

--
Arthur Borsboom
Mob: +31629089953
Email: <email address hidden>
[image: View Arthur's LinkedIn profile]
<http://uk.linkedin.com/in/arthurborsboom>

ham (fun9990) said : #4

both of them
i am using this command
yum install -y gtk3* glib2* glib2-devel*
but when i want to re-configure this line , i get these missing error again !

From configure.ac

GTK must be v3.10 or newer
Glib must be v2.40 or newer

Is that the cause?

On 26 February 2017 at 13:03, ham <email address hidden>
wrote:

> Question #486068 on Xpad changed:
> https://answers.launchpad.net/xpad/+question/486068
>
> ham posted a new comment:
> both of them
> i am using this command
> yum install -y gtk3* glib2* glib2-devel*
> but when i want to re-configure this line , i get these missing error
> again !
>
> --
> You received this question notification because your team Xpad
> Developers is an answer contact for Xpad.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~xpad-hackers
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~xpad-hackers
> More help : https://help.launchpad.net/ListHelp
>

--
Arthur Borsboom
Mob: +31629089953
Email: <email address hidden>
[image: View Arthur's LinkedIn profile]
<http://uk.linkedin.com/in/arthurborsboom>

ham (fun9990) said : #6

how to import this package ?

Import into what? :)

Sent from my phone

On 27 Feb 2017 6:38 a.m., "ham" <email address hidden>
wrote:

> Question #486068 on Xpad changed:
> https://answers.launchpad.net/xpad/+question/486068
>
> ham posted a new comment:
> how to import this package ?
>
> --
> You received this question notification because your team Xpad
> Developers is an answer contact for Xpad.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~xpad-hackers
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~xpad-hackers
> More help : https://help.launchpad.net/ListHelp
>

ham (fun9990) said : #9

import this packages to centos OS , because i cannot use this package .
i used yum whatproviders GTK3* and GLIB2*
and install this packages , but i cannot get result and this error comes again

Do you mean that you would like Xpad to be in the default repositories of
CentOS?
If so, I have no control over the CentOS repository.

The best you can do is ask (for help by) the CentOS community.
Maybe here?

https://www.centos.org/forums

On 27 February 2017 at 13:23, ham <email address hidden>
wrote:

> Question #486068 on Xpad changed:
> https://answers.launchpad.net/xpad/+question/486068
>
> ham posted a new comment:
> import this packages to centos OS , because i cannot use this package .
> i used yum whatproviders GTK3* and GLIB2*
> and install this packages , but i cannot get result and this error comes
> again
>
> --
> You received this question notification because your team Xpad
> Developers is an answer contact for Xpad.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~xpad-hackers
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~xpad-hackers
> More help : https://help.launchpad.net/ListHelp
>

--
Arthur Borsboom
Mob: +31629089953
Email: <email address hidden>
[image: View Arthur's LinkedIn profile]
<http://uk.linkedin.com/in/arthurborsboom>

Can you help with this problem?

Provide an answer of your own, or ask ham for more information if necessary.

To post a message you must log in.