Clock position

Asked by Ray Beaven on 2018-05-16

I've edited variety.conf (after changing ownership temporarily to root) so that the value of gravity is NorthEast, but the clock is still showing at the SouthEast position. I'm only displaying wallpapers from my local storage. Have I missed something?

(Ubuntu 18.04)

Question information

Language:
English Edit question
Status:
Solved
For:
Variety Edit question
Assignee:
No assignee Edit question
Last query:
2018-05-16
Last reply:
2018-05-16
Peter Levi (peterlevi) said : #1

There are two entries in the clock_filter that you need to change (for the clock, and its shadow). You've maybe changed just one of them.

You shouldn't edit variety.conf as root, it's supposed to be owned by your user, make sure you change ownership back or Variety may not be able to read the new settings and will use defaults.

Ray Beaven (raybee) said : #2

Thanks for the quick response.

I guess the two entries you refer to are the offsets, rather than
gravity itself. Maybe I have to recalculate both pairs of offsets from
the NorthEast corner?

Also, I'm new to Ubuntu. The whole folder structure under usr is owned
by root, and the variety folder, with its config, is in usr/share. This
is why I had to change ownership to edit the config. Have I installed
incorrectly? I don't yet have enough knowledge about Ubuntu's folder
structure. I partitioned my dual boot system and have a separate home
partition, which is owned by me, but everything under the root partition
is owned by root.

Best regards,

Ray Beaven

On 16/05/2018 12:43, Peter Levi wrote:
> Your question #669096 on Variety changed:
> https://answers.launchpad.net/variety/+question/669096
>
> Status: Open => Answered
>
> Peter Levi proposed the following answer:
> There are two entries in the clock_filter that you need to change (for
> the clock, and its shadow). You've maybe changed just one of them.
>
> You shouldn't edit variety.conf as root, it's supposed to be owned by
> your user, make sure you change ownership back or Variety may not be
> able to read the new settings and will use defaults.
>

Peter Levi (peterlevi) said : #3

The Variety config file you are supposed to edit is in your home - ~/.config/variety/variety.conf.
Do not edit the one under /usr/share.

Once you see changes you make in the clock_filter setting take effect (you need to restart Variety between changes, it does not auto-reload those settings), you'll have to play with it - I don't recall the details about gravity, offsets, etc., it's easier to just poke at it till you figure out the desired config.

Ray Beaven (raybee) said : #4

Thanks again.

I now realise that ~/.config is a hidden file, and that's why I only
found the /usr/share config file. One change to gravity, and a restart
of Variety, and all is now OK.

Best regards,

Ray Beaven

On 16/05/2018 14:13, Peter Levi wrote:
> Your question #669096 on Variety changed:
> https://answers.launchpad.net/variety/+question/669096
>
> Status: Open => Answered
>
> Peter Levi proposed the following answer:
> The Variety config file you are supposed to edit is in your home - ~/.config/variety/variety.conf.
> Do not edit the one under /usr/share.
>
> Once you see changes you make in the clock_filter setting take effect
> (you need to restart Variety between changes, it does not auto-reload
> those settings), you'll have to play with it - I don't recall the
> details about gravity, offsets, etc., it's easier to just poke at it
> till you figure out the desired config.
>

Peter Levi (peterlevi) said : #5

Solved