XFCE Multiple Monitors Different Wallpapers

Asked by Jim Gregory on 2014-08-12

I have two monitors and I want to use Variety to change the wallpaper on monitor 2 only. I used to be able to accomplish this on the Xfce desktop by modifying the file ~/.config/variety/scripts/set_wallpaper and the command xfconf-query -c xfce4-desktop -p /backdrop/screen0/monitor0/image-path -s"$1" 2> /dev/null. By changing monitor0 to monitor1 the wallpaper only changed on my second monitor. I recently did a fresh re-install of my operating system and I noticed that the latest version of Variety does not include this command. I tried inserting this command, but that only resulted in no wallpapers being changed at all. I greatly appreciate any advice on how to make this happen. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Variety Edit question
Assignee:
No assignee Edit question
Solved by:
Peter Levi
Solved:
2014-08-29
Last query:
2014-08-29
Last reply:
2014-08-29
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Jim Gregory (jgregory) said : #2

I'm still having this issue.

On 08/28/2014 08:04 AM, Launchpad Janitor wrote:
> Your question #253011 on Variety changed:
> https://answers.launchpad.net/variety/+question/253011
>
> Status: Open => Expired
>
> Launchpad Janitor expired the question:
> This question was expired because it remained in the 'Open' state
> without activity for the last 15 days.
>

Best Peter Levi (peterlevi) said : #3

XFCE changed the way for setting the wallpaper and Variety was updated accordingly. You can still edit the XFCE section in ~/.config/variety/scripts/set_wallpaper. You can see what the monitor IDs are by running

xfconf-query -c xfce4-desktop -p /backdrop -l|egrep -e "screen.*/monitor.*image-path$" -e "screen.*/monitor.*/last-image$"

You may also use tips from here: http://peterlevi.com/variety/wiki/Script_xfce_three_monitor

Jim Gregory (jgregory) said : #4

Thank you very much.