My login screen has a grey box instead of blending with the theme

Asked by Denny Mathews on 2010-02-25

My kids pressed something & I'm not sure what it is. But instead of the standard the Login prompt for Ubuntu, I get this grey box with my listed users. So, if I change the login screens or desktop themes, it doesn't matter. I will always see this grey box with the list of users in them.
Any idea how to reset this so that the login users can be blended with the theme?

Thank you in advance.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu yelp Edit question
Assignee:
No assignee Edit question
Last query:
2010-02-28
Last reply:
2010-02-28
Tom (tom6) said : #1

Hi :)

At the login screen do you get a little button called "Options"? This can change the whole DE back to Gnome or lets you try out different "sessions". Beware tho because the only way to logout of some of those is by using a right-click on the desktop since they don't have useful things on taskbars sometimes.

Also it might be worth looking in

System - Administration - Login Window

perhaps the "local" tab? Sorry i can't be more helpful right now. Hopefully someone else will know exactly the right way to fix this soon

Good luck and regards from
Tom :)

delance (olivier-delance) said : #2

System->Preferences->Login screen setting

Denny Mathews (dmathews) said : #3

I'm sorry, but your responses didn't solve my problem. Actually, I really wished that I could show you a screenshot of my login screen. I will try my best to explain it further & I'm hoping that that I get my point across.
The standard login screen is purple with the users name in a black background. So, let's say you have an user account called "admin". It would be in a box in a very dark background that complements the theme colors. I don't have that at all. I have a grey or white box with the user "admin" there. So, it really stands out
The responses that you gave only changes the theme for the login screen. That part is working fine, but I can't change the login box colors to match the theme. I have no idea how my toddler kid did to change it.
Do you have any idea on how to reset it back?

raydiokno (raydiokno22) said : #4

yes we do have same problem... i just installed ubuntu 10.9 through windows, and after i installed the start up login screen has no graphical image "GUI" its a Gray BOX center and it seems to be the login page,

i try to input the password for the user and Lodding icon apears which means that i'm on the UBUNTU desktop page now but still the screen got a large gray box on it...

btw im using AMD sempron(tm) and asus motherboard with gforce 7300 GT

HOW to fix this problem please post some over here

Tom (tom6) said : #5

Hi :)

Raydiokno's comment may have helped us see what is causing this problem. Installing Ubuntu inside Windows means that Ubuntu relies on various Windows systems working flawlessly and co-operating with a rival. Not something that MicroSquish is famous for! The Wubi install is only meant as a short-term demo of Ubuntu and it sounds as though you are both about ready to get the full advantages of switching to Ubuntu.

Part 8 of section 8 in this guide
https://wiki.ubuntu.com/WubiGuide
will help you change your wobbly Wubi into a rock-solid dual-boot with Windows and Ubuntu complementing each other rather than fighting each other.

Denny i recommend trying Qimo afterwards also.
"Qimo 4 Kids is ... derived from ... Ubuntu, customised for use by children ages 3 and up. The interface has been specifically designed to be easy to navigate by the youngest of users."
Once you have migrated Ubuntu onto its own space you will easily be able to add Qimo to make yours a truly decent multi-boot system
http://distrowatch.com/table.php?distribution=qimo
Hopefully this should provide a safer place for your toddler to learn and play with your machine without risking access to the machine's "higher functions"

I must admit i haven't tried Qimo myself although i guess i really should. My recommendation for trying it relies on people i have learned to trust rather than on personal experience.

As always i would recommend trying it as a LiveCd before commiting yourself to it
https://help.ubuntu.com/community/LiveCD
and then install as a proper dual-boot
https://help.ubuntu.com/community/WindowsDualBoot

Once installed as a dual-boot we can hopefully help you set the default so that the machine defaults into Qimo (or Windows) and then has Windows (or Qimo) as the top item on the boot menu.

Please let us know how this goes!
Good luck and regards from
Tom :)

Denny Mathews (dmathews) said : #6

Thanks for the update Tom.
There's one problem though, I only have a fresh install of Ubuntu 9.10 on my system. So, my problem might be a bit different from Raydiokno's.
I've done some research and think that I possibly found a solution, but it still didn't work for me.
Check out: http://www.ubuntumini.com/2009/09/hack-karmics-gdm-login-screen.html. The login screen that I want or that I originally had is the first pic on that post. My problem is that instead of the black background for the user logins, I have a grey background with a Computer logo instead of the ubuntu logo.
I thought that I could be able to change the GDM config screen to fit the old types, so I followed the instructions. Unfortunately, I got a few errors and I wasn't able to change the background. Here are the errors that I received: (within quotes)
"** (gnome-control-center:19640): WARNING **:
error raised: [libslab_get_gconf_value: error getting /desktop/gnome/applications/main-menu/lock-down/user_modifiable_apps]

** (gnome-control-center:19640): WARNING **:
error raised: [load_xbel_store: couldn't load bookmark file [NULL]

** (gnome-control-center:19640): WARNING **: get_actions_list() - PROBLEM - Can't load gtk-theme-selector.desktop

** (gnome-control-center:19640): WARNING **: get_actions_list() - PROBLEM - Can't load gnome-cups-manager.desktop"

Then the cursor just blinks. I don't see a prompt or anything. When I press <Alt> + <F7>, the "Login Screen" settings are still the same. So, this should be a detailed listing of the problem, Tom.

Now, if I do use a LiveCD, will I loose all my data that already have. I mean will it erase all my settings and important info I have right now? Lastly, you mentioned about "qimo", do I need to have windows installed to set it up?
Once again Tom, thanks for your feedback. I hope I've explained the problem a bit more for you to understand.

Tom (tom6) said : #7

Hi :)

A LiveCd runs entirely from the Cd and doesn't touch your installed systems at all.

You can access your hard-drive from within a LiveCd session through the "Places" menu but anything you 'save' to desktop or the standard "Documents" (and such-like) folders is only saved to the Live session which gets forgotten about as soon as you shut-down.

LiveCd sessions are ideal for doing online banking or for disaster recovery scenarios where you might want to be able to see your system without being affected by it (or affecting it)

Many versions of linux have a LiveCd and that is often on the same Cd that can be used as an installer. Ubuntu likes this dual-purpose for their Cds as it makes it easier for people that are new to linux. Hopefully Qimo do the same.

Qimo does NOT need Windows but can probably cope if there is a Windows install on the system. This is really a side-issue at the moment tho. Lets try to sort the Ubuntu problem first.

Please just try a LiveCd session and let us know how that goes first.

Good luck and regards from
Tom :)

Tom (tom6) said : #8

Hi :)

I forgot to ask what type of machine this is? Is it a netbook or a desktop machine? Does it have it's own cd/dvd-drive?

Regards from
Tom :)

Denny Mathews (dmathews) said : #9

Tom,

I have a HP Pavilion Desktop. It has a Lightscribe DVD player and it's about 2 years old. I've heard good things about Ubuntu, that's why I wanted to use Ubuntu rather than Windows.
Ok, I created the LiveCD and tried it out. It does do what you mentioned but isn't there a solution other than LiveCD? I'd like to be able to fix this problem rather than mount another device for a workaround.

Denny.

Tom (tom6) said : #10

Hi :)

From the LiveCd please could you get to a command-line and give us the output of

sudo fdisk -l

where " -l" is a lower-case " -L"? This might show us if something odd is going on. Also did you try the Qimo Cd as a LiveCd?

Good luck and regards from
Tom :)

Denny Mathews (dmathews) said : #11

No, I haven't used Qimo yet. I will do that soon. I would like to address the primary issue first. I will let you know the details of Qimo CD though.

Here's what I got from using your command:
ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x7a227a22

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 23971 192547026 83 Linux
/dev/sda2 23972 24321 2811375 5 Extended
/dev/sda5 23972 24321 2811343+ 82 Linux swap / Solaris

What's next?

Denny.

Tom (tom6) said : #12

Hi :)

Errr so you only have Ubuntu on this system? No Windows? I was hoping to find you had installed Ubuntu inside Windows in the same way that Raydiokno had. I could have helped move it onto it's own partition but it looks as tho it is already setup right.

I haven't got any good answers for this and since the question is now 3 days old i think it might be best to re-post this as a new question to hopefully get attention from the front desk in the Answers Section here
https://answers.launchpad.net/ubuntu/+addquestion
also it might be worth trying to post the question at ubuntuforums and at
http://www.linuxquestions.org
Hopefully someone will find an answer for you.

You might want to copy the link to this thread just to save time by showing what has been thought of so far
https://answers.launchpad.net/ubuntu/+source/yelp/+question/102427

Good luck and regards from
Tom :)

Tom (tom6) said : #13

Hi :)

Have you been able to test the new Ubuntu 10.04 before it gets officially released?
http://www.ubuntulinux.org/testing/lucid/beta1
Trying it as a LiveCd or as an extra dual/multi-boot would be ideal. Developers and everyone are keen to try to iron out any problems before 10.04 gets officially released so you might find faster & more effective answers to your bug reports which would make 10.04 work better on your system for you

Thanks and regards from
Tom :)

Can you help with this problem?

Provide an answer of your own, or ask Denny Mathews for more information if necessary.

To post a message you must log in.