Which regxpcom binary should be used to register components for firefox-3.0b*?

Asked by Charles Duffy (M1) on 2008-03-06

I have built, and am attempting to install, libnegotiateauth for firefox-3.0 on hardy.

I understand that xulrunner-1.9-dev should be used when building extensions targeting this browser version. However, unlike the libxul-dev it replaces, xulrunner-1.9-dev does not include a regxpcom binary. (xulrunner-1.9b3 includes regxpcom.py, but this throws "xpcom.Exception: 0x-7fffbffb (-2147467259)" when run).

How should I be registering this component?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xulrunner-1.9 Edit question
Assignee:
No assignee Edit question
Solved by:
Charles Duffy (M1)
Solved:
2008-03-06
Last query:
2008-03-06
Last reply:

According to #developers on irc.mozdev.org, regxpcom is no longer supported for usage in any way.