Totem and vlc player crash with a Intel Corporation 82865G Integrated Graphics Controller (rev 02) graphic card

Asked by Omar. P on 2009-09-26

Well I when I run Totem in terminal it opens. If I open a video, Totem closes itself and this appears in terminal. I have had problems streaming videos in Totem before, usually I can't watch them, and maybe this here, is the problem. Any suggestions in what this means.

The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 97 error_code 11 request_code 132 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Last query:
2009-09-28
Last reply:
2009-10-06
Duane Hinnen (duanedesign) said : #1

What graphics card do you have?

Run the following in the Terminal (Applications > Accessories > Terminal)

lspci | grep VGA

post the output.

Omar. P (omar.p) said : #2

okay I ran the command.this is what came up.

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Sam_ (and-sam) said : #3

Assume your system is updated (they were some fixed bugs)
you may try some options.
https://wiki.ubuntu.com/X/Troubleshooting/IntelPerformance
https://wiki.ubuntu.com/X/Troubleshooting/

User options:
http://ubuntuforums.org/showthread.php?t=1143873
https://answers.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+question/64356

You also may test VLC to watch and stream videos, it's more advanced and can be used with option 'X Window System (no Xv)'.

Omar. P (omar.p) said : #4

it does the same thing with VLC.

Duane Hinnen (duanedesign) said : #5

The new xserver-xorg-video-intel driver has fixed a lot of bugs. To install:

gksudo gedit /etc/apt/sources.list

add the folowing two lines to the bottom of the file.

deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main
deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main

Save it and close it.
Go back to the Terminal and a run the following command to add the PPA's key.

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com AF1CDFA9

Then run these two commands to download and install the new driver.

sudo apt-get update
sudo apt-get dist-upgrade

Add to your /etc/x11/xorg.conf 'Devices' section

gksudo gedit /etc/x11/xorg.conf

In the 'Devices' Section add:

Option "Accel Method" "UXA"

Also I would recommend updating to the newer kernel.
This is for 32bit
wget -c http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30.5/linux-headers-2.6.30-02063005_2.6.30-02063005_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30.5/linux-headers-2.6.30-02063005-generic_2.6.30-02063005_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30.5/linux-image-2.6.30-02063005-generic_2.6.30-02063005_i386.deb

sudo dpkg -i linux-headers-2.6.30-02063005_2.6.30-02063005_all.deb linux-headers-2.6.30-02063005-generic_2.6.30-02063005_i386.deb linux-image-2.6.30-02063005-generic_2.6.30-02063005_i386.deb

This is for 64bit
wget -c http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30.5/linux-headers-2.6.30-02063005_2.6.30-02063005_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30.5/linux-headers-2.6.30-02063005-generic_2.6.30-02063005_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.30.5/linux-image-2.6.30-02063005-generic_2.6.30-02063005_amd64.deb

sudo dpkg -i linux-headers-2.6.30-02063005_2.6.30-02063005_all.deb linux-headers-2.6.30-02063005-generic_2.6.30-02063005_amd64.deb linux-image-2.6.30-02063005-generic_2.6.30-02063005_amd64.deb

Omar. P (omar.p) said : #6

How do I this part?

Add to your /etc/x11/xorg.conf 'Devices' section

gksudo gedit /etc/x11/xorg.conf

Omar. P (omar.p) said : #7

What Am I suppose to open, to add?

Add to your /etc/x11/xorg.conf 'Devices' section

gksudo gedit /etc/x11/xorg.conf

Duane Hinnen (duanedesign) said : #8

Omar,
First the correct command is:
gksudo gedit /etc/X11/xorg.conf
the x in X11 is capitalized. That is probably where the confusion is from.
sorry for the delayed response. Here is my xorg.conf. Yours will be different, but this will illustrate the 'Devices' section.

Section "Device"
 Identifier "Default Device"
 Driver "nvidia"
 Option "Accel Method" "UXA"
EndSection

Again dont copy this entire thing as this is specific to my machine. You will only need to change the line: Option "Accel Method" "UXA"

Section "Screen"
 Identifier "Default Screen"
 DefaultDepth 24
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Default Device"
 Driver "nvidia"
 Option "Accel Method" "UXA"
EndSection

Can you help with this problem?

Provide an answer of your own, or ask Omar. P for more information if necessary.

To post a message you must log in.