Intel 865G - Ubuntu 9.04 - My Solution

Asked by wilbur on 2009-03-16

With the following /etc/X11/xorg.conf file I am able to boot Ubuntu 9.04 on a Dell computer with an Intel 82865G video. Screen response is slow but far better than no Xserver.

Section "ServerLayout"
 Identifier "X.org Configured"
 InputDevice "Mouse0" "CorePointer"
 InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
 ModulePath "/usr/lib/xorg/modules"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/usr/share/fonts/X11/cyrillic"
 FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/Type1"
 FontPath "/usr/share/fonts/X11/100dpi"
 FontPath "/usr/share/fonts/X11/75dpi"
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "dri2"
 Load "record"
 Load "dri"
 Load "dbe"
 Load "glx"
 Load "extmod"
EndSection

Section "InputDevice"
 Identifier "Keyboard0"
 Driver "kbd"
EndSection

Section "InputDevice"
 Identifier "Mouse0"
 Driver "mouse"
 Option "Protocol" "auto"
 Option "Device" "/dev/input/mice"
 Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
 Identifier "Monitor0"
 VendorName "Viewsonic"
 ModelName "Monitor Model"
 Option "DPMS" "true"
        HorizSync 31.5-80
        VertRefresh 36.5-75
EndSection

Section "Device"
 VendorName "Intel Corporation"
 Identifier "82865G Integrated Graphics Controller"
 Driver "Intel"
 BusID "PCI:0:2:0"
 Option "DRI" "False"
 Option "NoAccel" "True"
 Option "AccelMethod" "UXA"
EndSection

Section "Screen"
 Identifier "Default Screen"
        Device "Intel Corporation 82865G Integrated Graphics Controller"
 Monitor "Viewsonic"
 SubSection "Display"
  Viewport 0 0
  Depth 1
  Modes "1920x1200"
 EndSubSection
 SubSection "Display"
  Viewport 0 0
  Depth 4
  Modes "1920x1200"
 EndSubSection
 SubSection "Display"
  Viewport 0 0
  Depth 8
  Modes "1920x1200"
 EndSubSection
 SubSection "Display"
  Viewport 0 0
  Depth 15
  Modes "1920x1200"
 EndSubSection
 SubSection "Display"
  Viewport 0 0
  Depth 16
  Modes "1920x1200"
 EndSubSection
 SubSection "Display"
  Viewport 0 0
  Depth 24
  Modes "1920x1200"
 EndSubSection
EndSection

Section "ServerFlags"
        Option "DontZap" "False"
EndSection

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-video-intel Edit question
Assignee:
No assignee Edit question
Last query:
2009-03-16
Last reply:
2009-03-17
wilbur (wilburgr) said : #1

I hope this helps someone or provides some ideas for finding a work around.

Bhavani Shankar (bhavi) said : #2

Thanks for the workaround...

Please post the same in (as a sticky thread perhaps)

http://ubuntuforums.org

and not as a question here

Hope you kindly do the needful

Regards

Can you help with this problem?

Provide an answer of your own, or ask wilbur for more information if necessary.

To post a message you must log in.