Mach64 (xserver-xorg-video-ati) and DRM (mach64.ko)

Asked by audiophyl

As I understand, Mach64 chipsets can handle DRI, but mach64.ko isn't built from the DRM source by default. It is possible (and simple) to build from the DRM source, but DRI will still fail because of a version mismatch:

(II) ATI(0): [drm] loaded kernel module for "mach64" driver
(II) ATI(0): [drm] DRM interface version 1.3
(II) ATI(0): [drm] created "mach64" driver at busid "pci:0000:01:00.0"
(II) ATI(0): [drm] added 8192 byte SAREA at 0xe0c8f000
(II) ATI(0): [drm] mapped SAREA 0xe0c8f000 to 0xb71f4000
(II) ATI(0): [drm] framebuffer handle = 0xe9000000
(II) ATI(0): [drm] added 1 reserved context for kernel
(EE) ATI(0): [dri] ATIDRIScreenInit failed because of a version mismatch.
[dri] mach64.o kernel module version is 2.0.0, but version 1.0 or greater is needed.
[dri] Disabling DRI.
(II) ATI(0): [drm] removed 1 reserved context for kernel
(II) ATI(0): [drm] unmapping 8192 bytes of SAREA 0xe0c8f000 at 0xb71f4000

The actual question: Is there a reason that a functional mach64.ko DRM module (that won't give a version mismatch error such as above) isn't available/included so that people using xserver-xorg-video-ati with Mach64 chipsets can have working DRI? I understand this might be outside the scope of xserver-xorg-video-ati, but I'm hoping someone maintaining this package will know more than I've been able to find through my searching.

The newest information I could find, which was still quite old, did note "security concerns", but it has been quite a while since that was noted and the architecture has changed just a tad. Even the original note of "security concerns" was quite vague. Are those concerns still justified?

Thank you!

-Philip Barton

Question information

English Edit question
Ubuntu xserver-xorg-video-ati Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
audiophyl (audiophyl) said :

Sure would be nice to have an answer to this question...

-Philip Barton

On 4/19/07, Launchpad Answers Janitor <email address hidden>
> Your question #4608 on xserver-xorg-video-ati in ubuntu changed:
> Status: Open => Expired
> Launchpad Answers Janitor expired the question:
> This question was expired because it remained in the 'Open' state
> without activity for the last 15 days.
> _______________________________________________________________________
> If you're still having this problem, you can reopen your question either
> by replying to this email or by going to the following page and
> entering more information about your problem:

Revision history for this message
Alan Pope 🍺🐧🐱 🦄 (popey) said :

Maybe it's worth looking for or filing a bug if nobody here knows?

Revision history for this message
Samuel thibault (samuel-thibault) said :

I'm getting the same error (which is quite odd: shouldn't 2.0.0 be "greater" than 1.0 ?)

Can you help with this problem?

Provide an answer of your own, or ask audiophyl for more information if necessary.

To post a message you must log in.