my mouse isn't working on ubuntu 11.10

Asked by Chenille Jacob on 2012-01-20

I downloaded the latest ubuntu 11.10 on my laptop with windows 7 on it. it looked like a total success, but when i started ubuntu, my mouse wasn't working! the keyboard is fine though. i dont know how to fix it. my mouse works just fine on the windows. help?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xserver-xorg-input-mouse Edit question
Assignee:
No assignee Edit question
Last query:
2012-01-22
Last reply:
2012-01-22

What is the make and model of the system? Why is this information not part of the initial question??

Chenille Jacob (chenille-j95) said : #2

Sorry. I'm using a lenovo Y500 laptop running on windows 7/ubuntu, 1GB RAM, 32 bit operating system, intel core 2 CPU. is that the information you wanted?

Seems to need the boot option:

i8042.reset

So if you run:

gksudo gedit /etc/default/grub; sudo update-grub

Find this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change it to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset"

Save the new file and close gedit, the update grub will then run and apply the option, reboot to test.

Chenille Jacob (chenille-j95) said : #4

I'm sorry this didn't exactly help. I'm really new to Ubuntu. Could you tell me HOW to run this thing? I don't really know how to use ubuntu. Without the mouse it just makes everything really hard.

On Jan 20, 2012, at 8:55 PM, "actionparsnip" <email address hidden> wrote:

> Your question #185311 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/185311
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Seems to need the boot option:
>
> i8042.reset
>
> So if you run:
>
> gksudo gedit /etc/default/grub; sudo update-grub
>
> Find this line:
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
>
> and change it to:
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset"
>
> Save the new file and close gedit, the update grub will then run and
> apply the option, reboot to test.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+question/185311/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+question/185311
>
> You received this question notification because you asked the question.

The command is a terminal account, you can run a terminal by pressing CTRL+ALT+T

The rest is copying and pasting which I am SURE you can do...

Chenille Jacob (chenille-j95) said : #6

When I typed this into the terminal, all I got was "gtk warning: unable to locate theme engine in module_path:"pixmap"" repeated 3 times.
Then I got "generating grub.cfg" and then "found Linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found windows 7 (loader) on /dev/sda1
Skipping windows 7 (loader) on Wubi system
Done"
What do I do? I couldn't find any thing else of that sort that I could edit. And I still can't move the mouse so all I can do is fiddle around with my keyboard. A little more help would be really appreciated! :(

Chenille Jacob (chenille-j95) said : #8

That doesn't help. I mean, I'm not getting the Gedit thing that I'm supposed to get. I'm kinda confused :/

On Jan 21, 2012, at 10:17 PM, "michael" <email address hidden> wrote:

> Your question #185311 on xserver-xorg-input-mouse in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/xserver-xorg-input-mouse/+question/185311
>
> michael posted a new comment:
> May help copy and paste with no mouse.
> http://stackoverflow.com/questions/761807/copy-and-paste-from-terminal-with-keyboard-in-linux-ubuntu
> Good luck.
>
> --
> You received this question notification because you asked the question.

copy the command I gave and press CTRL+ALT+T and paste it there, type your password and gedit will run and you can edit the file.

Can you help with this problem?

Provide an answer of your own, or ask Chenille Jacob for more information if necessary.

To post a message you must log in.