8.04 System Update hammered Nvidia drivers

Asked by OneEye on 2009-09-16

Just applied recommend system updates via systray icon, and now my Nvidia drivers are not loading.

Xorg.log.0:

    (EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
    (EE) NVIDIA(0): *** Aborting ***
    (II) UnloadModule: "nvidia"
    (II) UnloadModule: "wfb"
    (II) UnloadModule: "fb"
    (EE) Screen(s) found, but none have a usable configuration.

    Fatal server error:
    no screens found

Looks like the update somehow removed or disabled the restricted drivers. And, I cannot reinstall them with Hardware Drivers.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Solved by:
OneEye
Solved:
2009-09-21
Last query:
2009-09-21
Last reply:
2009-09-17
Kevin Hunter (hunteke) said : #1

I hate Xorg issues. They're so hard to diagnose. Do you have a usable screen, but just want to use the nVidia drivers? Or do you have no GUI at all?

DarkJavi (darkjavi) said : #2

Try "sudo dpkg-reconfigure -phigh xserver-xorg" this should go back to generic configuration, then try enabling restricted driver again.

OneEye (theshuberts) said : #3

Darkjavi - the reconfigure did its job, but the System->Administration->Jardware Drivers does not list the Nvidia drivers (which, as I recall, is the only way to get a good install of the Nvidia restricted drivers).

DarkJavi (darkjavi) said : #4

I have that issue sometime in the past, I'm trying to remember how I solved it..
In the mean time can you post the result of "cat /etc/X11/xorg.conf"

OneEye (theshuberts) said : #5

Here is the xorg.conf that worked (with the binary drivers) before the update:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@vernadsky) Thu Jun 5 09:26:53 UTC 2008

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Screen0" 0 0
EndSection

Section "Module"
    Load "glx"
EndSection

Section "ServerFlags"
    Option "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
EndSection

Section "Monitor"
    Identifier "Configured Monitor"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "SAMSUNG"
    HorizSync 30.0 - 85.0
    VertRefresh 50.0 - 160.0
EndSection

Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    Option "NoLogo" "True"
EndSection

Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce FX 5500"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device "Configured Video Device"
    Monitor "Configured Monitor"
    DefaultDepth 24
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1280+0"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "DFP-0"
    Option "metamodes" "CRT: nvidia-auto-select +1024+0, DFP: nvidia-auto-select +0+0"
EndSection

DarkJavi (darkjavi) said : #6

Looks pretty close to my xorg.conf but have the device section duplicated:

Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    Option "NoLogo" "True"
EndSection

Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce FX 5500"
EndSection

Can you post you actual xorg.conf?

OneEye (theshuberts) said : #7

Darkjavi - Thanks for your assistance, but I think that we are barking up the wrong tree here. I know that problems of this sort are often cause by xorg.conf errors, but that's not the case here.

I can say this with certainty because the xorg.conf which I posted above was functioning perfectly, with full support for Nvidia custom features including dual screen and hardware acceleration, for about a month before the update.

I am currently using a generic xorg.conf, which allows me some use of the system, but I need to get back all of the Nvidia extensions.

It's clear that the update whacked the restricted drivers. What I need to know is, how do I reactivate them? Or reinstall them?

Any help?

DarkJavi (darkjavi) said : #8

I have mainly the same setup as you: Nvidia geforce with twinview.

I don't know if this apply to your problem as I'm on karmic,but, 4 days ago an update of the libc6 messed my nvidia driver,forcing me to switch to nv driver, yesterday was fixed and I could switch back to nvidia driver. so I would try to install all updates and load back your old xorg.conf file.

OneEye (theshuberts) said : #9

Darkjavi - are you basically saying that I should wait for another update? Surely there's some way to reinstall the Nvidia drivers and get them working!

Can anyone else offer any guidance?

DarkJavi (darkjavi) said : #10

El jue, 17-09-2009 a las 00:13 +0000, OneEye escribiĆ³:
> Question #82926 on xserver-xorg-driver-nv in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/xserver-xorg-driver-nv/+question/82926
>
> Status: Answered => Open
>
> OneEye is still having a problem:
> Darkjavi - are you basically saying that I should wait for another
> update? Surely there's some way to reinstall the Nvidia drivers and get
> them working!
>
> Can anyone else offer any guidance?
>
If the same problem as mine, the update is already out! so may you try
to install all updates and put back your xorg.conf and see what happens.

Also I wold try to edit xorg.conf by hand and put in the device section:

Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
EndSection

OneEye (theshuberts) said : #11

Darkjavi - again, thanks for your persistence, but I have run update-manager several times since last night (when the problem began), and there are no new updates. Likewise, I have already made all necessary changes to xorg.conf. The problem obviously lies with last night's run of update-manager, and so I filed a new bug to document the problem.

Thanks again,

Chris

OneEye (theshuberts) said : #12

After a number of mystical reinstalls, I finally got the Nvidia driver working again. Along the way, I reinstalled nvidia-glx-new and nvidia-kernel-common, which did not seem to help the problem. I also let some nitwit talk me into "m-a a-i nvidia", which installs obsolete drivers in the kernel, but I managed to back that out after hours of painful hair-pulling.

In the end, I think it was the reinstall of linux-restricted-modules that made it work, but I had thrashed the machine so much that I seriously doubt I could come close to duplicating the process. Anyway, if your Nvidia drivers are hammered like mine were, try reinstalling linux-restricted-modules, then nvidia-glx-new, then nvidia-kernel-common. Maybe the elves will make shoes for you.