Ubuntu 10.04 LTS offers only 640x480 display resolution after installation

Asked by Wolfgang on 2010-09-26

NVIDIA GeForce 4 MX 440,
AMD Athlon XP 2000+ 512 MB
Windows XP already installed.
Ubuntu 10.04 LTS installed on free 10G partition.
Bootmanger is working fine, except from X the system is working fine.
No messages while installing the System.
What else do we need here?

after installing Ubuntu 10.04 on the the above computer the system started with VGA resolution.
System advised to install Nvididas drivers and so I did. Nviidia X server settings program is hard to handle in this mode and does not offer further options.

xrandr output is: Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480.

For XP the card runs on 1280 x 1024 and even higher resolutions are available.

Can anyone advise how to solve this problem?

Many thanks in advance

Wolfgang

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xserver-xorg-driver-nv Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2010-09-26
Last query:
2010-09-26
Last reply:
2010-09-26
Wolfgang (w-feierabend) said : #2

Sam, thank you for this hint. But still the problem is not solved because nvidia-xconfig provides only two possible resolution values, i. e. those I mentioned 320x240 and 640x480. No further selection is available although the card supports many higher resolution values. Is there a program/script to create the X configuration again from scratch?

Thanks for all your effort.

Wolfgang (w-feierabend) said : #4

Thank you very much Sam. I just forgot to restart X. Sorry. Now I think I got it.

Wolfgang (w-feierabend) said : #5

Thanks Sam, that solved my question.

Sam_ (and-sam) said : #6

Follow-up regarding Nvidia and xorg-1.9 incl. a list of concerned graphic cards: Bug #626974