Ubuntu 17.04 GCP VM Instance startx do not work

Asked by Jay on 2017-08-09

Using Google Cloud Platform Ubuntu 17.04 VM instance startx from command line do not work. Tried the following.
sudo apt-get update
sudo apt-get install ubuntu-desktop also tried ubuntu-gnome desktop

    sudo nano /etc/default/grub.
    Change line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="text"
    Ctrl - X , press Y and then Enter to save and exit.
    sudo update-grub.

Stop instance, then start instance (basically rebooting)
I get back to command-line and type "startx"

****** Get this message **********
/usr/lib/xorg/Xorg.wrap: Only console users are allowed to run the X server
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
Couldn't get a file descriptor referring to the console
What am doing wrong ?
I want to have some type of GUI on my server.

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu xorg Edit question
Assignee:
No assignee Edit question
Last query:
2017-08-09
Last reply:
2017-08-09

What do you want to do on the system that needs a GUI?

Can you help with this problem?

Provide an answer of your own, or ask Jay for more information if necessary.

To post a message you must log in.