unable to get exclusive lock

Asked by digdug on 2008-12-26

when i try to update i get the message "unable to get exclusive lock"
another package management application (like apt-get or aptitude) is already running please close that application first.
How do i know which one is running and then how do i close it? and what did i do to cause this error?
Thankyou for your help Ubuntu 8.04 rocks!!!!!!
oh and by the way the updates are sun java6-bin and sun java6-jre

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Fabián Rodríguez
Solved:
2008-12-26
Last query:
2008-12-26
Last reply:
2008-12-26
Best Fabián Rodríguez (magicfab) said : #2

Indeed, comments in https://answers.launchpad.net/ubuntu/+source/gnome-panel/+question/27524 will help you understand what's happened and work around it.

digdug (digdug1120) said : #3

this helped (kinda) LOL im not computer savy but i just faked it !!! seems to work fine

digdug (digdug1120) said : #4

Thanks Fabián Rodríguez, that solved my question.