"Could not initialize the package information"

Asked by Ben Birkinbine on 2013-01-19

Similar to other posts here, but a different package seems to be listed.

I, too, have an red circle icon with white horizontal line appearing when I start Ubuntu. I am directed to run the package manager, but I get the following message:

"An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:
E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_quantal-security_main_i18n_Translation-en, E:The package lists or status file could not be parsed or opened."

I guess I'm a bit worried because this lists security. Any help is greatly appreciated.

FYI, I'm running Ubuntu 12.10 on my new ASUS U47A-RS51 laptop.

Thanks,
B

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Ben Birkinbine
Solved:
2013-01-19
Last query:
2013-01-19
Last reply:
2013-01-19

What is the output of:

cd; wget https://dl.dropbox.com/u/8850924/fixpackage
chmod +x ./fixpackage; sudo ./fixpackage

Thanks

Ben Birkinbine (bbirkinbine) said : #3

1) Re:actionparsnip, the fixpackage seemed to do the trick. I ran fixpackage, and the red circle icon with white horizontal line disappeared from the top of my screen. Then I was asked to proceed (y/n) with the downloads (updates). I entered "y" but the packages did not download. The terminal simply said "aborted."

However, I was able to open software updater after this process, and I downloaded the available updates. Things appear to be running smoothly.

2) Re:markrijckenberg, I was unable to open "Software Sources" to complete your suggestion. After running actionparsnip's "fixpackage" suggestion, I am now able access to "software sources."

Would you still like me to proceed with your suggestion and post the Terminal output?

What is the full output of:

sudo apt-get update; sudo apt-get upgrade

Thanks

No. If the issue is now solved, please set the thread status to "solved".

Ben Birkinbine (bbirkinbine) said : #6

actionparsnip, here is the full Terminal output:

Ign http://archive.ubuntu.com quantal InRelease
Ign http://archive.ubuntu.com quantal-updates InRelease
Ign http://archive.ubuntu.com quantal-backports InRelease
Ign http://archive.ubuntu.com quantal-security InRelease
Get:1 http://archive.ubuntu.com quantal Release.gpg [933 B]
Get:2 http://archive.ubuntu.com quantal-updates Release.gpg [933 B]
Get:3 http://archive.ubuntu.com quantal-backports Release.gpg [933 B]
Get:4 http://archive.ubuntu.com quantal-security Release.gpg [933 B]
Get:5 http://archive.ubuntu.com quantal Release [49.6 kB]
Get:6 http://archive.ubuntu.com quantal-updates Release [49.6 kB]
Get:7 http://archive.ubuntu.com quantal-backports Release [49.6 kB]
Get:8 http://archive.ubuntu.com quantal-security Release [49.6 kB]
Get:9 http://archive.ubuntu.com quantal/main Sources [872 kB]
Get:10 http://archive.ubuntu.com quantal/restricted Sources [5,646 B]
Get:11 http://archive.ubuntu.com quantal/universe Sources [5,522 kB]
Get:12 http://archive.ubuntu.com quantal/multiverse Sources [166 kB]
Get:13 http://archive.ubuntu.com quantal/main amd64 Packages [1,137 kB]
Get:14 http://archive.ubuntu.com quantal/restricted amd64 Packages [8,369 B]
Get:15 http://archive.ubuntu.com quantal/universe amd64 Packages [5,274 kB]
Get:16 http://archive.ubuntu.com quantal/multiverse amd64 Packages [131 kB]
Get:17 http://archive.ubuntu.com quantal/main i386 Packages [1,136 kB]
Get:18 http://archive.ubuntu.com quantal/restricted i386 Packages [8,387 B]
Get:19 http://archive.ubuntu.com quantal/universe i386 Packages [5,285 kB]
Get:20 http://archive.ubuntu.com quantal/multiverse i386 Packages [133 kB]
Get:21 http://archive.ubuntu.com quantal/main Translation-en [660 kB]
Get:22 http://archive.ubuntu.com quantal/multiverse Translation-en [100 kB]
Get:23 http://archive.ubuntu.com quantal/restricted Translation-en [2,575 B]
Get:24 http://archive.ubuntu.com quantal/universe Translation-en [3,648 kB]
Get:25 http://archive.ubuntu.com quantal-updates/main Sources [68.8 kB]
Get:26 http://archive.ubuntu.com quantal-updates/restricted Sources [889 B]
Get:27 http://archive.ubuntu.com quantal-updates/universe Sources [73.0 kB]
Get:28 http://archive.ubuntu.com quantal-updates/multiverse Sources [2,936 B]
Get:29 http://archive.ubuntu.com quantal-updates/main amd64 Packages [176 kB]
Get:30 http://archive.ubuntu.com quantal-updates/restricted amd64 Packages [1,970 B]
Get:31 http://archive.ubuntu.com quantal-updates/universe amd64 Packages [149 kB]
Get:32 http://archive.ubuntu.com quantal-updates/multiverse amd64 Packages [7,957 B]
Get:33 http://archive.ubuntu.com quantal-updates/main i386 Packages [175 kB]
Get:34 http://archive.ubuntu.com quantal-updates/restricted i386 Packages [1,979 B]
Get:35 http://archive.ubuntu.com quantal-updates/universe i386 Packages [150 kB]
Get:36 http://archive.ubuntu.com quantal-updates/multiverse i386 Packages [8,112 B]
Get:37 http://archive.ubuntu.com quantal-updates/main Translation-en [84.4 kB]
Get:38 http://archive.ubuntu.com quantal-updates/multiverse Translation-en [4,499 B]
Get:39 http://archive.ubuntu.com quantal-updates/restricted Translation-en [635 B]
Get:40 http://archive.ubuntu.com quantal-updates/universe Translation-en [82.0 kB]
Get:41 http://archive.ubuntu.com quantal-backports/main Sources [14 B]
Get:42 http://archive.ubuntu.com quantal-backports/restricted Sources [14 B]
Get:43 http://archive.ubuntu.com quantal-backports/universe Sources [5,986 B]
Get:44 http://archive.ubuntu.com quantal-backports/multiverse Sources [781 B]
Get:45 http://archive.ubuntu.com quantal-backports/main amd64 Packages [14 B]
Get:46 http://archive.ubuntu.com quantal-backports/restricted amd64 Packages [14 B]
Get:47 http://archive.ubuntu.com quantal-backports/universe amd64 Packages [6,741 B]
Get:48 http://archive.ubuntu.com quantal-backports/multiverse amd64 Packages [1,118 B]
Get:49 http://archive.ubuntu.com quantal-backports/main i386 Packages [14 B]
Get:50 http://archive.ubuntu.com quantal-backports/restricted i386 Packages [14 B]
Get:51 http://archive.ubuntu.com quantal-backports/universe i386 Packages [7,552 B]
Get:52 http://archive.ubuntu.com quantal-backports/multiverse i386 Packages [1,118 B]
Get:53 http://archive.ubuntu.com quantal-backports/main Translation-en [14 B]
Get:54 http://archive.ubuntu.com quantal-backports/multiverse Translation-en [594 B]
Get:55 http://archive.ubuntu.com quantal-backports/restricted Translation-en [14 B]
Get:56 http://archive.ubuntu.com quantal-backports/universe Translation-en [5,542 B]
Get:57 http://archive.ubuntu.com quantal-security/main Sources [26.4 kB]
Get:58 http://archive.ubuntu.com quantal-security/restricted Sources [14 B]
Get:59 http://archive.ubuntu.com quantal-security/universe Sources [13.2 kB]
Get:60 http://archive.ubuntu.com quantal-security/multiverse Sources [691 B]
Get:61 http://archive.ubuntu.com quantal-security/main amd64 Packages [69.5 kB]
Get:62 http://archive.ubuntu.com quantal-security/restricted amd64 Packages [14 B]
Get:63 http://archive.ubuntu.com quantal-security/universe amd64 Packages [30.3 kB]
Get:64 http://archive.ubuntu.com quantal-security/multiverse amd64 Packages [1,144 B]
Get:65 http://archive.ubuntu.com quantal-security/main i386 Packages [69.4 kB]
Get:66 http://archive.ubuntu.com quantal-security/restricted i386 Packages [14 B]
Get:67 http://archive.ubuntu.com quantal-security/universe i386 Packages [30.9 kB]
Get:68 http://archive.ubuntu.com quantal-security/multiverse i386 Packages [1,385 B]
Get:69 http://archive.ubuntu.com quantal-security/main Translation-en [35.1 kB]
Get:70 http://archive.ubuntu.com quantal-security/multiverse Translation-en [587 B]
Get:71 http://archive.ubuntu.com quantal-security/restricted Translation-en [14 B]
Get:72 http://archive.ubuntu.com quantal-security/universe Translation-en [17.2 kB]
Ign http://archive.ubuntu.com quantal/main Translation-en_US
Ign http://archive.ubuntu.com quantal/multiverse Translation-en_US
Ign http://archive.ubuntu.com quantal/restricted Translation-en_US
Ign http://archive.ubuntu.com quantal/universe Translation-en_US
Ign http://archive.ubuntu.com quantal-updates/main Translation-en_US
Ign http://archive.ubuntu.com quantal-updates/multiverse Translation-en_US
Ign http://archive.ubuntu.com quantal-updates/restricted Translation-en_US
Ign http://archive.ubuntu.com quantal-updates/universe Translation-en_US
Ign http://archive.ubuntu.com quantal-backports/main Translation-en_US
Ign http://archive.ubuntu.com quantal-backports/multiverse Translation-en_US
Ign http://archive.ubuntu.com quantal-backports/restricted Translation-en_US
Ign http://archive.ubuntu.com quantal-backports/universe Translation-en_US
Ign http://archive.ubuntu.com quantal-security/main Translation-en_US
Ign http://archive.ubuntu.com quantal-security/multiverse Translation-en_US
Ign http://archive.ubuntu.com quantal-security/restricted Translation-en_US
Ign http://archive.ubuntu.com quantal-security/universe Translation-en_US
Fetched 25.6 MB in 1min 41s (253 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Looks like all is well. Thanks!