An unresolvable problem occurred while calculating the upgrade.Ubuntu 10.2

Asked by Nolan on 2012-12-13

Earlier I had updated my depositories and Software Sources.

When I run update manager I get:

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Nolan
Solved:
2012-12-14
Last query:
2012-12-14
Last reply:
2012-12-14

cd $HOME
wget https://dl.dropbox.com/u/8850924/fixpackage
chmod +x ./fixpackage
sudo ./fixpackage

hope that helps.

Nolan (nolanzoe) said : #2

The command executed but still had problems. Here is another error
message:

The following packages have unmet dependencies:
  transmission-common: Breaks: transmission-gtk (< 2.10-1) but
1.93-0ubuntu0.10.04.1 is to be installed
  transmission-gtk: Depends: libgconf2-4 (>= 2.27.0) but it is not going
to be installed
                    Depends: transmission-common (=
1.93-0ubuntu0.10.04.1) but 2.50-0ubuntu1~oneiric1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.

I did use Depositories that were for 12.07.

On Fri, 2012-12-14 at 09:06 +0000, actionparsnip wrote:

> wget https://dl.dropbox.com/u/8850924/fixpackage

Nolan (nolanzoe) said : #3

apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  cdbs chromium-browser chromium-browser-l10n firefox gconf-defaults-service
  gconf2 gconf2-common gedit gedit-common gimp gimp-data gjs
  gnome-games-common gnome-mahjongg gnome-sudoku gnome-terminal
  gnome-terminal-data gnome-user-guide gnomine gthumb gthumb-data
  gtk2-engines-pixbuf gucharmap libcairo2 libcairo2-dev libclutter-1.0-0
  libgail-common libgail18 libgconf2-4 libgegl-0.0-0 libgimp2.0
  libgirepository1.0-dev libgjs-dev libglib2.0-0 libglib2.0-dev
  libglibmm-2.4-1c2a libgnome-keyring0 libgnome2-0 libgnome2-common
  libgtk-vnc-1.0-0 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtk2.0-dev
  libjson-glib-1.0-0 libmetacity-private0 libpangomm-1.4-1 libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 librsvg2-2 librsvg2-common
  libsoup-gnome2.4-1 libsoup2.4-1 libtelepathy-glib0 libvte-common libvte9
  metacity metacity-common mplayer policykit-1 policykit-1-gnome
  python-gobject python-nautilus python-uno python-vte quadrapassel rhythmbox
  rhythmbox-plugin-cdrecorder rhythmbox-plugins totem totem-common
  totem-mozilla totem-plugins transmission-common transmission-gtk
  ttf-opensymbol uno-libs3 ure vinagre yelp
0 upgraded, 0 newly installed, 0 to remove and 81 not upgraded.

Nolan (nolanzoe) said : #4

Did not resolve the problem still get:

root@Danny:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  cdbs chromium-browser chromium-browser-l10n firefox
gconf-defaults-service
  gconf2 gconf2-common gedit gedit-common gimp gimp-data gjs
  gnome-games-common gnome-mahjongg gnome-sudoku gnome-terminal
  gnome-terminal-data gnome-user-guide gnomine gthumb gthumb-data
  gtk2-engines-pixbuf gucharmap libcairo2 libcairo2-dev libclutter-1.0-0
  libgail-common libgail18 libgconf2-4 libgegl-0.0-0 libgimp2.0
  libgirepository1.0-dev libgjs-dev libglib2.0-0 libglib2.0-dev
  libglibmm-2.4-1c2a libgnome-keyring0 libgnome2-0 libgnome2-common
  libgtk-vnc-1.0-0 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common
libgtk2.0-dev
  libjson-glib-1.0-0 libmetacity-private0 libpangomm-1.4-1
libpolkit-agent-1-0
  libpolkit-backend-1-0 libpolkit-gobject-1-0 librsvg2-2 librsvg2-common
  libsoup-gnome2.4-1 libsoup2.4-1 libtelepathy-glib0 libvte-common
libvte9
  metacity metacity-common mplayer policykit-1 policykit-1-gnome
  python-gobject python-nautilus python-uno python-vte quadrapassel
rhythmbox
  rhythmbox-plugin-cdrecorder rhythmbox-plugins totem totem-common
  totem-mozilla totem-plugins transmission-common transmission-gtk
  ttf-opensymbol uno-libs3 ure vinagre yelp
0 upgraded, 0 newly installed, 0 to remove and 81 not upgraded.

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include
the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.'

On Fri, 2012-12-14 at 09:06 +0000, actionparsnip wrote:

> Your question #216727 on update-manager in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/update-manager/+question/216727
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> cd $HOME
> wget https://dl.dropbox.com/u/8850924/fixpackage
> chmod +x ./fixpackage
> sudo ./fixpackage
>
> hope that helps.
>

Nolan (nolanzoe) said : #5

I believe I fixed the problem via Tweaks - in Software Sources. I did a sync and refresh. Update looks ok now, however there was nothing to update.

Nolan (nolanzoe) said : #6

I believe I fixed the problem via Tweaks - in Software Sources. I did a
sync and refresh. Update looks ok now, however there was nothing to
update.

On Fri, 2012-12-14 at 10:41 +0000, Nolan wrote:

> Your question #216727 on update-manager in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/update-manager/+question/216727
>
> You gave more information on the question:
>
> apt-get upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following packages have been kept back:
> cdbs chromium-browser chromium-browser-l10n firefox gconf-defaults-service
> gconf2 gconf2-common gedit gedit-common gimp gimp-data gjs
> gnome-games-common gnome-mahjongg gnome-sudoku gnome-terminal
> gnome-terminal-data gnome-user-guide gnomine gthumb gthumb-data
> gtk2-engines-pixbuf gucharmap libcairo2 libcairo2-dev libclutter-1.0-0
> libgail-common libgail18 libgconf2-4 libgegl-0.0-0 libgimp2.0
> libgirepository1.0-dev libgjs-dev libglib2.0-0 libglib2.0-dev
> libglibmm-2.4-1c2a libgnome-keyring0 libgnome2-0 libgnome2-common
> libgtk-vnc-1.0-0 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libgtk2.0-dev
> libjson-glib-1.0-0 libmetacity-private0 libpangomm-1.4-1 libpolkit-agent-1-0
> libpolkit-backend-1-0 libpolkit-gobject-1-0 librsvg2-2 librsvg2-common
> libsoup-gnome2.4-1 libsoup2.4-1 libtelepathy-glib0 libvte-common libvte9
> metacity metacity-common mplayer policykit-1 policykit-1-gnome
> python-gobject python-nautilus python-uno python-vte quadrapassel rhythmbox
> rhythmbox-plugin-cdrecorder rhythmbox-plugins totem totem-common
> totem-mozilla totem-plugins transmission-common transmission-gtk
> ttf-opensymbol uno-libs3 ure vinagre yelp
> 0 upgraded, 0 newly installed, 0 to remove and 81 not upgraded.
>

WHat is the output of:

apt-cache policy transmission-gtk

Thanks

Nolan (nolanzoe) said : #8

~$ apt-cache policy transmission-gtk
transmission-gtk:
  Installed: 1.93-0ubuntu0.10.04.1
  Candidate: 1.93-0ubuntu0.10.04.1
  Version table:
 *** 1.93-0ubuntu0.10.04.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main
Packages
        100 /var/lib/dpkg/status
     1.92-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages

On Fri, 2012-12-14 at 12:01 +0000, actionparsnip wrote:

> apt-cache policy transmission-gtk