No Printer Interface with 12.04

Asked by Bruce Ludlow on 2012-09-06

Neither "System Settings/Printing" or "Gear Icon/Printers" does anything in Ubuntu 12.04. I upgraded from 10.04 LTS to 12.04 LTS last week. I find no way to view existing printers or to add a new printer. Ubuntu Software Center shows cups, printing and printer installed when I search cups. I am able to print to the printers that were configured in 10.04. During the upgrade there were several dialog boxes where the content was showing as small square boxes for each letter so I closed the dialog box without answering since I did not know what the question was.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu system-config-printer Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-09-07
Last query:
2012-09-07
Last reply:
2012-09-07

Could use:

http://localhost:631

And add it there

Bruce Ludlow (bruce-ludlow) said : #2

Thank you! This worked for me, but is there a way to "fix" the menu options in Ubuntu 12.04?

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | egrep 'cups|cups'

Thanks

Bruce Ludlow (bruce-ludlow) said : #4

Attached is the output from the command. (I added " > output to your
command string.)

On 09/06/2012 02:15 PM, actionparsnip wrote:
> lsb_release -a; uname -a; dpkg -l | egrep 'cups|cups'

Then you missed a character, copy and paste the entire line I gave

Bruce Ludlow (bruce-ludlow) said : #6

Sorry, I'll paste the output to this email.

bruce@BEL:~$ lsb_release -a; uname -a; dpkg -l | egrep 'cups|cups'
LSB Version:
core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux BEL 3.2.0-30-generic #48-Ubuntu SMP Fri Aug 24 16:54:40 UTC 2012
i686 i686 i386 GNU/Linux
ii cups 1.5.3-0ubuntu4 Common UNIX
Printing System(tm) - server
ii cups-bsd 1.5.3-0ubuntu4 Common UNIX
Printing System(tm) - BSD commands
ii cups-client 1.5.3-0ubuntu4 Common
UNIX Printing System(tm) - client programs (SysV)
ii cups-common 1.5.3-0ubuntu4 Common
UNIX Printing System(tm) - common files
ii cups-filters 1.0.18-0ubuntu0.1
OpenPrinting CUPS Filters
rc cups-pk-helper 0.2.1.2-1
PolicyKit helper to configure cups with fine-grained privileges
ii cups-ppdc 1.5.3-0ubuntu4 Common
UNIX Printing System(tm) - PPD manipulation utilities
ii ghostscript-cups 9.05~dfsg-0ubuntu4.1
interpreter for the PostScript language and for PDF - CUPS filters
ii libcups2 1.5.3-0ubuntu4 Common UNIX
Printing System(tm) - Core library
ii libcupscgi1 1.5.3-0ubuntu4 Common
UNIX Printing System(tm) - CGI library
ii libcupsdriver1 1.5.3-0ubuntu4
Common UNIX Printing System(tm) - Driver library
ii libcupsfilters1 1.0.18-0ubuntu0.1
OpenPrinting CUPS Filters - Shared library
ii libcupsimage2 1.5.3-0ubuntu4 Common
UNIX Printing System(tm) - Raster image library
ii libcupsmime1 1.5.3-0ubuntu4 Common
UNIX Printing System(tm) - MIME library
ii libcupsppdc1 1.5.3-0ubuntu4 Common
UNIX Printing System(tm) - PPD manipulation library
ii python-cups 1.9.61-0ubuntu2 Python
bindings for CUPS
ii python-cupshelpers 1.3.8+20120201-0ubuntu8.1
Python modules for printer configuration with CUPS
bruce@BEL:~$

Thanks.

On 09/06/2012 10:25 PM, actionparsnip wrote:
> Your question #207864 on system-config-printer in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/system-config-printer/+question/207864
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Then you missed a character, copy and paste the entire line I gave
>

Only package I have different is cups-ppdc so try installing that. Also try installing system-config-printer-gnome

Bruce Ludlow (bruce-ludlow) said : #8

Both cups-ppdc and system-config-printer-gnome appeared installed in Ubuntu Software Center, so I uninstalled and reinstalled them both and still no function from the Unity System Settings/Printing Icon or the Gear Icon/Printers on the main panel. I guess I will be happy with the http://localhost:631 option as it seems to be AOK!