After installing frostwire I go to open it and I get a error, FrostWire version 4.21.3 Java version 1.6.0_20 from Sun Microsystems Inc. Linux v. 2.6.35-24-generic on i386 Free/total memory: 51388584/96112640 FATAL ERROR! java.lang.ExceptionInInitia

Asked by oocevin on 2010-12-27

I just installed frostwireand when I go to open it it comes up with this error:
FrostWire version 4.21.3
Java version 1.6.0_20 from Sun Microsystems Inc.
Linux v. 2.6.35-24-generic on i386
Free/total memory: 51388584/96112640

FATAL ERROR!

java.lang.ExceptionInInitializerError
 at com.limegroup.gnutella.gui.Initializer$6.run(Unknown Source)
 at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:216)
 at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
 at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
 at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
 at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
Caused by: java.lang.UnsupportedOperationException: The system tray is not supported on the current platform.
 at java.awt.SystemTray.getSystemTray(SystemTray.java:168)
 at com.limegroup.gnutella.gui.notify.TrayNotifier.<init>(Unknown Source)
 at com.limegroup.gnutella.gui.notify.NotifyUserProxy.<init>(Unknown Source)
 at com.limegroup.gnutella.gui.notify.NotifyUserProxy.<clinit>(Unknown Source)
 ... 9 more

-- listing session information --
Current thread: main
Active Threads: 19
Peak Number of Thread: 24
System Load Avg: 1.56
Objects Pending GC: 0
Free Space In Settings: 69476433920
Free Space In Incomplete: 69476433920
Free Space In Downloads: 69476433920
Heap Memory Usage: init = 15892480(15520K) used = 44861192(43809K) committed = 96112640(93860K) max = 492634112(481088K)
Non-Heap Memory Usage: init = 35815424(34976K) used = 35228720(34403K) committed = 43253760(42240K) max = 123731968(120832K)

-- listing threads --
Timer-0: 1
CreationTimeCacheDeserializer: 1
Timer-1: 1
AWT-Shutdown: 1
HostileUpdater Worker: 1
MulticastClerk: 1
Deadlock Detection Thread: 1
CleanStaleDevices: 1
BroadcastClerk: 1
AWT-XAWT: 1
DelayedGUI: 1
main: 1
Thread-6: 1
Thread-4: 1
Image Animator 1: 1
AWT-EventQueue-0: 1
Image Fetcher 0: 1
NIODispatcher: 1
Image Fetcher 3: 1

-- listing properties --
EXTENSIONS_MIGRATE=false
LAST_EXPIRE_TIME=1293487524521
INTRO_NETWORK_LINK=http://www.frostwire.com
COUNTRY=
INTRO_URL=file:///home/tim/.frostwire4.20/overl...
INTRO_LOCAL_LINK=http://www.frostwire.com
CLIENT_ID=745A03CA01F7FD912DB6DC803C251700
CHAT_IRC_NICK=
MAX_QUERY_LENGTH=100
AFTER_SEARCH_URL=file:///home/tim/.frostwire4.20/overl...
AFTER_SEARCH_LOCAL_LINK=http://www.frostclick.com/wp/?from=fw
PORT=42083
EXTENSIONS_TO_SEARCH_FOR=m4a;mpg;tif;mpe;rmvp;ogm;cue;swf;shn;...
INSTALLED=true
MAX_SIM_DOWNLOAD=8
AFTER_SEARCH_NETWORK_LINK=http://www.frostclick.com/wp/?from=fw
CHAT_SERVER=chat.frostwire.com
EXTENSIONS_LIST_UNSHARED=pdf;doc;rtf
WINDOW_Y=180
WINDOW_X=128

**************** Comments from the user ****************
null

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sun-java6 Edit question
Assignee:
No assignee Edit question
Solved by:
GREG T.
Solved:
2010-12-29
Last query:
2010-12-29
Last reply:
2010-12-29
GREG T. (ubuntuer) said : #1

 sun java runtime 6

oocevin (ccct007) said : #2

It's all installed

GREG T. (ubuntuer) said : #3

if you are running lubuntu . it may be missing several things that
ubuntu has installed by default

On 12/27/2010 10:02 PM, oocevin wrote:
> Question #139279 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/139279
>
> Status: Answered => Open
>
> oocevin is still having a problem:
> It's all installed
>

oocevin (ccct007) said : #4

I looked all over for the older one it keeps sending me to the newer one

On 12/28/2010 10:20 PM, marcobra (Marco Braida) wrote:
> Your question #139279 on sun-java6 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/sun-java6/+question/139279
>
> Project: Ubuntu => sun-java6 in ubuntu
>

GREG T. (ubuntuer) said : #5
GREG T. (ubuntuer) said : #6

use the debian version for lubuntu
http://www.frostwire.com/downloads

Best GREG T. (ubuntuer) said : #7

i found how to get it installed .... remove open jdk java 6 . and it`s
supports , then download and install .

On 12/28/2010 10:20 PM, marcobra (Marco Braida) wrote:
> Question #139279 on sun-java6 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/sun-java6/+question/139279
>
> Project: Ubuntu => sun-java6 in ubuntu
>

oocevin (ccct007) said : #8

Thanks GREG T., that solved my question.